aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/lidarr
diff options
context:
space:
mode:
authorKeith Chiem <keith.chiem@gmail.com>2023-09-24 17:16:28 +0000
committerDries Michiels <driesm@FreeBSD.org>2023-09-24 17:24:33 +0000
commit5cf4242d5f468f1663da0df17f0b18b6edd6f581 (patch)
tree859abfcf4abf28709882577771d82d54dedea2be /net-p2p/lidarr
parent6c696ba462f0fe954461370f664888f9ddaeb61c (diff)
downloadports-5cf4242d5f468f1663da0df17f0b18b6edd6f581.tar.gz
ports-5cf4242d5f468f1663da0df17f0b18b6edd6f581.zip
.NET ports: improve IPv6 detection in rc script
An IPv6 address on the localhost does not mean a jail has IPv6. Also remove two credit lines as he is now credited in the git log. PR: 273542 Reported by: michiel@vanbaak.eu Approved by: michiel@vanbaak.eu (maintainer)
Diffstat (limited to 'net-p2p/lidarr')
-rw-r--r--net-p2p/lidarr/Makefile1
-rw-r--r--net-p2p/lidarr/files/lidarr.in2
2 files changed, 2 insertions, 1 deletions
diff --git a/net-p2p/lidarr/Makefile b/net-p2p/lidarr/Makefile
index 567b970bc5a5..d11a95c98121 100644
--- a/net-p2p/lidarr/Makefile
+++ b/net-p2p/lidarr/Makefile
@@ -1,5 +1,6 @@
PORTNAME= lidarr
DISTVERSION= 1.3.5.3530
+PORTREVISION= 1
CATEGORIES= net-p2p
MASTER_SITES= https://github.com/lidarr/Lidarr/releases/download/v${PORTVERSION}/
DISTNAME= Lidarr.master.${DISTVERSION}.freebsd-core-x64
diff --git a/net-p2p/lidarr/files/lidarr.in b/net-p2p/lidarr/files/lidarr.in
index db723160de4a..78f689ae38f4 100644
--- a/net-p2p/lidarr/files/lidarr.in
+++ b/net-p2p/lidarr/files/lidarr.in
@@ -43,7 +43,7 @@ start_precmd=${name}_precmd
# .NET 6+ use dual mode sockets to avoid the separate AF handling.
# disable .NET use of V6 if no ipv6 is configured.
# See https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=259194#c17
- ifconfig | grep -q inet6
+ ifconfig -a -u -G lo | grep -q inet6
if [ $? == 1 ]; then
export DOTNET_SYSTEM_NET_DISABLEIPV6=1
fi