aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/microdc2
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-03-07 14:47:51 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-03-07 14:47:51 +0000
commit6128b6bd8422afc98df7804a20c1785061652c3b (patch)
tree2f209a17aeb3496481c84700b74dff548e27c763 /net-p2p/microdc2
parent06b21dbe6514eb2f957f50530ddb71658d312502 (diff)
downloadports-6128b6bd8422afc98df7804a20c1785061652c3b.tar.gz
ports-6128b6bd8422afc98df7804a20c1785061652c3b.zip
- Do not build local libbzip2.a, link to the one from the base
- Convert libxml2-related REINPLACE_CMD to patch due to the above - Augment port description text
Notes
Notes: svn path=/head/; revision=347395
Diffstat (limited to 'net-p2p/microdc2')
-rw-r--r--net-p2p/microdc2/Makefile3
-rw-r--r--net-p2p/microdc2/files/patch-configure28
-rw-r--r--net-p2p/microdc2/files/patch-src-Makefile.in31
-rw-r--r--net-p2p/microdc2/pkg-descr22
4 files changed, 76 insertions, 8 deletions
diff --git a/net-p2p/microdc2/Makefile b/net-p2p/microdc2/Makefile
index 0615904ce607..d3d1d409187c 100644
--- a/net-p2p/microdc2/Makefile
+++ b/net-p2p/microdc2/Makefile
@@ -24,7 +24,4 @@ OPTIONS_SUB= yes
NLS_USES= gettext
NLS_CONFIGURE_OFF= --disable-nls
-post-patch:
- @${REINPLACE_CMD} -e 's,-ge 2616,\\> 2616,' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/net-p2p/microdc2/files/patch-configure b/net-p2p/microdc2/files/patch-configure
new file mode 100644
index 000000000000..0af2171c7f84
--- /dev/null
+++ b/net-p2p/microdc2/files/patch-configure
@@ -0,0 +1,28 @@
+--- configure.orig 2006-12-25 02:45:07 +0800
++++ configure
+@@ -21508,7 +21508,7 @@ cat >>confdefs.h <<\_ACEOF
+ _ACEOF
+
+ fi
+- if test $LIBXML2_VERSION -ge 2616; then
++ if test $LIBXML2_VERSION \> 2615; then
+ cat >>confdefs.h <<\_ACEOF
+ #define HAVE_LIBXML2 1
+ _ACEOF
+@@ -22197,7 +22197,7 @@ fi
+ # Checks for library functions
+
+ # Output generation
+-ac_config_files="$ac_config_files Makefile po/Makefile.in lib/Makefile src/Makefile src/common/Makefile src/bzip2/Makefile src/tth/Makefile rpm/microdc.spec"
++ac_config_files="$ac_config_files Makefile po/Makefile.in lib/Makefile src/Makefile src/common/Makefile src/tth/Makefile rpm/microdc.spec"
+
+ ac_config_files="$ac_config_files slackware/microdc.SlackBuild"
+
+@@ -22793,7 +22793,6 @@ do
+ "lib/Makefile") CONFIG_FILES="$CONFIG_FILES lib/Makefile" ;;
+ "src/Makefile") CONFIG_FILES="$CONFIG_FILES src/Makefile" ;;
+ "src/common/Makefile") CONFIG_FILES="$CONFIG_FILES src/common/Makefile" ;;
+- "src/bzip2/Makefile") CONFIG_FILES="$CONFIG_FILES src/bzip2/Makefile" ;;
+ "src/tth/Makefile") CONFIG_FILES="$CONFIG_FILES src/tth/Makefile" ;;
+ "rpm/microdc.spec") CONFIG_FILES="$CONFIG_FILES rpm/microdc.spec" ;;
+ "slackware/microdc.SlackBuild") CONFIG_FILES="$CONFIG_FILES slackware/microdc.SlackBuild" ;;
diff --git a/net-p2p/microdc2/files/patch-src-Makefile.in b/net-p2p/microdc2/files/patch-src-Makefile.in
new file mode 100644
index 000000000000..efdae40b8cd5
--- /dev/null
+++ b/net-p2p/microdc2/files/patch-src-Makefile.in
@@ -0,0 +1,31 @@
+--- src/Makefile.in.orig 2006-12-25 02:44:47 +0800
++++ src/Makefile.in
+@@ -97,7 +97,7 @@ am_microdc2_OBJECTS = command.$(OBJEXT)
+ charsets.$(OBJEXT)
+ microdc2_OBJECTS = $(am_microdc2_OBJECTS)
+ am__DEPENDENCIES_1 =
+-microdc2_DEPENDENCIES = common/libcommon.a bzip2/libbzip2.a \
++microdc2_DEPENDENCIES = common/libcommon.a \
+ tth/libtth.a ../lib/libgnu.a $(am__DEPENDENCIES_1) \
+ $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
+ $(am__DEPENDENCIES_1)
+@@ -246,7 +246,7 @@ sbindir = @sbindir@
+ sharedstatedir = @sharedstatedir@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+-SUBDIRS = common bzip2 tth
++SUBDIRS = common tth
+ AM_CFLAGS = \
+ -Wall \
+ $(LIBXML2_CFLAGS)
+@@ -288,9 +288,9 @@ tthsum_SOURCES = \
+ # microdc_tth.c
+ microdc2_LDADD = \
+ common/libcommon.a \
+- bzip2/libbzip2.a \
+ tth/libtth.a \
+ ../lib/libgnu.a \
++ -lbz2 \
+ $(READLINE_LIBS) \
+ $(LIBINTL) \
+ $(LIBICONV) \
diff --git a/net-p2p/microdc2/pkg-descr b/net-p2p/microdc2/pkg-descr
index f153e216de8f..d43253c67af2 100644
--- a/net-p2p/microdc2/pkg-descr
+++ b/net-p2p/microdc2/pkg-descr
@@ -1,7 +1,19 @@
-microdc is a command-line based Direct Connect client that uses the
-GNU Readline library for user interaction. It was developed from
-ground up and does not depend on any other program. Despite the
-command-line user interface, microdc was designed to be user
-friendly and simple to use.
+microdc is a command-line based Direct Connect client written in C by Oskar
+Liljeblad and designed to build and run on modern POSIX compatible systems.
+It uses GNU Readline library for user interaction. Despite the command-line
+user interface, microdc is quite user friendly and simple to use.
+
+microdc2 is a future improvement (fork) of the microdc based on Oskar's code
+version 0.11.0. After version 0.12.0 the project was renamed to microdc2 on
+Oskar's request.
+
+Features of microdc2 include:
+
+ - Nearly full support of the original Direct Connect protocol
+ - GNU Readline support for command line editing and history
+ - Sensible tab-completion of commands, user names, local files, remote
+ files, speed names, and connection names
+ - One process per connection for optimal transfer rates
+ - Small memory footprint
WWW: http://corsair626.no-ip.org/microdc/