aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/mktorrent
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-09-11 00:11:48 +0000
committerJohn Marino <marino@FreeBSD.org>2016-09-11 00:11:48 +0000
commitca47aed1c80b017fe4926a3f68765f9624ed5d2a (patch)
tree3bbfa35dee2d4fdace4751d9f5e6ea271941d5f2 /net-p2p/mktorrent
parentfdd36b8efc1f0660965e731c1bba9c2a3ff92e44 (diff)
downloadports-ca47aed1c80b017fe4926a3f68765f9624ed5d2a.tar.gz
ports-ca47aed1c80b017fe4926a3f68765f9624ed5d2a.zip
net-p2p/mktorrent: Add SSL flags
Approved by: SSL blanket
Notes
Notes: svn path=/head/; revision=421759
Diffstat (limited to 'net-p2p/mktorrent')
-rw-r--r--net-p2p/mktorrent/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net-p2p/mktorrent/Makefile b/net-p2p/mktorrent/Makefile
index 851f4df5ce5b..995a3cb4580c 100644
--- a/net-p2p/mktorrent/Makefile
+++ b/net-p2p/mktorrent/Makefile
@@ -24,6 +24,10 @@ THREADS_DESC= Enable support for pthreads
OPENSSL_DESC= Use OpenSSL for hashing
HASHCHECK_DESC= Verify file hashes
+OPENSSL_USES= ssl
+OPENSSL_CFLAGS= -I${OPENSSLINC}
+OPENSSL_LDFLAGS= -L${OPENSSLLIB}
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MTHREADS}
@@ -32,7 +36,6 @@ MAKE_FLAGS+= USE_PTHREADS=1
.if ${PORT_OPTIONS:MOPENSSL}
MAKE_FLAGS+= USE_OPENSSL=1
-USE_OPENSSL= yes
.endif
.if ! ${PORT_OPTIONS:MHASHCHECK}