aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/mktorrent
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-03 21:15:43 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-03 21:15:43 +0000
commitdbe34e1d761780cffd61813eda07b50c3464583f (patch)
tree4d1336a5753b02b38713598b254666c9ac5c85c8 /net-p2p/mktorrent
parentb3f92a36547bcc4b143ecac25364db27b856fe84 (diff)
downloadports-dbe34e1d761780cffd61813eda07b50c3464583f.tar.gz
ports-dbe34e1d761780cffd61813eda07b50c3464583f.zip
Fix build with bmake
While here convert to new options framework
Notes
Notes: svn path=/head/; revision=317259
Diffstat (limited to 'net-p2p/mktorrent')
-rw-r--r--net-p2p/mktorrent/Makefile26
1 files changed, 14 insertions, 12 deletions
diff --git a/net-p2p/mktorrent/Makefile b/net-p2p/mktorrent/Makefile
index 6cff3bd2f0e0..3ef50017c1a0 100644
--- a/net-p2p/mktorrent/Makefile
+++ b/net-p2p/mktorrent/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mktorrent
-# Date created: 9 May 2010
-# Whom: Damian Gerow <dgerow@afflictions.org>
-#
+# Created by: Damian Gerow <dgerow@afflictions.org>
# $FreeBSD$
-#
PORTNAME= mktorrent
PORTVERSION= 1.0
@@ -11,29 +7,35 @@ CATEGORIES= net-p2p
MASTER_SITES= SF
MAINTAINER= dgerow@afflictions.org
-COMMENT= A command-line utility for creating BitTorrent metainfo files
+COMMENT= Command-line utility for creating BitTorrent metainfo files
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+.else
MAKEFILE= BSDmakefile
+.endif
MAKE_FLAGS= USE_LONG_OPTIONS=1
PLIST_FILES= bin/mktorrent
-OPTIONS= THREADS "Enable support for pthreads" on \
- OPENSSL "Use OpenSSL for hashing" on \
- HASHCHECK "Verify file hashes" on
+OPTIONS_DEFINE= THREADS OPENSSL HASHCHECK
+OPTIONS_DEFAULT= THREADS OPENSSL HASHCHECK
+THREADS_DESC= Enable support for pthreads
+OPENSSL_DESC= Use OpenSSL for hashing
+HASHCHECK_DESC= Verify file hashes
.include <bsd.port.options.mk>
-.if !defined(WITHOUT_THREADS)
+.if ${PORT_OPTIONS:MTHREADS}
MAKE_FLAGS+= USE_PTHREADS=1
.endif
-.if !defined(WITHOUT_OPENSSL)
+.if ${PORT_OPTIONS:MOPENSSL}
MAKE_FLAGS+= USE_OPENSSL=1
USE_OPENSSL= yes
.endif
-.if defined(WITHOUT_HASHCHECK)
+.if ! ${PORT_OPTIONS:MHASHCHECK}
MAKE_FLAGS+= NO_HASH_CHECK=1
.endif