aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/monero-cli/Makefile
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2018-10-12 20:46:32 +0000
committerVasil Dimov <vd@FreeBSD.org>2018-10-12 20:46:32 +0000
commit1f0f547938101bcf896b2ae5a3c0600cf4544574 (patch)
tree155c46ad712a58998442f68f2b3138bf50a4dc9f /net-p2p/monero-cli/Makefile
parent53dd3b73ea571f3f217ab5b3b4d4bfcdd808db6c (diff)
downloadports-1f0f547938101bcf896b2ae5a3c0600cf4544574.tar.gz
ports-1f0f547938101bcf896b2ae5a3c0600cf4544574.zip
Notes
Diffstat (limited to 'net-p2p/monero-cli/Makefile')
-rw-r--r--net-p2p/monero-cli/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/net-p2p/monero-cli/Makefile b/net-p2p/monero-cli/Makefile
index 50bd1b9de34f..2851512f0961 100644
--- a/net-p2p/monero-cli/Makefile
+++ b/net-p2p/monero-cli/Makefile
@@ -3,8 +3,8 @@
PORTNAME= monero-cli
# To build from an arbitrary git commit comment the following two lines
-PORTVERSION= 0.12.3.0
-PORTREVISION= 3
+PORTVERSION= 0.13.0.2
+PORTREVISION= 0
DISTVERSIONPREFIX= v
# and uncomment the following two lines
#PORTVERSION= 0
@@ -33,6 +33,7 @@ LIB_DEPENDS= \
libminiupnpc.so:net/miniupnpc \
libnorm.so:net/norm \
libpgm.so:net/openpgm \
+ libsodium.so:security/libsodium \
libunbound.so:dns/unbound \
libunwind.so:devel/libunwind \
libzmq.so:net/libzmq4
@@ -75,7 +76,8 @@ LD_EMULATION= elf32ppc
LD_EMULATION= elf64ppc
.endif
-CMAKE_ARGS+= -DLD_RAW_FLAGS:STRING=-m${LD_EMULATION}
+CMAKE_ARGS+= -DLD_RAW_FLAGS:STRING=-m${LD_EMULATION} \
+ -DMANUAL_SUBMODULES:BOOL=ON
.endif
USE_RC_SUBR= monerod
@@ -84,7 +86,9 @@ USERS= monero
GROUPS= monero
PLIST_FILES= \
+ bin/monero-blockchain-ancestry \
bin/monero-blockchain-blackball \
+ bin/monero-blockchain-depth \
bin/monero-blockchain-export \
bin/monero-blockchain-import \
bin/monero-blockchain-usage \