aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/monero-cli
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2019-04-15 17:27:54 +0000
committerVasil Dimov <vd@FreeBSD.org>2019-04-15 17:27:54 +0000
commite6a55266a44de8caec6bd5d0dea73f724888b5d0 (patch)
tree2837cf8b566a2070d52f3f40195553641928292a /net-p2p/monero-cli
parent2c118450a8beccdfb9ba9db3c69f3eaa25e4bf00 (diff)
downloadports-e6a55266a44de8caec6bd5d0dea73f724888b5d0.tar.gz
ports-e6a55266a44de8caec6bd5d0dea73f724888b5d0.zip
net-p2p/monero-cli: Apply all changes from upstream after 0.14.0.2
Use git commit id 1f809e7485fc3085 instead of tag v0.14.0.2. This fixes the compilation with boost 1.70. PR: 236597
Notes
Notes: svn path=/head/; revision=499035
Diffstat (limited to 'net-p2p/monero-cli')
-rw-r--r--net-p2p/monero-cli/Makefile9
-rw-r--r--net-p2p/monero-cli/distinfo6
-rw-r--r--net-p2p/monero-cli/files/patch-src_crypto_CMakeLists.txt11
3 files changed, 9 insertions, 17 deletions
diff --git a/net-p2p/monero-cli/Makefile b/net-p2p/monero-cli/Makefile
index 07e0b87be0f3..c44792a2f0d4 100644
--- a/net-p2p/monero-cli/Makefile
+++ b/net-p2p/monero-cli/Makefile
@@ -5,8 +5,8 @@ PORTNAME= monero-cli
# To build from an arbitrary git commit comment PORTVERSION and PORTREVISION (if present)
PORTVERSION= 0.14.0.2
DISTVERSIONPREFIX= v
-PORTREVISION= 2
-# and uncomment the following two lines
+PORTREVISION= 3
+# and uncomment the following two lines (use for example -git-HEAD or -git-b6420e1)
#PORTVERSION= 0
#PKGNAMESUFFIX= -git-HEAD
CATEGORIES= net-p2p finance
@@ -16,7 +16,6 @@ COMMENT= Private, secure, untraceable, decentralised digital currency (CLI)
LICENSE= BSD3CLAUSE
-BROKEN= fails to build with boost 1.70, see bug 236597
BROKEN_aarch64= fails to compile: the clang compiler does not support -march=native
BROKEN_armv6= fails to compile: the clang compiler does not support -march=native
BROKEN_armv7= fails to compile: the clang compiler does not support -march=native
@@ -45,6 +44,7 @@ USE_GITHUB= yes
GH_ACCOUNT= monero-project
GH_PROJECT= monero
+GH_TAGNAME= 1f809e7485fc3085
.if defined(PKGNAMESUFFIX)
GH_TAGNAME= ${PKGNAMESUFFIX:C/-git-//}
.endif
@@ -98,6 +98,9 @@ PLIST_FILES= \
bin/monero-blockchain-export \
bin/monero-blockchain-import \
bin/monero-blockchain-mark-spent-outputs \
+ bin/monero-blockchain-prune \
+ bin/monero-blockchain-prune-known-spent-data \
+ bin/monero-blockchain-stats \
bin/monero-blockchain-usage \
bin/monero-gen-trusted-multisig \
bin/monero-wallet-cli \
diff --git a/net-p2p/monero-cli/distinfo b/net-p2p/monero-cli/distinfo
index c7bd5a231d4c..30a86e5d7452 100644
--- a/net-p2p/monero-cli/distinfo
+++ b/net-p2p/monero-cli/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1552137551
-SHA256 (monero-project-monero-v0.14.0.2_GH0.tar.gz) = 90a0a9395fe911378a2e1e495df4cdb6b03cb7baaae63b8dda1c8ae827bb5385
-SIZE (monero-project-monero-v0.14.0.2_GH0.tar.gz) = 8659788
+TIMESTAMP = 1555342508
+SHA256 (monero-project-monero-v0.14.0.2-1f809e7485fc3085_GH0.tar.gz) = ea53a95cba71e5d932e214f2f713c7a83f50d39004ba60aa054a01f92b8af7d4
+SIZE (monero-project-monero-v0.14.0.2-1f809e7485fc3085_GH0.tar.gz) = 9011540
diff --git a/net-p2p/monero-cli/files/patch-src_crypto_CMakeLists.txt b/net-p2p/monero-cli/files/patch-src_crypto_CMakeLists.txt
deleted file mode 100644
index cf65b737f9b2..000000000000
--- a/net-p2p/monero-cli/files/patch-src_crypto_CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/crypto/CMakeLists.txt.orig 2019-03-07 13:25:34 UTC
-+++ src/crypto/CMakeLists.txt
-@@ -48,7 +48,7 @@ set(crypto_sources
- CryptonightR_JIT.c
- tree-hash.c)
-
--if(ARCH_ID STREQUAL "x86_64" OR ARCH_ID STREQUAL "x86-64")
-+if(ARCH_ID STREQUAL "x86_64" OR ARCH_ID STREQUAL "x86-64" OR ARCH_ID STREQUAL "amd64")
- list(APPEND crypto_sources CryptonightR_template.S)
- endif()
-