aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/py-bittorrent-devel/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2006-02-23 01:07:17 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2006-02-23 01:07:17 +0000
commit9844966798cc72ebd43849fa24fb6af436a43b7e (patch)
treec3858acd07da9b15471a6d7e4a5fe6be6442ffd3 /net-p2p/py-bittorrent-devel/Makefile
parent94af970bb0565cd16c5cad90ab11d6f87539f4ef (diff)
downloadports-9844966798cc72ebd43849fa24fb6af436a43b7e.tar.gz
ports-9844966798cc72ebd43849fa24fb6af436a43b7e.zip
Notes
Diffstat (limited to 'net-p2p/py-bittorrent-devel/Makefile')
-rw-r--r--net-p2p/py-bittorrent-devel/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/net-p2p/py-bittorrent-devel/Makefile b/net-p2p/py-bittorrent-devel/Makefile
index 47c4310b0525..9829e1432d30 100644
--- a/net-p2p/py-bittorrent-devel/Makefile
+++ b/net-p2p/py-bittorrent-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= BitTorrent
PORTVERSION= 4.4.0
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES?= net-p2p python
MASTER_SITES= http://www.bittorrent.com/dl/ \
@@ -22,8 +22,6 @@ COMMENT?= A peer-to-peer tool for distributing files written in Python
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/dns/__init__.py:${PORTSDIR}/dns/py-dnspython \
${PYTHON_SITELIBDIR}/Crypto/__init__.py:${PORTSDIR}/security/py-pycrypto
-BROKEN= Incomplete pkg-plist
-
USE_GETTEXT= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
@@ -95,14 +93,13 @@ PLIST_FILES+= \
share/pixmaps/BitTorrent/logo/bittorrent_32.png \
share/pixmaps/BitTorrent/logo/bittorrent_96.png
-PLIST_DIRS+= \
- share/pixmaps/BitTorrent/logo \
- share/pixmaps/BitTorrent/icons/old \
- share/pixmaps/BitTorrent/icons/default \
- share/pixmaps/BitTorrent/icons \
- share/pixmaps/BitTorrent
+PLIST_SUB+= \
+ GUI=""
.else
EXTRA_PATCHES+= ${FILESDIR}/extra-nogui-patch-setup.py
+
+PLIST_SUB+= \
+ GUI="@comment "
.endif
# required for PSYCO
.ifndef(WITHOUT_PSYCO)