aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/qbittorrent
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /net-p2p/qbittorrent
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'net-p2p/qbittorrent')
-rw-r--r--net-p2p/qbittorrent/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/net-p2p/qbittorrent/Makefile b/net-p2p/qbittorrent/Makefile
index 782c16dcca5c..0e79fa8ecf11 100644
--- a/net-p2p/qbittorrent/Makefile
+++ b/net-p2p/qbittorrent/Makefile
@@ -24,16 +24,15 @@ default_LIB_DEPENDS= libGeoIP.so:net/GeoIP
nox_PKGNAMESUFFIX= -nox
nox_PLIST= ${NONEXISTENT}
-USES= compiler:c++11-lib pkgconfig tar:xz
+USES= compiler:c++11-lib pkgconfig qmake:no_env qt:5 tar:xz
GNU_CONFIGURE= yes
-USE_QT5= core network xml buildtools_build linguisttools_build qmake_build
+USE_QT= core network xml buildtools_build linguisttools_build qmake_build
CONFIGURE_ARGS= CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
-QT_NONSTANDARD= yes
DESTDIRNAME= INSTALL_ROOT
.if ${FLAVOR} == default
USES+= desktop-file-utils
-USE_QT5+= concurrent gui svg widgets
+USE_QT+= concurrent gui svg widgets
USE_GL= gl
.endif
@@ -50,7 +49,7 @@ OPTIONS_DEFAULT= DBUS
DEBUG_CONFIGURE_ENABLE= debug
DBUS_CONFIGURE_ENABLE= qt-dbus
-DBUS_USE= qt5=dbus
+DBUS_USE= qt=dbus
PORTDOCS= AUTHORS Changelog README.md