aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/qtum
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2018-09-15 19:33:16 +0000
committerVasil Dimov <vd@FreeBSD.org>2018-09-15 19:33:16 +0000
commit294a55568d7508c529f741f61b411b774f579f56 (patch)
tree377f34757fd748163023a37b66b3d155f1c50c28 /net-p2p/qtum
parentdf326ce673eeb912ee752d9a9ed1775727997261 (diff)
downloadports-294a55568d7508c529f741f61b411b774f579f56.tar.gz
ports-294a55568d7508c529f741f61b411b774f579f56.zip
net-p2p/qtum: Upgrade from 0.15.3 to 0.16.0
Notes
Notes: svn path=/head/; revision=479844
Diffstat (limited to 'net-p2p/qtum')
-rw-r--r--net-p2p/qtum/Makefile3
-rw-r--r--net-p2p/qtum/distinfo6
-rw-r--r--net-p2p/qtum/files/patch-src_wallet_wallet.h263
3 files changed, 4 insertions, 268 deletions
diff --git a/net-p2p/qtum/Makefile b/net-p2p/qtum/Makefile
index b050dcec07a5..317e4e8fed45 100644
--- a/net-p2p/qtum/Makefile
+++ b/net-p2p/qtum/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= qtum
-PORTVERSION= 0.15.3
-PORTREVISION= 1
+PORTVERSION= 0.16.0
DISTVERSIONPREFIX= mainnet-ignition-v
CATEGORIES= net-p2p finance
diff --git a/net-p2p/qtum/distinfo b/net-p2p/qtum/distinfo
index be39ccd1f3ec..5ec7ea608385 100644
--- a/net-p2p/qtum/distinfo
+++ b/net-p2p/qtum/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1533740100
-SHA256 (qtumproject-qtum-mainnet-ignition-v0.15.3_GH0.tar.gz) = 0ef0ea73e563048797b1ff08b689a5469fee16faf803a172d155018d8b0ef030
-SIZE (qtumproject-qtum-mainnet-ignition-v0.15.3_GH0.tar.gz) = 13182417
+TIMESTAMP = 1536992752
+SHA256 (qtumproject-qtum-mainnet-ignition-v0.16.0_GH0.tar.gz) = cd35b3aa8537a76d5fa188bd26011bea9084572c33e72a0e584ced75683808b5
+SIZE (qtumproject-qtum-mainnet-ignition-v0.16.0_GH0.tar.gz) = 12229638
SHA256 (qtumproject-cpp-eth-qtum-d6081ecc98e3c5f4701363_GH0.tar.gz) = 62c858543510aaf656ce0a247e26fbce4a9b11d1fa424f40e9ff0fdc822b4b34
SIZE (qtumproject-cpp-eth-qtum-d6081ecc98e3c5f4701363_GH0.tar.gz) = 1114149
diff --git a/net-p2p/qtum/files/patch-src_wallet_wallet.h b/net-p2p/qtum/files/patch-src_wallet_wallet.h
deleted file mode 100644
index 929040d9f515..000000000000
--- a/net-p2p/qtum/files/patch-src_wallet_wallet.h
+++ /dev/null
@@ -1,263 +0,0 @@
---- src/wallet/wallet.h.orig 2018-05-25 13:32:42 UTC
-+++ src/wallet/wallet.h
-@@ -668,7 +668,130 @@ class CAccountingEntry (private)
- std::vector<char> _ssExtra;
- };
-
-+/** Contract book data */
-+class CContractBookData
-+{
-+public:
-+ std::string name;
-+ std::string abi;
-
-+ CContractBookData()
-+ {}
-+};
-+
-+class CTokenTx
-+{
-+public:
-+ static const int CURRENT_VERSION=1;
-+ int nVersion;
-+ std::string strContractAddress;
-+ std::string strSenderAddress;
-+ std::string strReceiverAddress;
-+ uint256 nValue;
-+ uint256 transactionHash;
-+
-+ // Wallet data for token transaction
-+ int64_t nCreateTime;
-+ uint256 blockHash;
-+ int64_t blockNumber;
-+ std::string strLabel;
-+
-+ CTokenTx()
-+ {
-+ SetNull();
-+ }
-+
-+ ADD_SERIALIZE_METHODS;
-+
-+ template <typename Stream, typename Operation>
-+ inline void SerializationOp(Stream& s, Operation ser_action) {
-+ if (!(s.GetType() & SER_GETHASH))
-+ {
-+ READWRITE(nVersion);
-+ READWRITE(nCreateTime);
-+ READWRITE(blockHash);
-+ READWRITE(blockNumber);
-+ READWRITE(LIMITED_STRING(strLabel, 65536));
-+ }
-+ READWRITE(strContractAddress);
-+ READWRITE(strSenderAddress);
-+ READWRITE(strReceiverAddress);
-+ READWRITE(nValue);
-+ READWRITE(transactionHash);
-+ }
-+
-+ void SetNull()
-+ {
-+ nVersion = CTokenTx::CURRENT_VERSION;
-+ nCreateTime = 0;
-+ strContractAddress = "";
-+ strSenderAddress = "";
-+ strReceiverAddress = "";
-+ nValue.SetNull();
-+ transactionHash.SetNull();
-+ blockHash.SetNull();
-+ blockNumber = -1;
-+ strLabel = "";
-+ }
-+
-+ uint256 GetHash() const;
-+};
-+
-+class CTokenInfo
-+{
-+public:
-+ static const int CURRENT_VERSION=1;
-+ int nVersion;
-+ std::string strContractAddress;
-+ std::string strTokenName;
-+ std::string strTokenSymbol;
-+ uint8_t nDecimals;
-+ std::string strSenderAddress;
-+
-+ // Wallet data for token transaction
-+ int64_t nCreateTime;
-+ uint256 blockHash;
-+ int64_t blockNumber;
-+
-+ CTokenInfo()
-+ {
-+ SetNull();
-+ }
-+
-+ ADD_SERIALIZE_METHODS;
-+
-+ template <typename Stream, typename Operation>
-+ inline void SerializationOp(Stream& s, Operation ser_action) {
-+ if (!(s.GetType() & SER_GETHASH))
-+ {
-+ READWRITE(nVersion);
-+ READWRITE(nCreateTime);
-+ READWRITE(strTokenName);
-+ READWRITE(strTokenSymbol);
-+ READWRITE(blockHash);
-+ READWRITE(blockNumber);
-+ }
-+ READWRITE(nDecimals);
-+ READWRITE(strContractAddress);
-+ READWRITE(strSenderAddress);
-+ }
-+
-+ void SetNull()
-+ {
-+ nVersion = CTokenInfo::CURRENT_VERSION;
-+ nCreateTime = 0;
-+ strContractAddress = "";
-+ strTokenName = "";
-+ strTokenSymbol = "";
-+ nDecimals = 0;
-+ strSenderAddress = "";
-+ blockHash.SetNull();
-+ blockNumber = -1;
-+ }
-+
-+ uint256 GetHash() const;
-+};
-+
- /**
- * A CWallet is an extension of a keystore, which also maintains a set of transactions and balances,
- * and provides the ability to create new transactions.
-@@ -1304,129 +1427,5 @@ bool CWallet::DummySignTx(CMutableTransaction &txNew,
- }
- return true;
- }
--
--class CTokenInfo
--{
--public:
-- static const int CURRENT_VERSION=1;
-- int nVersion;
-- std::string strContractAddress;
-- std::string strTokenName;
-- std::string strTokenSymbol;
-- uint8_t nDecimals;
-- std::string strSenderAddress;
--
-- // Wallet data for token transaction
-- int64_t nCreateTime;
-- uint256 blockHash;
-- int64_t blockNumber;
--
-- CTokenInfo()
-- {
-- SetNull();
-- }
--
-- ADD_SERIALIZE_METHODS;
--
-- template <typename Stream, typename Operation>
-- inline void SerializationOp(Stream& s, Operation ser_action) {
-- if (!(s.GetType() & SER_GETHASH))
-- {
-- READWRITE(nVersion);
-- READWRITE(nCreateTime);
-- READWRITE(strTokenName);
-- READWRITE(strTokenSymbol);
-- READWRITE(blockHash);
-- READWRITE(blockNumber);
-- }
-- READWRITE(nDecimals);
-- READWRITE(strContractAddress);
-- READWRITE(strSenderAddress);
-- }
--
-- void SetNull()
-- {
-- nVersion = CTokenInfo::CURRENT_VERSION;
-- nCreateTime = 0;
-- strContractAddress = "";
-- strTokenName = "";
-- strTokenSymbol = "";
-- nDecimals = 0;
-- strSenderAddress = "";
-- blockHash.SetNull();
-- blockNumber = -1;
-- }
--
-- uint256 GetHash() const;
--};
--
--class CTokenTx
--{
--public:
-- static const int CURRENT_VERSION=1;
-- int nVersion;
-- std::string strContractAddress;
-- std::string strSenderAddress;
-- std::string strReceiverAddress;
-- uint256 nValue;
-- uint256 transactionHash;
--
-- // Wallet data for token transaction
-- int64_t nCreateTime;
-- uint256 blockHash;
-- int64_t blockNumber;
-- std::string strLabel;
--
-- CTokenTx()
-- {
-- SetNull();
-- }
--
-- ADD_SERIALIZE_METHODS;
--
-- template <typename Stream, typename Operation>
-- inline void SerializationOp(Stream& s, Operation ser_action) {
-- if (!(s.GetType() & SER_GETHASH))
-- {
-- READWRITE(nVersion);
-- READWRITE(nCreateTime);
-- READWRITE(blockHash);
-- READWRITE(blockNumber);
-- READWRITE(LIMITED_STRING(strLabel, 65536));
-- }
-- READWRITE(strContractAddress);
-- READWRITE(strSenderAddress);
-- READWRITE(strReceiverAddress);
-- READWRITE(nValue);
-- READWRITE(transactionHash);
-- }
--
-- void SetNull()
-- {
-- nVersion = CTokenTx::CURRENT_VERSION;
-- nCreateTime = 0;
-- strContractAddress = "";
-- strSenderAddress = "";
-- strReceiverAddress = "";
-- nValue.SetNull();
-- transactionHash.SetNull();
-- blockHash.SetNull();
-- blockNumber = -1;
-- strLabel = "";
-- }
--
-- uint256 GetHash() const;
--};
--
--/** Contract book data */
--class CContractBookData
--{
--public:
-- std::string name;
-- std::string abi;
--
-- CContractBookData()
-- {}
--};
-
- #endif // BITCOIN_WALLET_WALLET_H