aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/qtum
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2018-06-07 13:00:19 +0000
committerVasil Dimov <vd@FreeBSD.org>2018-06-07 13:00:19 +0000
commita47531032fd2301684b3547f771b2aba1f275a2b (patch)
treecee246ac7eec94776057c884ae7ad280562d75eb /net-p2p/qtum
parent84b6c91edc38c8b314bffec8095719e0f485b749 (diff)
downloadports-a47531032fd2301684b3547f771b2aba1f275a2b.tar.gz
ports-a47531032fd2301684b3547f771b2aba1f275a2b.zip
net-p2p/qtum: Upgrade from 0.14.16 to 0.15.1
Notes
Notes: svn path=/head/; revision=471914
Diffstat (limited to 'net-p2p/qtum')
-rw-r--r--net-p2p/qtum/Makefile5
-rw-r--r--net-p2p/qtum/distinfo10
-rw-r--r--net-p2p/qtum/files/patch-src_wallet_wallet.h270
3 files changed, 7 insertions, 278 deletions
diff --git a/net-p2p/qtum/Makefile b/net-p2p/qtum/Makefile
index f20f7684e77e..4e3e44dcc778 100644
--- a/net-p2p/qtum/Makefile
+++ b/net-p2p/qtum/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= qtum
-PORTVERSION= 0.14.16
+PORTVERSION= 0.15.1
DISTVERSIONPREFIX= mainnet-ignition-v
-PORTREVISION= 1
CATEGORIES= net-p2p finance
MAINTAINER= vd@FreeBSD.org
@@ -41,7 +40,7 @@ USES= autoreconf bdb:5+ compiler:c++11-lib gmake libtool pkgconfig ssl
USE_QT5= buildtools core dbus gui linguisttools network testlib widgets
USE_GITHUB= yes
GH_TUPLE= qtumproject:qtum:${DISTVERSIONPREFIX}${PORTVERSION} \
- qtumproject:cpp-eth-qtum:6e3173715867f5de56d6aa:cppeth/src/cpp-ethereum
+ qtumproject:cpp-eth-qtum:8db7fc170f7c0a475bc40c:cppeth/src/cpp-ethereum
.include <bsd.port.pre.mk>
diff --git a/net-p2p/qtum/distinfo b/net-p2p/qtum/distinfo
index 03a5987aa27e..cde6a2912225 100644
--- a/net-p2p/qtum/distinfo
+++ b/net-p2p/qtum/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1524732327
-SHA256 (qtumproject-qtum-mainnet-ignition-v0.14.16_GH0.tar.gz) = bcca9a7f9f125264d53b56cb5093cb66ca7ff9147d9803832c019fbc6499fd8c
-SIZE (qtumproject-qtum-mainnet-ignition-v0.14.16_GH0.tar.gz) = 12878018
-SHA256 (qtumproject-cpp-eth-qtum-6e3173715867f5de56d6aa_GH0.tar.gz) = 01dbb43979768fc9755594e234a5b431023ace8d197a940587a05c835b3cdefc
-SIZE (qtumproject-cpp-eth-qtum-6e3173715867f5de56d6aa_GH0.tar.gz) = 1113747
+TIMESTAMP = 1528372368
+SHA256 (qtumproject-qtum-mainnet-ignition-v0.15.1_GH0.tar.gz) = 459e28c3e4e09cc2f7ff5228510f69b012deb81c25995e4a2e9e09b86357b1c9
+SIZE (qtumproject-qtum-mainnet-ignition-v0.15.1_GH0.tar.gz) = 13189384
+SHA256 (qtumproject-cpp-eth-qtum-8db7fc170f7c0a475bc40c_GH0.tar.gz) = 9fa34f808e547f08694106b6e96fa69bfac4bda7db0181131fcde55ce2a09de7
+SIZE (qtumproject-cpp-eth-qtum-8db7fc170f7c0a475bc40c_GH0.tar.gz) = 1114037
diff --git a/net-p2p/qtum/files/patch-src_wallet_wallet.h b/net-p2p/qtum/files/patch-src_wallet_wallet.h
deleted file mode 100644
index 83712d266d81..000000000000
--- a/net-p2p/qtum/files/patch-src_wallet_wallet.h
+++ /dev/null
@@ -1,270 +0,0 @@
---- src/wallet/wallet.h.orig 2018-01-23 18:15:09.538396000 +0200
-+++ src/wallet/wallet.h 2018-01-23 18:15:13.206365000 +0200
-@@ -90,8 +90,6 @@
- class CScript;
- class CTxMemPool;
- class CWalletTx;
--class CTokenTx;
--class CContractBookData;
-
- /** (client) version numbers for particular wallet features */
- enum WalletFeature
-@@ -579,6 +577,129 @@
- std::vector<char> _ssExtra;
- };
-
-+/** Contract book data */
-+class CContractBookData
-+{
-+public:
-+ std::string name;
-+ std::string abi;
-+
-+ CContractBookData()
-+ {}
-+};
-+
-+class CTokenTx
-+{
-+public:
-+ static const int CURRENT_VERSION=1;
-+ int nVersion;
-+ std::string strContractAddress;
-+ std::string strSenderAddress;
-+ std::string strReceiverAddress;
-+ uint256 nValue;
-+ uint256 transactionHash;
-+
-+ // Wallet data for token transaction
-+ int64_t nCreateTime;
-+ uint256 blockHash;
-+ int64_t blockNumber;
-+ std::string strLabel;
-+
-+ CTokenTx()
-+ {
-+ SetNull();
-+ }
-+
-+ ADD_SERIALIZE_METHODS;
-+
-+ template <typename Stream, typename Operation>
-+ inline void SerializationOp(Stream& s, Operation ser_action) {
-+ if (!(s.GetType() & SER_GETHASH))
-+ {
-+ READWRITE(nVersion);
-+ READWRITE(nCreateTime);
-+ READWRITE(blockHash);
-+ READWRITE(blockNumber);
-+ READWRITE(LIMITED_STRING(strLabel, 65536));
-+ }
-+ READWRITE(strContractAddress);
-+ READWRITE(strSenderAddress);
-+ READWRITE(strReceiverAddress);
-+ READWRITE(nValue);
-+ READWRITE(transactionHash);
-+ }
-+
-+ void SetNull()
-+ {
-+ nVersion = CTokenTx::CURRENT_VERSION;
-+ nCreateTime = 0;
-+ strContractAddress = "";
-+ strSenderAddress = "";
-+ strReceiverAddress = "";
-+ nValue.SetNull();
-+ transactionHash.SetNull();
-+ blockHash.SetNull();
-+ blockNumber = -1;
-+ strLabel = "";
-+ }
-+
-+ uint256 GetHash() const;
-+};
-+
-+class CTokenInfo
-+{
-+public:
-+ static const int CURRENT_VERSION=1;
-+ int nVersion;
-+ std::string strContractAddress;
-+ std::string strTokenName;
-+ std::string strTokenSymbol;
-+ uint8_t nDecimals;
-+ std::string strSenderAddress;
-+
-+ // Wallet data for token transaction
-+ int64_t nCreateTime;
-+ uint256 blockHash;
-+ int64_t blockNumber;
-+
-+ CTokenInfo()
-+ {
-+ SetNull();
-+ }
-+
-+ ADD_SERIALIZE_METHODS;
-+
-+ template <typename Stream, typename Operation>
-+ inline void SerializationOp(Stream& s, Operation ser_action) {
-+ if (!(s.GetType() & SER_GETHASH))
-+ {
-+ READWRITE(nVersion);
-+ READWRITE(nCreateTime);
-+ READWRITE(strTokenName);
-+ READWRITE(strTokenSymbol);
-+ READWRITE(blockHash);
-+ READWRITE(blockNumber);
-+ }
-+ READWRITE(nDecimals);
-+ READWRITE(strContractAddress);
-+ READWRITE(strSenderAddress);
-+ }
-+
-+ void SetNull()
-+ {
-+ nVersion = CTokenInfo::CURRENT_VERSION;
-+ nCreateTime = 0;
-+ strContractAddress = "";
-+ strTokenName = "";
-+ strTokenSymbol = "";
-+ nDecimals = 0;
-+ strSenderAddress = "";
-+ blockHash.SetNull();
-+ blockNumber = -1;
-+ }
-+
-+ uint256 GetHash() const;
-+};
-
- /**
- * A CWallet is an extension of a keystore, which also maintains a set of transactions and balances,
-@@ -1156,128 +1277,4 @@
- return true;
- }
-
--class CTokenInfo
--{
--public:
-- static const int CURRENT_VERSION=1;
-- int nVersion;
-- std::string strContractAddress;
-- std::string strTokenName;
-- std::string strTokenSymbol;
-- uint8_t nDecimals;
-- std::string strSenderAddress;
--
-- // Wallet data for token transaction
-- int64_t nCreateTime;
-- uint256 blockHash;
-- int64_t blockNumber;
--
-- CTokenInfo()
-- {
-- SetNull();
-- }
--
-- ADD_SERIALIZE_METHODS;
--
-- template <typename Stream, typename Operation>
-- inline void SerializationOp(Stream& s, Operation ser_action) {
-- if (!(s.GetType() & SER_GETHASH))
-- {
-- READWRITE(nVersion);
-- READWRITE(nCreateTime);
-- READWRITE(strTokenName);
-- READWRITE(strTokenSymbol);
-- READWRITE(blockHash);
-- READWRITE(blockNumber);
-- }
-- READWRITE(nDecimals);
-- READWRITE(strContractAddress);
-- READWRITE(strSenderAddress);
-- }
--
-- void SetNull()
-- {
-- nVersion = CTokenInfo::CURRENT_VERSION;
-- nCreateTime = 0;
-- strContractAddress = "";
-- strTokenName = "";
-- strTokenSymbol = "";
-- nDecimals = 0;
-- strSenderAddress = "";
-- blockHash.SetNull();
-- blockNumber = -1;
-- }
--
-- uint256 GetHash() const;
--};
--
--class CTokenTx
--{
--public:
-- static const int CURRENT_VERSION=1;
-- int nVersion;
-- std::string strContractAddress;
-- std::string strSenderAddress;
-- std::string strReceiverAddress;
-- uint256 nValue;
-- uint256 transactionHash;
--
-- // Wallet data for token transaction
-- int64_t nCreateTime;
-- uint256 blockHash;
-- int64_t blockNumber;
-- std::string strLabel;
--
-- CTokenTx()
-- {
-- SetNull();
-- }
--
-- ADD_SERIALIZE_METHODS;
--
-- template <typename Stream, typename Operation>
-- inline void SerializationOp(Stream& s, Operation ser_action) {
-- if (!(s.GetType() & SER_GETHASH))
-- {
-- READWRITE(nVersion);
-- READWRITE(nCreateTime);
-- READWRITE(blockHash);
-- READWRITE(blockNumber);
-- READWRITE(LIMITED_STRING(strLabel, 65536));
-- }
-- READWRITE(strContractAddress);
-- READWRITE(strSenderAddress);
-- READWRITE(strReceiverAddress);
-- READWRITE(nValue);
-- READWRITE(transactionHash);
-- }
--
-- void SetNull()
-- {
-- nVersion = CTokenTx::CURRENT_VERSION;
-- nCreateTime = 0;
-- strContractAddress = "";
-- strSenderAddress = "";
-- strReceiverAddress = "";
-- nValue.SetNull();
-- transactionHash.SetNull();
-- blockHash.SetNull();
-- blockNumber = -1;
-- strLabel = "";
-- }
--
-- uint256 GetHash() const;
--};
--
--/** Contract book data */
--class CContractBookData
--{
--public:
-- std::string name;
-- std::string abi;
--
-- CContractBookData()
-- {}
--};
--
- #endif // BITCOIN_WALLET_WALLET_H