aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/radarr
diff options
context:
space:
mode:
authorMichiel van Baak Jansen <michiel@vanbaak.eu>2023-12-11 16:25:18 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-12-13 07:49:19 +0000
commitec69600aeb6950b40a506486c06e1287ca9b0b39 (patch)
treeae790500dd55ab75e5517b988c44d7b840e495b8 /net-p2p/radarr
parentec331642a2a4f04e440ffe4dbdeb53d39ff6e9da (diff)
downloadports-ec69600aeb6950b40a506486c06e1287ca9b0b39.tar.gz
ports-ec69600aeb6950b40a506486c06e1287ca9b0b39.zip
net-p2p/radarr: Select correct openssl runtime version
PR: 275696 Reported by: michiel@vanbaak.eu (maintainer)
Diffstat (limited to 'net-p2p/radarr')
-rw-r--r--net-p2p/radarr/Makefile3
-rw-r--r--net-p2p/radarr/files/radarr.in4
2 files changed, 6 insertions, 1 deletions
diff --git a/net-p2p/radarr/Makefile b/net-p2p/radarr/Makefile
index cc28ee89b507..7822f3e990bb 100644
--- a/net-p2p/radarr/Makefile
+++ b/net-p2p/radarr/Makefile
@@ -1,5 +1,6 @@
PORTNAME= radarr
DISTVERSION= 5.1.3.8246
+PORTREVISION= 1
CATEGORIES= net-p2p
MASTER_SITES= https://github.com/Radarr/Radarr/releases/download/v${PORTVERSION}/
DISTNAME= Radarr.master.${DISTVERSION}.freebsd-core-x64
@@ -20,7 +21,7 @@ RUN_DEPENDS= ca_root_nss>0:security/ca_root_nss \
libinotify>0:devel/libinotify \
libunwind>0:devel/libunwind
-USES= ssl:run sqlite:3
+USES= sqlite:3 ssl:run
USE_RC_SUBR= ${PORTNAME}
diff --git a/net-p2p/radarr/files/radarr.in b/net-p2p/radarr/files/radarr.in
index ebde62bb3eba..1460241f5e95 100644
--- a/net-p2p/radarr/files/radarr.in
+++ b/net-p2p/radarr/files/radarr.in
@@ -48,6 +48,10 @@ start_precmd=${name}_precmd
export DOTNET_SYSTEM_NET_DISABLEIPV6=1
fi
+ if [ `uname -K` -ge 1400092 ]; then
+ export CLR_OPENSSL_VERSION_OVERRIDE=30
+ fi
+
rc_flags="-r -f -p ${pidfile_child} -P ${pidfile} ${%%PORTNAME%%_exec_dir}/Radarr --data=${%%PORTNAME%%_data_dir} --nobrowser >> /dev/null 2>&1 ${rc_flags}"
}