aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/retroshare
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
commit216b5a285fdcc1456a307fcc60f3507c20d613eb (patch)
treed0c8617b772b8f0a175d436d938b8d844590b41f /net-p2p/retroshare
parentb829518a7d432b7cc2546fde7f032238d1db13dc (diff)
downloadports-216b5a285fdcc1456a307fcc60f3507c20d613eb.tar.gz
ports-216b5a285fdcc1456a307fcc60f3507c20d613eb.zip
- Fix missing library problems when the linker enforces explicit linking
PR: 192062 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=366215
Diffstat (limited to 'net-p2p/retroshare')
-rw-r--r--net-p2p/retroshare/Makefile24
-rw-r--r--net-p2p/retroshare/files/patch-retroshare-gui__src__retroshare-gui.pro11
-rw-r--r--net-p2p/retroshare/files/patch-retroshare-nogui__src__retroshare-nogui.pro11
3 files changed, 22 insertions, 24 deletions
diff --git a/net-p2p/retroshare/Makefile b/net-p2p/retroshare/Makefile
index 4536654e743c..7d3de3abf105 100644
--- a/net-p2p/retroshare/Makefile
+++ b/net-p2p/retroshare/Makefile
@@ -3,7 +3,7 @@
PORTNAME= retroshare
PORTVERSION= 0.5.5c
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-p2p
MASTER_SITES= SF
MASTER_SITE_SUBDIR=${PORTNAME}/${BINARY}/${PORTVERSION}
@@ -14,29 +14,17 @@ COMMENT= Private and secure decentralised communication platform
LICENSE= GPLv2
-BUILD_DEPENDS= protoc:${PORTSDIR}/devel/protobuf \
- pkg-config:${PORTSDIR}/devel/pkgconf
-LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus \
- libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs \
- libpcre.so:${PORTSDIR}/devel/pcre \
+BUILD_DEPENDS= protoc:${PORTSDIR}/devel/protobuf
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
libupnp.so:${PORTSDIR}/devel/upnp \
- libpng15.so:${PORTSDIR}/graphics/png \
- libfreetype.so:${PORTSDIR}/print/freetype2 \
- libassuan.so:${PORTSDIR}/security/libassuan \
- libgcrypt.so:${PORTSDIR}/security/libgcrypt \
libgnome-keyring.so:${PORTSDIR}/security/libgnome-keyring \
- libgpg-error.so:${PORTSDIR}/security/libgpg-error \
- libgpgme.so:${PORTSDIR}/security/gpgme \
- libexpat.so:${PORTSDIR}/textproc/expat2 \
- libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
libspeex.so:${PORTSDIR}/audio/speex \
libxslt.so:${PORTSDIR}/textproc/libxslt \
libssh_threads.so:${PORTSDIR}/security/libssh
-RUN_DEPENDS= pinentry-qt4:${PORTSDIR}/security/pinentry-qt4
-USES= compiler:features dos2unix qmake
-USE_GNOME= glib20
-USE_XORG= ice sm x11 xau xcb xdmcp xext xrender
+USES= compiler:features dos2unix pkgconfig qmake
+USE_GNOME= glib20 libxml2 libxslt
+USE_XORG= x11 xscrnsaver
USE_QT4= corelib gui network xml script designer_build uic_build \
qmake_build moc_build rcc_build multimedia
HAS_CONFIGURE= yes
diff --git a/net-p2p/retroshare/files/patch-retroshare-gui__src__retroshare-gui.pro b/net-p2p/retroshare/files/patch-retroshare-gui__src__retroshare-gui.pro
index c97372734ee0..6255e157257c 100644
--- a/net-p2p/retroshare/files/patch-retroshare-gui__src__retroshare-gui.pro
+++ b/net-p2p/retroshare/files/patch-retroshare-gui__src__retroshare-gui.pro
@@ -1,24 +1,29 @@
--- retroshare-gui/src/retroshare-gui.pro.orig 2014-04-10 13:28:51.661832058 +0200
+++ retroshare-gui/src/retroshare-gui.pro 2014-04-10 13:29:31.092831413 +0200
-@@ -215,17 +215,19 @@
+@@ -215,17 +215,22 @@ macx {
freebsd-* {
INCLUDEPATH *= /usr/local/include/gpgme
LIBS *= ../../libretroshare/src/lib/libretroshare.a
+ LIBS *= ../../openpgpsdk/src/lib/libops.a -lbz2
LIBS *= -lssl
- LIBS *= -lgpgme
+- LIBS *= -lgpgme
- LIBS *= -lupnp
++ LIBS *= -lcrypto
++ LIBS *= -lz
+ LIBS *= -lupnp -lixml
++ LIBS *= -lXss -lX11
LIBS *= -lgnome-keyring
PRE_TARGETDEPS *= ../../libretroshare/src/lib/libretroshare.a
+ PRE_TARGETDEPS *= ../../openpgpsdk/src/lib/libops.a
gxs {
LIBS += ../../supportlibs/pegmarkdown/lib/libpegmarkdown.a
- LIBS += -lsqlite3
+- LIBS += -lsqlite3
++ LIBS += ../../../lib/sqlcipher/.libs/libsqlcipher.a
}
-
+ LIBS *= -rdynamic
++ DEFINES *= HAVE_XSS # for idle time, libx screensaver extensions
}
##################################### OpenBSD ######################################
diff --git a/net-p2p/retroshare/files/patch-retroshare-nogui__src__retroshare-nogui.pro b/net-p2p/retroshare/files/patch-retroshare-nogui__src__retroshare-nogui.pro
index 90292c2c22e5..fd794a6492f8 100644
--- a/net-p2p/retroshare/files/patch-retroshare-nogui__src__retroshare-nogui.pro
+++ b/net-p2p/retroshare/files/patch-retroshare-nogui__src__retroshare-nogui.pro
@@ -1,21 +1,26 @@
--- retroshare-nogui/src/retroshare-nogui.pro.orig 2014-04-10 14:14:22.622840778 +0200
+++ retroshare-nogui/src/retroshare-nogui.pro 2014-04-10 14:14:55.384836372 +0200
-@@ -114,12 +114,16 @@
+@@ -114,12 +114,20 @@ macx {
freebsd-* {
INCLUDEPATH *= /usr/local/include/gpgme
+ QMAKE_CXXFLAGS *= -Dfseeko64=fseeko -Dftello64=ftello -Dstat64=stat -Dstatvfs64=statvfs -Dfopen64=fopen
LIBS *= ../../libretroshare/src/lib/libretroshare.a
- LIBS *= -lssl
+- LIBS *= -lgpgme
+- LIBS *= -lupnp
+ LIBS *= ../../openpgpsdk/src/lib/libops.a -lbz2
+ LIBS *= -lssl -lcrypto
- LIBS *= -lgpgme
-- LIBS *= -lupnp
++ LIBS *= -lz
+ LIBS *= -lupnp -lixml
LIBS *= -lgnome-keyring
PRE_TARGETDEPS *= ../../libretroshare/src/lib/libretroshare.a
+ PRE_TARGETDEPS *= ../../openpgpsdk/src/lib/libops.a
+ LIBS *= -rdynamic
++ gxs {
++ # We need a explicit path here, to force using the home version
++ LIBS += ../../../lib/sqlcipher/.libs/libsqlcipher.a
++ }
}
##################################### OpenBSD ######################################