aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/retroshare
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-04-22 08:26:59 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-04-22 08:26:59 +0000
commit56900eadb950d5b3e5d66068650d27e2f5f0f28f (patch)
tree5eea8f1ba26c251ed5b549abcd28f15e89c88e60 /net-p2p/retroshare
parent5cd6c2ce21f337eb1a9bc08744116c81988bac72 (diff)
downloadports-56900eadb950d5b3e5d66068650d27e2f5f0f28f.tar.gz
ports-56900eadb950d5b3e5d66068650d27e2f5f0f28f.zip
net-p2p/retroshare: Switch from devel/upnp to net/miniupnpc
RetroShare does not build with upnp >= 1.8. Upstream does not have a solution for this yet other than suggesting to switch to using miniupnpc as a workaround. PR: 237406 Submitted by: tobik Approved by: peter@netkey.at (maintainer)
Notes
Notes: svn path=/head/; revision=499614
Diffstat (limited to 'net-p2p/retroshare')
-rw-r--r--net-p2p/retroshare/Makefile6
-rw-r--r--net-p2p/retroshare/files/patch-libretroshare_src_libretroshare.pro7
-rw-r--r--net-p2p/retroshare/files/patch-retroshare-gui_src_retroshare-gui.pro8
-rw-r--r--net-p2p/retroshare/files/patch-retroshare-nogui_src_retroshare-nogui.pro8
4 files changed, 15 insertions, 14 deletions
diff --git a/net-p2p/retroshare/Makefile b/net-p2p/retroshare/Makefile
index 91e474ca19f1..22232deb043a 100644
--- a/net-p2p/retroshare/Makefile
+++ b/net-p2p/retroshare/Makefile
@@ -4,7 +4,7 @@
PORTNAME= retroshare
DISTVERSIONPREFIX= v
DISTVERSION= 0.6.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-p2p
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
@@ -19,14 +19,14 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LIB_DEPENDS= libsqlcipher.so:databases/sqlcipher \
libspeex.so:audio/speex \
libspeexdsp.so:audio/speexdsp \
- libupnp.so:devel/upnp \
libgnome-keyring.so:security/libgnome-keyring \
libgpgme.so:security/gpgme \
libopencv_highgui.so:graphics/opencv \
libopencv_imgproc.so:graphics/opencv-core \
libavcodec.so:multimedia/ffmpeg \
libcurl.so:ftp/curl \
- libmicrohttpd.so:www/libmicrohttpd
+ libmicrohttpd.so:www/libmicrohttpd \
+ libminiupnpc.so:net/miniupnpc
USES= compiler:features desktop-file-utils dos2unix \
gnome pkgconfig qmake qt:5 ssl
diff --git a/net-p2p/retroshare/files/patch-libretroshare_src_libretroshare.pro b/net-p2p/retroshare/files/patch-libretroshare_src_libretroshare.pro
index db054c4a8650..a0b92aa59abd 100644
--- a/net-p2p/retroshare/files/patch-libretroshare_src_libretroshare.pro
+++ b/net-p2p/retroshare/files/patch-libretroshare_src_libretroshare.pro
@@ -1,6 +1,6 @@
--- libretroshare/src/libretroshare.pro.orig 2018-03-13 19:25:38 UTC
+++ libretroshare/src/libretroshare.pro
-@@ -341,13 +341,15 @@ mac {
+@@ -341,13 +341,14 @@ mac {
freebsd-* {
INCLUDEPATH *= /usr/local/include/gpgme
@@ -10,8 +10,9 @@
QMAKE_CXXFLAGS *= -Dfseeko64=fseeko -Dftello64=ftello -Dstat64=stat -Dstatvfs64=statvfs -Dfopen64=fopen
# linux/bsd can use either - libupnp is more complete and packaged.
- #CONFIG += upnp_miniupnpc
- CONFIG += upnp_libupnp
+- #CONFIG += upnp_miniupnpc
+- CONFIG += upnp_libupnp
++ CONFIG += upnp_miniupnpc
+ DEFINES *= PLUGIN_DIR=\"\\\"$${PLUGIN_DIR}\\\"\"
+ DEFINES *= DATA_DIR=\"\\\"$${DATA_DIR}\\\"\"
}
diff --git a/net-p2p/retroshare/files/patch-retroshare-gui_src_retroshare-gui.pro b/net-p2p/retroshare/files/patch-retroshare-gui_src_retroshare-gui.pro
index a1e57a49fa10..211137df7b6b 100644
--- a/net-p2p/retroshare/files/patch-retroshare-gui_src_retroshare-gui.pro
+++ b/net-p2p/retroshare/files/patch-retroshare-gui_src_retroshare-gui.pro
@@ -1,16 +1,16 @@
---- retroshare-gui/src/retroshare-gui.pro.orig 2016-02-05 19:04:46 UTC
+--- retroshare-gui/src/retroshare-gui.pro.orig 2018-03-13 19:25:38 UTC
+++ retroshare-gui/src/retroshare-gui.pro
-@@ -239,12 +239,16 @@ macx {
+@@ -270,12 +270,15 @@ macx {
freebsd-* {
INCLUDEPATH *= /usr/local/include/gpgme
- LIBS *= -lssl
+ LIBS *= -lssl -lcrypto
LIBS *= -lgpgme
- LIBS *= -lupnp
+- LIBS *= -lupnp
++ LIBS *= -lminiupnpc
LIBS *= -lgnome-keyring
+ LIBS *= -lz
-+ LIBS *= -lixml
+ LIBS *= -lexecinfo
- LIBS += -lsqlite3
diff --git a/net-p2p/retroshare/files/patch-retroshare-nogui_src_retroshare-nogui.pro b/net-p2p/retroshare/files/patch-retroshare-nogui_src_retroshare-nogui.pro
index 90ea4f9f8a1b..f919b3376856 100644
--- a/net-p2p/retroshare/files/patch-retroshare-nogui_src_retroshare-nogui.pro
+++ b/net-p2p/retroshare/files/patch-retroshare-nogui_src_retroshare-nogui.pro
@@ -1,16 +1,16 @@
---- retroshare-nogui/src/retroshare-nogui.pro.orig 2016-03-05 21:29:14 UTC
+--- retroshare-nogui/src/retroshare-nogui.pro.orig 2019-04-20 14:26:36 UTC
+++ retroshare-nogui/src/retroshare-nogui.pro
-@@ -126,10 +126,16 @@ macx {
+@@ -115,10 +115,15 @@ macx {
freebsd-* {
INCLUDEPATH *= /usr/local/include/gpgme
- LIBS *= -lssl
+ LIBS *= -lssl -lcrypto
LIBS *= -lgpgme
- LIBS *= -lupnp
+- LIBS *= -lupnp
++ LIBS *= -lminiupnpc
LIBS *= -lgnome-keyring
+ LIBS *= -lz
-+ LIBS *= -lixml
+ LIBS *= -lthr
+ LIBS += -lsqlcipher
+ LIBS *= -lexecinfo