aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/retroshare
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-11-22 12:55:00 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-11-22 12:55:00 +0000
commit5898d7df5c5c0c4c33faa934a38001e755f6d900 (patch)
treeedc1328e7d68e649db202ae07c396b88869f73de /net-p2p/retroshare
parent14b67ba33b83fe27381b6547b20370f812a4da0f (diff)
downloadports-5898d7df5c5c0c4c33faa934a38001e755f6d900.tar.gz
ports-5898d7df5c5c0c4c33faa934a38001e755f6d900.zip
- Convert to USES=qmake (and other USES while I'm here)
- Add state support - Convert LIB_DEPENDS to new style, adjust USE_QT4 components, etc. Approved by: portmgr (blanket approval)
Notes
Notes: svn path=/head/; revision=334586
Diffstat (limited to 'net-p2p/retroshare')
-rw-r--r--net-p2p/retroshare/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/net-p2p/retroshare/Makefile b/net-p2p/retroshare/Makefile
index 256fdd9b7f4c..9c502a60b1ad 100644
--- a/net-p2p/retroshare/Makefile
+++ b/net-p2p/retroshare/Makefile
@@ -30,12 +30,12 @@ LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus \
libxslt.so:${PORTSDIR}/textproc/libxslt
RUN_DEPENDS= pinentry-qt4:${PORTSDIR}/security/pinentry-qt4
+USES= qmake
USE_ZIP= yes
USE_GNOME= glib20
USE_XORG= ice sm x11 xau xcb xdmcp xext xrender
USE_QT4= corelib gui network xml script designer_build uic_build \
- qmake_build moc_build rcc_build multimedia
-HAS_CONFIGURE= yes
+ moc_build rcc_build multimedia
BINARY= RetroShare
MAKE_JOBS_UNSAFE=yes
USE_LDCONFIG= yes
@@ -43,10 +43,6 @@ USE_LDCONFIG= yes
DESKTOP_ENTRIES="${BINARY}" "${COMMENT}" "${DATADIR}/retrosharelogo1.png" \
"${BINARY}" "Network;FileTransfer;" true
-do-configure:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} PREFIX=${PREFIX} ${BINARY}.pro
-
USE_DOS2UNIX= retroshare-gui/src/retroshare-gui.pro
post-patch: