aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/shx
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2013-08-19 14:52:18 +0000
committerWesley Shields <wxs@FreeBSD.org>2013-08-19 14:52:18 +0000
commit9c6901cf8265213d96f0ad421aaacf216f9ca377 (patch)
tree5ff815425a473735af32f1a9bf325c0437dfef76 /net-p2p/shx
parenta132c68a0045821b665fff91bf5e78a4139faeff (diff)
downloadports-9c6901cf8265213d96f0ad421aaacf216f9ca377.tar.gz
ports-9c6901cf8265213d96f0ad421aaacf216f9ca377.zip
This is a text based version of the popular hotline client for
Macintosh. Hotline is a chat/ftp/news protocol. It's setup almost like an IRC client, but with the ability to do commands such as cd into a directory with /cd and more file transfer oriented functions. WWW: http://synhxd.sourceforge.net/ PR: ports/181401 Submitted by: dteske@
Notes
Notes: svn path=/head/; revision=324997
Diffstat (limited to 'net-p2p/shx')
-rw-r--r--net-p2p/shx/Makefile84
-rw-r--r--net-p2p/shx/distinfo4
-rw-r--r--net-p2p/shx/pkg-descr6
3 files changed, 94 insertions, 0 deletions
diff --git a/net-p2p/shx/Makefile b/net-p2p/shx/Makefile
new file mode 100644
index 000000000000..0c909a6ba56e
--- /dev/null
+++ b/net-p2p/shx/Makefile
@@ -0,0 +1,84 @@
+# Created by: Devin Teske <dteske@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= shx
+PORTVERSION= 0.2.4
+CATEGORIES= net-p2p
+MASTER_SITES= http://synhxd.sourceforge.net/releases/
+EXTRACT_SUFX= .tgz
+
+PATCH_SITES= ${MASTER_SITES}
+PATCHFILES= ${DISTNAME}.diff.gz
+
+MAINTAINER= dteske@FreeBSD.org
+COMMENT= A text based Hotline Communications client for Unix
+
+LICENSE= GPLv1
+
+OPTIONS_DEFINE= WARNINGS HTXF_PTHREAD HFS HOPE CIPHER COMPRESS HAL XMMS NOIPV4
+OPTIONS_DEFAULT= HTXF_PTHREAD HFS HOPE CIPHER COMPRESS XMMS
+
+WARNINGS_DESC= Show compiler warnings
+HTXF_PTHREAD_DESC= Use pthread instead of fork or clone for htxf
+HFS_DESC= Enable HFS file system emulation
+HOPE_DESC= Enable HOPE (required by Cipher/Compress)
+CIPHER_DESC= Enable Cipher (HOPE required)
+COMPRESS_DESC= Enable Compress (HOPE required)
+HAL_DESC= Compile MegaHAL (enables hal command)
+XMMS_DESC= Enable trackname command
+NOIPV4_DESC= IPv6 support (disables IPv4 support)
+
+MAKEFILE= makefile
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS=
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MWARNINGS}
+CONFIGURE_ARGS+= --enable-warnings
+.endif
+
+.if ${PORT_OPTIONS:MHTXF_PTHREAD}
+CONFIGURE_ARGS+= --enable-htxf-pthread
+.endif
+
+.if ! ${PORT_OPTIONS:MHFS}
+CONFIGURE_ARGS+= --disable-hfs
+.endif
+
+.if ${PORT_OPTIONS:MHOPE}
+CONFIGURE_ARGS+= --enable-hope
+.if ${PORT_OPTIONS:MCIPHER}
+CONFIGURE_ARGS+= --enable-cipher
+.endif
+.if ${PORT_OPTIONS:MCOMPRESS}
+CONFIGURE_ARGS+= --enable-compress
+.endif
+.endif
+
+.if ${PORT_OPTIONS:MHAL}
+CONFIGURE_ARGS+= --enable-hal
+.endif
+
+.if ${PORT_OPTIONS:MXMMS}
+CONFIGURE_ARGS+= --enable-xmms
+.endif
+
+.if ${PORT_OPTIONS:MNOIPV4}
+CONFIGURE_ARGS+= --enable-ipv6
+.endif
+
+PLIST_FILES= \
+ bin/hx \
+ share/examples/shx/hxrc \
+ share/examples/shx/hxvars
+
+PLIST_DIRS= share/examples/shx
+
+do-install:
+ @${CP} -fv ${WRKSRC}/run/hx ${PREFIX}/bin/
+ @${MKDIR} ${PREFIX}/share/examples/${PORTNAME}
+ @${CP} -fv ${WRKSRC}/run/hxrc ${PREFIX}/share/examples/${PORTNAME}/
+ @${CP} -fv ${WRKSRC}/run/hxvars ${PREFIX}/share/examples/${PORTNAME}/
+
+.include <bsd.port.mk>
diff --git a/net-p2p/shx/distinfo b/net-p2p/shx/distinfo
new file mode 100644
index 000000000000..ea9f9b720608
--- /dev/null
+++ b/net-p2p/shx/distinfo
@@ -0,0 +1,4 @@
+SHA256 (shx-0.2.4.tgz) = 0fe2d3bed542c4659614d449bf42b618a37130c7e63bce13db3832575e45e325
+SIZE (shx-0.2.4.tgz) = 290512
+SHA256 (shx-0.2.4.diff.gz) = 70d41179c0e2fb5f8dd3ee104aeddac2346da45a7f344682dfa2c67116c78e2a
+SIZE (shx-0.2.4.diff.gz) = 651
diff --git a/net-p2p/shx/pkg-descr b/net-p2p/shx/pkg-descr
new file mode 100644
index 000000000000..5da2b8804cb8
--- /dev/null
+++ b/net-p2p/shx/pkg-descr
@@ -0,0 +1,6 @@
+This is a text based version of the popular hotline client for
+Macintosh. Hotline is a chat/ftp/news protocol. It's setup almost
+like an IRC client, but with the ability to do commands such as cd
+into a directory with /cd and more file transfer oriented functions.
+
+WWW: http://synhxd.sourceforge.net/