aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/sonarr
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2016-11-12 19:13:07 +0000
committerMark Felder <feld@FreeBSD.org>2016-11-12 19:13:07 +0000
commitee02011957cbc1f31659b20bfb300aae2efc2573 (patch)
tree0806b90f2728bd2234c6b743e983314ed3b90893 /net-p2p/sonarr
parent11e596877a90ad683a30eb563764d2b93d5059ab (diff)
downloadports-ee02011957cbc1f31659b20bfb300aae2efc2573.tar.gz
ports-ee02011957cbc1f31659b20bfb300aae2efc2573.zip
net-p2p/sonarr: Make X11 optional
X11 dependencies were added to resolve a crashing issue in newer versions of sonarr. This has been resolved upstream and is now optional. The role of X11 (libgdiplus) is to enable image file resizing. PR: 214244
Notes
Notes: svn path=/head/; revision=425985
Diffstat (limited to 'net-p2p/sonarr')
-rw-r--r--net-p2p/sonarr/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/net-p2p/sonarr/Makefile b/net-p2p/sonarr/Makefile
index 77cdf42aae46..bbce6b16c349 100644
--- a/net-p2p/sonarr/Makefile
+++ b/net-p2p/sonarr/Makefile
@@ -2,7 +2,7 @@
PORTNAME= sonarr
PORTVERSION= 2.0.0.4389
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= net-p2p
MASTER_SITES= http://download.sonarr.tv/v2/master/mono/
DISTNAME= NzbDrone.master.${PORTVERSION}.mono
@@ -15,8 +15,7 @@ LICENSE= GPLv3
RUN_DEPENDS= mono>0:lang/mono \
mediainfo>0:multimedia/mediainfo \
sqlite3>0:databases/sqlite3
-LIB_DEPENDS= libcurl.so:ftp/curl \
- libgdiplus.so:x11-toolkits/libgdiplus
+LIB_DEPENDS= libcurl.so:ftp/curl
USE_RC_SUBR= sonarr
@@ -25,6 +24,13 @@ WRKSRC= ${WRKDIR}/NzbDrone
USERS= sonarr
+OPTIONS_DEFINE= X11
+
+# Permits image resizing
+X11_LIB_DEPENDS+=libgdiplus.so:x11-toolkits/libgdiplus
+
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL} -d -m 755 ${STAGEDIR}/${DATADIR}
cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${STAGEDIR}/${DATADIR}