aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/torrent-file-editor
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2019-03-05 07:50:10 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2019-03-05 07:50:10 +0000
commit76ccc27f96df9e6d2a3ae52f9e4213ede093f4a7 (patch)
tree13aaab9e2abde5840fb3dcdd269e88daa1377ba7 /net-p2p/torrent-file-editor
parent61c57a3b47551d9d23fefe7b7dc22b8608c06da1 (diff)
downloadports-76ccc27f96df9e6d2a3ae52f9e4213ede093f4a7.tar.gz
ports-76ccc27f96df9e6d2a3ae52f9e4213ede093f4a7.zip
With Qt 4.x sadly going away in less than two weeks, use Qt 5 by default
and remove QT5 option earlier to ease the deprecation process and reduce repo churn when the time comes.
Notes
Notes: svn path=/head/; revision=494684
Diffstat (limited to 'net-p2p/torrent-file-editor')
-rw-r--r--net-p2p/torrent-file-editor/Makefile29
1 files changed, 6 insertions, 23 deletions
diff --git a/net-p2p/torrent-file-editor/Makefile b/net-p2p/torrent-file-editor/Makefile
index 189567600bfb..efeb24dc77f0 100644
--- a/net-p2p/torrent-file-editor/Makefile
+++ b/net-p2p/torrent-file-editor/Makefile
@@ -3,7 +3,7 @@
PORTNAME= torrent-file-editor
PORTVERSION= 0.3.13
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-p2p
MASTER_SITES= SF/${PORTNAME}/v${PORTVERSION}
@@ -12,35 +12,18 @@ COMMENT= Qt-based GUI tool for creating and editing .torrent files
LICENSE= GPLv3
-USES= cmake compiler:c++11-lang desktop-file-utils
-
-_QT4_DEPS= linguisttools_build moc_build qmake_build rcc_build \
- uic_build corelib gui
-_QT5_DEPS= buildtools_build linguisttools_build qmake_build \
+USES= cmake compiler:c++11-lang desktop-file-utils qt:5
+USE_QT= buildtools_build linguisttools_build qmake_build \
core gui widgets
-OPTIONS_DEFINE= DONATION QT5
+CMAKE_ARGS= -DQT5_BUILD:BOOL=ON
+
+OPTIONS_DEFINE= DONATION
OPTIONS_DEFAULT= DONATION
DONATION_DESC= Show donation text in the About dialog
-QT5_DESC= Build against Qt 5 instead of Qt 4
-
DONATION_CMAKE_OFF= -DDISABLE_DONATION:BOOL=ON
-QT5_USES= qt:5
-QT5_USES_OFF= qt:4
-QT5_USE= QT=${_QT5_DEPS:ts,}
-QT5_USE_OFF= QT=${_QT4_DEPS:ts,}
-QT5_LIB_DEPENDS_OFF= libqjson.so:devel/qjson@qt4
-QT5_CMAKE_BOOL= QT5_BUILD
-
-.include <bsd.port.options.mk>
-
-.if ! ${PORT_OPTIONS:MQT5}
-DEPRECATED= Qt4 has been EOL since december 2015
-EXPIRATION_DATE= 2019-03-15
-.endif
-
post-patch:
# Avoid conflict with C++20 <version> by adding .txt suffix
@${REINPLACE_CMD} -i .c++20 '/file/s/version/&.txt/' \