aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/torrent-file-editor
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2017-05-31 19:25:55 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2017-05-31 19:25:55 +0000
commit9f4e7930a32dedec9f7269d9d843c2b5469335fd (patch)
tree4e863fb60223016defafe84583147275f9d47689 /net-p2p/torrent-file-editor
parentbf7d5a9efedbee40a5235120777c48e984470f38 (diff)
downloadports-9f4e7930a32dedec9f7269d9d843c2b5469335fd.tar.gz
ports-9f4e7930a32dedec9f7269d9d843c2b5469335fd.zip
Add a port of Qt-based GUI tool designed to create and edit .torrent files.
Notes
Notes: svn path=/head/; revision=442260
Diffstat (limited to 'net-p2p/torrent-file-editor')
-rw-r--r--net-p2p/torrent-file-editor/Makefile29
-rw-r--r--net-p2p/torrent-file-editor/distinfo3
-rw-r--r--net-p2p/torrent-file-editor/files/patch-CMakeLists.txt10
-rw-r--r--net-p2p/torrent-file-editor/pkg-descr10
-rw-r--r--net-p2p/torrent-file-editor/pkg-plist9
5 files changed, 61 insertions, 0 deletions
diff --git a/net-p2p/torrent-file-editor/Makefile b/net-p2p/torrent-file-editor/Makefile
new file mode 100644
index 000000000000..56eeaf11e5ec
--- /dev/null
+++ b/net-p2p/torrent-file-editor/Makefile
@@ -0,0 +1,29 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= torrent-file-editor
+PORTVERSION= 0.3.4
+CATEGORIES= net-p2p
+MASTER_SITES= SF/${PORTNAME}/v${PORTVERSION}
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Qt-based GUI tool for creating and editing .torrent files
+
+LICENSE= GPLv3
+
+USES= cmake
+
+_QT4_DEPS= linguisttools_build moc_build qmake_build rcc_build \
+ uic_build corelib gui
+_QT5_DEPS= buildtools_build linguisttools_build qmake_build \
+ core gui widgets
+
+OPTIONS_DEFINE= QT5
+QT5_DESC= Build against Qt 5 instead of Qt 4
+
+QT5_USE= QT5=${_QT5_DEPS:ts,}
+QT5_USE_OFF= QT4=${_QT4_DEPS:ts,}
+QT5_LIB_DEPENDS_OFF= libqjson.so:devel/qjson
+QT5_CMAKE_ON= -DQT5_BUILD:BOOL=ON
+
+.include <bsd.port.mk>
diff --git a/net-p2p/torrent-file-editor/distinfo b/net-p2p/torrent-file-editor/distinfo
new file mode 100644
index 000000000000..686c6f302767
--- /dev/null
+++ b/net-p2p/torrent-file-editor/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1492441821
+SHA256 (torrent-file-editor-0.3.4.tar.gz) = 6f3dda0fe0dee76bd1e15f62af4d29b11e6f4149d05ed520e5a7c2baa269a08c
+SIZE (torrent-file-editor-0.3.4.tar.gz) = 302621
diff --git a/net-p2p/torrent-file-editor/files/patch-CMakeLists.txt b/net-p2p/torrent-file-editor/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..6f23f3f190fb
--- /dev/null
+++ b/net-p2p/torrent-file-editor/files/patch-CMakeLists.txt
@@ -0,0 +1,10 @@
+--- CMakeLists.txt.orig 2017-04-17 14:19:04 UTC
++++ CMakeLists.txt
+@@ -73,6 +73,7 @@ if(QT5_BUILD)
+ else()
+ find_package(Qt4 REQUIRED)
+ find_package(QJSON 0.8.0 REQUIRED)
++ include_directories(${QJSON_INCLUDE_DIR})
+ include(${QT_USE_FILE})
+ endif()
+
diff --git a/net-p2p/torrent-file-editor/pkg-descr b/net-p2p/torrent-file-editor/pkg-descr
new file mode 100644
index 000000000000..0cf42cf84ab3
--- /dev/null
+++ b/net-p2p/torrent-file-editor/pkg-descr
@@ -0,0 +1,10 @@
+This is a Qt-based GUI tool designed to create and edit .torrent files.
+Some of its features:
+
+ - Create .torrent file from scratch
+ - Edit .torrent file in user-friendly way
+ - Edit .torrent file in JSON format
+ - Add, remove, and interchange files in .torrent file
+ - Support for different encodings
+
+WWW: https://sourceforge.net/projects/torrent-file-editor/
diff --git a/net-p2p/torrent-file-editor/pkg-plist b/net-p2p/torrent-file-editor/pkg-plist
new file mode 100644
index 000000000000..70c1a2e0f560
--- /dev/null
+++ b/net-p2p/torrent-file-editor/pkg-plist
@@ -0,0 +1,9 @@
+bin/torrent-file-editor
+share/appdata/torrent-file-editor.appdata.xml
+share/applications/torrent-file-editor.desktop
+share/icons/hicolor/16x16/apps/torrent-file-editor.png
+share/icons/hicolor/32x32/apps/torrent-file-editor.png
+share/icons/hicolor/48x48/apps/torrent-file-editor.png
+share/icons/hicolor/64x64/apps/torrent-file-editor.png
+share/icons/hicolor/128x128/apps/torrent-file-editor.png
+share/icons/hicolor/256x256/apps/torrent-file-editor.png