aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/torrentcheck
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2016-08-14 15:30:26 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2016-08-14 15:30:26 +0000
commitdacb774302fb7c64d214a38e911ec0ef8841f21a (patch)
tree4a381ab5a68e2ef54c4c3686a2687f3af282cfba /net-p2p/torrentcheck
parent0744f9be686c74eff0c7262985b3077a5dc398af (diff)
downloadports-dacb774302fb7c64d214a38e911ec0ef8841f21a.tar.gz
ports-dacb774302fb7c64d214a38e911ec0ef8841f21a.zip
Add a port of torrentcheck, command-line torrent viewer and hash checker.
NB: TIMESTAMP line in distinfo should read as follows, but has to stay in its current form due to a bug in the hook script: TIMESTAMP (torrentcheck/torrentcheck-1.00.zip) = 1291291031 WWW: https://sourceforge.net/projects/torrentcheck/
Notes
Notes: svn path=/head/; revision=420189
Diffstat (limited to 'net-p2p/torrentcheck')
-rw-r--r--net-p2p/torrentcheck/Makefile41
-rw-r--r--net-p2p/torrentcheck/distinfo5
-rw-r--r--net-p2p/torrentcheck/pkg-descr15
3 files changed, 61 insertions, 0 deletions
diff --git a/net-p2p/torrentcheck/Makefile b/net-p2p/torrentcheck/Makefile
new file mode 100644
index 000000000000..a53ba333e443
--- /dev/null
+++ b/net-p2p/torrentcheck/Makefile
@@ -0,0 +1,41 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= torrentcheck
+PORTVERSION= 1.00
+CATEGORIES= net-p2p
+MASTER_SITES= SF/${PORTNAME}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} readme.txt
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY= ${_DISTFILES:N*.txt}
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Command-line torrent viewer and hash checker
+
+LICENSE= PD
+
+USES= zip
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= README
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e '/malloc\.h/d' ${WRKSRC}/torrentcheck.c
+
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} ${CPPFLAGS} -o ${PORTNAME} \
+ sha1.c torrentcheck.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+# Convert to Unix line-endings and trim useless compile-related information
+ ${TR} -d \\r < ${_DISTDIR}/readme.txt | ${SED} '126,$$d' > \
+ ${STAGEDIR}${DOCSDIR}/README
+
+.include <bsd.port.mk>
diff --git a/net-p2p/torrentcheck/distinfo b/net-p2p/torrentcheck/distinfo
new file mode 100644
index 000000000000..a636b6e2ea63
--- /dev/null
+++ b/net-p2p/torrentcheck/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1291291031
+SHA256 (torrentcheck/torrentcheck-1.00.zip) = a839f9ac9669d942f83af33db96ce9902d84f85592c99b568ef0f5232ff318c5
+SIZE (torrentcheck/torrentcheck-1.00.zip) = 28150
+SHA256 (torrentcheck/readme.txt) = 4c91ae5f0a446632fc664b9c6921a3f8e7fc75c3bd152141f2c3352fe0275164
+SIZE (torrentcheck/readme.txt) = 7240
diff --git a/net-p2p/torrentcheck/pkg-descr b/net-p2p/torrentcheck/pkg-descr
new file mode 100644
index 000000000000..ecc1f489c2a2
--- /dev/null
+++ b/net-p2p/torrentcheck/pkg-descr
@@ -0,0 +1,15 @@
+This program is a command-line utility to catalog and verify torrent files.
+Run with only the -t option, it displays the metadata, name, and size of
+each file in the torrent. Run with the -t and -p options, it computes the
+hashes of all files in the torrent, compares them against the hashes stored
+in the metadata, and warns of any errors.
+
+Torrentcheck also verifies the length of each file, and flags an error if
+the length is wrong even if the hash codes match. It is designed to handle
+files over 4GB on a 32-bit machine.
+
+If torrentcheck returns "torrent is good" at the end of its output, every
+byte of every file in the torrent is present and correct, to a high degree
+of certainty (as explained in the README file).
+
+WWW: https://sourceforge.net/projects/torrentcheck/