aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/torrentsniff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-11-14 22:49:14 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-11-14 22:49:14 +0000
commitee3e9393b00491d22f914ae4b247b0ccbed59c53 (patch)
treeb5d160a58da0205c4423258d4581f941e67a72d3 /net-p2p/torrentsniff
parent9c917bf574757794879c55d1069ad43ec63b83cd (diff)
downloadports-ee3e9393b00491d22f914ae4b247b0ccbed59c53.tar.gz
ports-ee3e9393b00491d22f914ae4b247b0ccbed59c53.zip
Add torrentsniff, a commandline tool to display information
about a torrent like file names and a number of seeds and peers. PR: ports/54272 (based on) Approved by: adamw (mentor)
Notes
Notes: svn path=/head/; revision=93980
Diffstat (limited to 'net-p2p/torrentsniff')
-rw-r--r--net-p2p/torrentsniff/Makefile30
-rw-r--r--net-p2p/torrentsniff/distinfo1
-rw-r--r--net-p2p/torrentsniff/files/patch-BitTorrent-BDecode.pm10
-rw-r--r--net-p2p/torrentsniff/files/patch-torrentsniff11
-rw-r--r--net-p2p/torrentsniff/pkg-descr8
-rw-r--r--net-p2p/torrentsniff/pkg-plist3
6 files changed, 63 insertions, 0 deletions
diff --git a/net-p2p/torrentsniff/Makefile b/net-p2p/torrentsniff/Makefile
new file mode 100644
index 000000000000..59deef6d85e4
--- /dev/null
+++ b/net-p2p/torrentsniff/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: torrentsniff
+# Date created: 06 July 2003
+# Whom: Pav Lucistnik <pav@oook.cz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= torrentsniff
+PORTVERSION= 0.3.0
+CATEGORIES= net perl5
+MASTER_SITES= http://www.highprogrammer.com/alan/perl/
+
+MAINTAINER= pav@FreeBSD.org
+COMMENT= Commandline tool for getting status of torrent
+
+RUN_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
+
+USE_PERL5= yes
+NO_BUILD= yes
+
+post-patch:
+ ${PERL} -pi -e "s#/usr/local/bin/perl#${PERL5}#" ${WRKSRC}/torrentsniff
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/torrentsniff ${LOCALBASE}/bin
+ ${MKDIR} ${SITE_PERL}/BitTorrent
+ ${INSTALL_DATA} ${WRKSRC}/BitTorrent/BDecode.pm ${SITE_PERL}/BitTorrent
+
+.include <bsd.port.mk>
diff --git a/net-p2p/torrentsniff/distinfo b/net-p2p/torrentsniff/distinfo
new file mode 100644
index 000000000000..945ef244491c
--- /dev/null
+++ b/net-p2p/torrentsniff/distinfo
@@ -0,0 +1 @@
+MD5 (torrentsniff-0.3.0.tar.gz) = 3884cac276a990a95ea77738195508aa
diff --git a/net-p2p/torrentsniff/files/patch-BitTorrent-BDecode.pm b/net-p2p/torrentsniff/files/patch-BitTorrent-BDecode.pm
new file mode 100644
index 000000000000..9caadb0eda4e
--- /dev/null
+++ b/net-p2p/torrentsniff/files/patch-BitTorrent-BDecode.pm
@@ -0,0 +1,10 @@
+--- BitTorrent/BDecode.pm.orig Sun Jun 15 05:47:46 2003
++++ BitTorrent/BDecode.pm Fri Nov 14 18:42:44 2003
+@@ -5,7 +5,6 @@
+ use Carp;
+ use base 'Exporter';
+ use strict;
+-our @EXPORT_OK = qw(bdecode);
+
+ sub bdecode {
+ my ($dataref) = @_;
diff --git a/net-p2p/torrentsniff/files/patch-torrentsniff b/net-p2p/torrentsniff/files/patch-torrentsniff
new file mode 100644
index 000000000000..03062bb7be8e
--- /dev/null
+++ b/net-p2p/torrentsniff/files/patch-torrentsniff
@@ -0,0 +1,11 @@
+--- torrentsniff.orig Fri Nov 14 18:17:20 2003
++++ torrentsniff Fri Nov 14 18:27:24 2003
+@@ -115,7 +115,7 @@
+ my($file, $report_file_info, $report_tracker_info) = @_;
+ print "$file\n";
+ local *TOR;
+- if( not open(TOR, "<", $file) ) {
++ if( not open(TOR, "< $file") ) {
+ print STDERR "Unable to read $file because of $!\n";
+ return 0;
+ }
diff --git a/net-p2p/torrentsniff/pkg-descr b/net-p2p/torrentsniff/pkg-descr
new file mode 100644
index 000000000000..24bf555b5635
--- /dev/null
+++ b/net-p2p/torrentsniff/pkg-descr
@@ -0,0 +1,8 @@
+TorrentSniff is a command line Perl program that reads a BitTorrent .torrent
+file from the local file system or from a URL and reports on the status of the
+torrent.
+
+TorrentSniff is based on an early version of TorrentSpy. Reporting seed and
+leech numbers works only with some tracker implementations.
+
+WWW: http://www.highprogrammer.com/alan/perl/torrentsniff.html
diff --git a/net-p2p/torrentsniff/pkg-plist b/net-p2p/torrentsniff/pkg-plist
new file mode 100644
index 000000000000..3ad613bb1f47
--- /dev/null
+++ b/net-p2p/torrentsniff/pkg-plist
@@ -0,0 +1,3 @@
+bin/torrentsniff
+%%SITE_PERL%%/BitTorrent/BDecode.pm
+@dirrm %%SITE_PERL%%/BitTorrent