aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/transmission-cli
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2007-04-23 21:18:01 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2007-04-23 21:18:01 +0000
commit4972deae12beb73bbc23d647d279111ddf890e89 (patch)
tree7ceae571fa53542b9ea6ed508bae69d270f664ff /net-p2p/transmission-cli
parent3c7dfb5dbac87ee652f3dcbcef53ebb66b226489 (diff)
downloadports-4972deae12beb73bbc23d647d279111ddf890e89.tar.gz
ports-4972deae12beb73bbc23d647d279111ddf890e89.zip
Update to 0.70, as for transmission-gtk2, the prefix has been changed from
X11BASE to LOCALBASE.
Notes
Notes: svn path=/head/; revision=190758
Diffstat (limited to 'net-p2p/transmission-cli')
-rw-r--r--net-p2p/transmission-cli/Makefile21
-rw-r--r--net-p2p/transmission-cli/distinfo6
-rw-r--r--net-p2p/transmission-cli/files/patch-configure11
-rw-r--r--net-p2p/transmission-cli/files/patch-version.sh12
4 files changed, 24 insertions, 26 deletions
diff --git a/net-p2p/transmission-cli/Makefile b/net-p2p/transmission-cli/Makefile
index beb9ec794dd8..4dee64496770 100644
--- a/net-p2p/transmission-cli/Makefile
+++ b/net-p2p/transmission-cli/Makefile
@@ -6,17 +6,16 @@
#
PORTNAME= transmission
-PORTVERSION= 0.6.1
+PORTVERSION= 0.70
PORTREVISION?= 0
CATEGORIES= net-p2p
-MASTER_SITES= http://download.m0k.org/${PORTNAME}/files/ \
- ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR=mezz
-DISTNAME= Transmission-${PORTVERSION}
+MASTER_SITES= http://download.m0k.org/${PORTNAME}/files/
+DISTNAME= Transmission-${PORTVERSION:S/70/7/}
MAINTAINER= mezz@FreeBSD.org
COMMENT?= A free BitTorrent client written from scratch in C
+WRKSRC= ${WRKDIR}/Transmission-${PORTVERSION}
USE_GMAKE= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS?=--prefix=${PREFIX} \
@@ -24,8 +23,6 @@ CONFIGURE_ARGS?=--prefix=${PREFIX} \
EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude beos \
--exclude macosx \
- --exclude packageOSX.sh \
- --exclude Sparkle.framework \
--exclude Transmission.xcodeproj
DOCS= AUTHORS LICENSE NEWS README
@@ -33,8 +30,6 @@ DOCS= AUTHORS LICENSE NEWS README
.if defined(SLAVE_TRANS)
EXTRACT_AFTER_ARGS+=--exclude cli
.else
-CFLAGS+= ${CPPFLAGS}
-USE_GETOPT_LONG=yes
EXTRACT_AFTER_ARGS+=--exclude gtk
MAN1= transmissioncli.1
.endif
@@ -49,8 +44,6 @@ pre-everything::
.if !defined(WITHOUT_OPENSSL)
@${ECHO_MSG} "You may specify the following on the command line:"
@${ECHO_MSG} " "
-.endif
-.if !defined(WITHOUT_OPENSSL)
@${ECHO_MSG} "WITHOUT_OPENSSL=yes to disable OpenSSL support, using built-in SHA1 implementation. Warning, it is a bit slower if you use this option." | ${FMT} 75 75
.endif
@@ -61,15 +54,19 @@ general-patch:
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g ; \
s|-g -Wall -W -O3 -funroll-loops|-Wall -W|g' \
${WRKSRC}/mk/common.mk
+ @${REINPLACE_CMD} -e 's|) .install.misc|)|g' \
+ ${WRKSRC}/mk/default.mk
post-patch: general-patch
+general-install:
.ifndef (NOPORTDOCS)
-post-install:
@${MKDIR} ${DOCSDIR}
.for i in ${DOCS}
@${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
.endif
+post-install: general-install
+
.include <bsd.port.mk>
diff --git a/net-p2p/transmission-cli/distinfo b/net-p2p/transmission-cli/distinfo
index d501da0dd62f..e7a1e2928d6a 100644
--- a/net-p2p/transmission-cli/distinfo
+++ b/net-p2p/transmission-cli/distinfo
@@ -1,3 +1,3 @@
-MD5 (Transmission-0.6.1.tar.gz) = 1156a88c77ab71782b9261881ea13811
-SHA256 (Transmission-0.6.1.tar.gz) = e427a78c680052edffb5850e31956c077c174dfa6c22ab1433d8c03617f914c0
-SIZE (Transmission-0.6.1.tar.gz) = 447868
+MD5 (Transmission-0.7.tar.gz) = c89bb82fde303d16f63f383aa2bdc6ef
+SHA256 (Transmission-0.7.tar.gz) = 6e21f0eb2bc56b89dc045a6c65396c33844491b0fe712cb84496b2f1b45f7993
+SIZE (Transmission-0.7.tar.gz) = 1358151
diff --git a/net-p2p/transmission-cli/files/patch-configure b/net-p2p/transmission-cli/files/patch-configure
deleted file mode 100644
index b84dfde9b2ae..000000000000
--- a/net-p2p/transmission-cli/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
-Index: trunk/configure
-===================================================================
---- configure (revision 516)
-+++ configure (revision 559)
-@@ -174,5 +174,5 @@
- if runcmd pkg-config gtk+-2.0
- then
-- if runcmd expr `pkg-config --modversion gtk+-2.0` '>=' 2.6.0
-+ if runcmd pkg-config --exists gtk+-2.0 '>=' 2.6.0
- then
- cat > testconf.c << EOF
diff --git a/net-p2p/transmission-cli/files/patch-version.sh b/net-p2p/transmission-cli/files/patch-version.sh
new file mode 100644
index 000000000000..cc23ee3516c7
--- /dev/null
+++ b/net-p2p/transmission-cli/files/patch-version.sh
@@ -0,0 +1,12 @@
+--- version.sh.orig Wed Apr 18 11:24:12 2007
++++ version.sh Wed Apr 18 11:24:21 2007
+@@ -48,9 +48,4 @@
+ EOF
+ replace_if_differs libtransmission/version.h.new libtransmission/version.h
+
+-# Generate Info.plist from Info.plist.in
+-sed -e "s/%%BUNDLE_VERSION%%/$REV/" -e "s/%%SHORT_VERSION_STRING%%/$STRING/" \
+- < macosx/Info.plist.in > macosx/Info.plist.new
+-replace_if_differs macosx/Info.plist.new macosx/Info.plist
+-
+ exit 0