aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/transmission-cli
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2005-10-10 19:31:11 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2005-10-10 19:31:11 +0000
commita375cd9af92d9df04adc36a4b89ecbb9b2dfdd79 (patch)
tree60b9403dd678f0ff8729921050af780f4b82caa6 /net-p2p/transmission-cli
parent5c0706e43b43043404c5524295d17fbc6c94aead (diff)
downloadports-a375cd9af92d9df04adc36a4b89ecbb9b2dfdd79.tar.gz
ports-a375cd9af92d9df04adc36a4b89ecbb9b2dfdd79.zip
Transmission is a free BitTorrent client written from scratch in C. It aims to
be as efficient as possible. Only the Mac OS X version has a graphical interface yet. Transmission is released under the MIT license. Transmission is still in early development stage. WWW: http://transmission.m0k.org/ -- Let me know if it doesn't work with FreeBSD 4.x for USE_GETOPT_LONG and for anyone that has the different setup of OpenSSL (USE_OPENSSL). FreeBSD 4.x is untest, but FreeBSD 5.x, 6.x and 7.x have been tested. BTW: Using CVS version, because it has good bugs fixes and added FreeBSD support that I sent Eric Petit (the author/developer) a patch.
Notes
Notes: svn path=/head/; revision=144858
Diffstat (limited to 'net-p2p/transmission-cli')
-rw-r--r--net-p2p/transmission-cli/Makefile53
-rw-r--r--net-p2p/transmission-cli/distinfo2
-rw-r--r--net-p2p/transmission-cli/pkg-descr7
3 files changed, 62 insertions, 0 deletions
diff --git a/net-p2p/transmission-cli/Makefile b/net-p2p/transmission-cli/Makefile
new file mode 100644
index 000000000000..da7b1c887d48
--- /dev/null
+++ b/net-p2p/transmission-cli/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: transmission
+# Date created: 08 October 2005
+# Whom: Mezz <mezz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= transmission
+PORTVERSION= 0.2.20051009
+CATEGORIES= net
+#MASTER_SITES= http://download.m0k.org/${PORTNAME}/files/
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= mezz
+DISTNAME= Transmission-${PORTVERSION}
+
+MAINTAINER= mezz@FreeBSD.org
+COMMENT= A free BitTorrent client written from scratch in C
+
+BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam
+
+USE_OPENSSL= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+USE_GETOPT_LONG=yes
+
+EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude macosx \
+ --exclude packageOSX.sh
+
+PLIST_FILES= bin/transmissioncli
+PORTDOCS= AUTHORS LICENSE NEWS README
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g ; \
+ s|$$LINKLIBS ;|${LDFLAGS} $$LINKLIBS ;|g' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-O3||g ; \
+ s|-g |${CFLAGS} ${CPPFLAGS} ${PTHREAD_CFLAGS}|g' \
+ ${WRKSRC}/Jamrules
+
+# jam -dx, it will giving a verbose of build.
+do-build:
+ @(cd ${BUILD_WRKSRC} ; ${SETENV} ${MAKE_ENV} jam)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/transmissioncli ${PREFIX}/bin/
+.ifndef (NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-p2p/transmission-cli/distinfo b/net-p2p/transmission-cli/distinfo
new file mode 100644
index 000000000000..add1d0cca2c5
--- /dev/null
+++ b/net-p2p/transmission-cli/distinfo
@@ -0,0 +1,2 @@
+MD5 (Transmission-0.2.20051009.tar.gz) = 1ca6e92280d6cbf5465344b49eb6e10a
+SIZE (Transmission-0.2.20051009.tar.gz) = 141614
diff --git a/net-p2p/transmission-cli/pkg-descr b/net-p2p/transmission-cli/pkg-descr
new file mode 100644
index 000000000000..96a46498eea2
--- /dev/null
+++ b/net-p2p/transmission-cli/pkg-descr
@@ -0,0 +1,7 @@
+Transmission is a free BitTorrent client written from scratch in C. It aims to
+be as efficient as possible. Only the Mac OS X version has a graphical
+interface yet. Transmission is released under the MIT license.
+
+Transmission is still in early development stage.
+
+WWW: http://transmission.m0k.org/