aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/transmission-cli
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2007-08-24 20:05:01 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2007-08-24 20:05:01 +0000
commitd2d9c480fb21af57638cb11b95e0f02f2c08b09f (patch)
treed97bb9df94423ff75389ab5f525c4b78322ade95 /net-p2p/transmission-cli
parentc75eaadcfabc20b74a847cca8a1ebc83b2546cdd (diff)
downloadports-d2d9c480fb21af57638cb11b95e0f02f2c08b09f.tar.gz
ports-d2d9c480fb21af57638cb11b95e0f02f2c08b09f.zip
Update to 0.81.
Notes
Notes: svn path=/head/; revision=198266
Diffstat (limited to 'net-p2p/transmission-cli')
-rw-r--r--net-p2p/transmission-cli/Makefile8
-rw-r--r--net-p2p/transmission-cli/distinfo6
-rw-r--r--net-p2p/transmission-cli/files/patch-libtransmission_torrent.c13
3 files changed, 8 insertions, 19 deletions
diff --git a/net-p2p/transmission-cli/Makefile b/net-p2p/transmission-cli/Makefile
index 6dffdee52946..d91e3e6c0336 100644
--- a/net-p2p/transmission-cli/Makefile
+++ b/net-p2p/transmission-cli/Makefile
@@ -6,16 +6,18 @@
#
PORTNAME= transmission
-PORTVERSION= 0.80
+PORTVERSION= 0.81
PORTREVISION?= 0
CATEGORIES= net-p2p
-MASTER_SITES= http://download.m0k.org/${PORTNAME}/files/
+#MASTER_SITES= http://download.m0k.org/${PORTNAME}/files/
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ http://people.freebsd.org/~mezz/distfiles/
+MASTER_SITE_SUBDIR=mezz
DISTNAME= Transmission-${PORTVERSION}
MAINTAINER= mezz@FreeBSD.org
COMMENT?= A free BitTorrent client written from scratch in C
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GMAKE= yes
SLAVE_TRANS?= no
HAS_CONFIGURE= yes
diff --git a/net-p2p/transmission-cli/distinfo b/net-p2p/transmission-cli/distinfo
index 1c2461268d4d..5c495fb78960 100644
--- a/net-p2p/transmission-cli/distinfo
+++ b/net-p2p/transmission-cli/distinfo
@@ -1,3 +1,3 @@
-MD5 (Transmission-0.80.tar.gz) = 5fde1bc0f8c3c31daaa202680e00d44a
-SHA256 (Transmission-0.80.tar.gz) = d05d158d23e819d7a4f06eee92c158a86be52b18af838927f19be8897050f06e
-SIZE (Transmission-0.80.tar.gz) = 2283341
+MD5 (Transmission-0.81.tar.gz) = b672f380cda612c4d825d864ebc36d89
+SHA256 (Transmission-0.81.tar.gz) = cabbd5273835c0fa078fd35ed3f01c4fd19a729bd20777dfff5a69795c5dfd48
+SIZE (Transmission-0.81.tar.gz) = 2257245
diff --git a/net-p2p/transmission-cli/files/patch-libtransmission_torrent.c b/net-p2p/transmission-cli/files/patch-libtransmission_torrent.c
deleted file mode 100644
index 90c4162c14ab..000000000000
--- a/net-p2p/transmission-cli/files/patch-libtransmission_torrent.c
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: /branches/0.8x/libtransmission/torrent.c
-===================================================================
---- /branches/0.8x/libtransmission/torrent.c (revision 2573)
-+++ libtransmission/torrent.c (revision 2650)
-@@ -736,6 +736,6 @@
- assert( 0<=fileIndex && fileIndex<tor->info.fileCount );
- assert( file->offset + file->length <= tor->info.totalSize );
-- assert( (int)firstBlock < tor->blockCount );
-- assert( (int)lastBlock < tor->blockCount );
-+ assert( ( (int)firstBlock < tor->blockCount ) || (!file->length && file->offset==tor->info.totalSize) );
-+ assert( ( (int)lastBlock < tor->blockCount ) || (!file->length && file->offset==tor->info.totalSize) );
- assert( firstBlock <= lastBlock );
- assert( (int)tr_torBlockPiece( tor, firstBlock ) == file->firstPiece );