aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/zetacoin
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-09-19 16:41:59 +0000
committerJohn Marino <marino@FreeBSD.org>2016-09-19 16:41:59 +0000
commitceb10318ae0ec43ff19a9bcd77c98da625fc840a (patch)
tree142624ed072f5be58f38d230ccd2f1a66ec51156 /net-p2p/zetacoin
parenta0a8861d09e9e409c0f55ecc2f9c415c5d13425f (diff)
downloadports-ceb10318ae0ec43ff19a9bcd77c98da625fc840a.tar.gz
ports-ceb10318ae0ec43ff19a9bcd77c98da625fc840a.zip
net-p2p/zetacoin: IGNORE when SSL_DEFAULT matches libressl
Zetacoin explicitly fails to configure when libressl is detected. It can only be built with OpenSSL right now (similar to litecoin). Approved by: SSL blanket
Notes
Notes: svn path=/head/; revision=422448
Diffstat (limited to 'net-p2p/zetacoin')
-rw-r--r--net-p2p/zetacoin/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/net-p2p/zetacoin/Makefile b/net-p2p/zetacoin/Makefile
index 78953a2f6674..2858ad4b74b9 100644
--- a/net-p2p/zetacoin/Makefile
+++ b/net-p2p/zetacoin/Makefile
@@ -91,6 +91,13 @@ USERS= ${PORTNAME}
GROUPS= ${PORTNAME}
.endif
+.include <bsd.port.pre.mk>
+
+.if ${SSL_DEFAULT:Mlibressl*}
+# The configure script will output this message, so save the user the trouble
+IGNORE= Detected LibreSSL: This is NOT supported, and may break consensus compatibility!
+.endif
+
post-patch:
${MKDIR} ${WRKSRC}/src/build-aux
@@ -113,4 +120,4 @@ do-install-X11-off:
${INSTALL_PROGRAM} -s ${WRKSRC}/src/${DAEMON} ${STAGEDIR}${PREFIX}/bin/${DAEMON}
${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.conf.sample ${STAGEDIR}${PREFIX}/etc/${PORTNAME}.conf.sample
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>