aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2010-07-06 00:13:06 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2010-07-06 00:13:06 +0000
commit00094fc602567f1ad37fa01370f2ca3991e4cfce (patch)
tree046b95278df5762791af1633228fea4f1a13dcbb /net-p2p
parentdbebd471caf7dbeb1294ad96efb73e6cd819d566 (diff)
downloadports-00094fc602567f1ad37fa01370f2ca3991e4cfce.tar.gz
ports-00094fc602567f1ad37fa01370f2ca3991e4cfce.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/Makefile1
-rw-r--r--net-p2p/mktorrent/Makefile46
-rw-r--r--net-p2p/mktorrent/distinfo3
-rw-r--r--net-p2p/mktorrent/pkg-descr5
4 files changed, 55 insertions, 0 deletions
diff --git a/net-p2p/Makefile b/net-p2p/Makefile
index 4e7baa04ad46..23231f644058 100644
--- a/net-p2p/Makefile
+++ b/net-p2p/Makefile
@@ -75,6 +75,7 @@
SUBDIR += lopster
SUBDIR += microdc2
SUBDIR += minder
+ SUBDIR += mktorrent
SUBDIR += mldonkey
SUBDIR += mldonkey-core
SUBDIR += mldonkey-gui
diff --git a/net-p2p/mktorrent/Makefile b/net-p2p/mktorrent/Makefile
new file mode 100644
index 000000000000..6cff3bd2f0e0
--- /dev/null
+++ b/net-p2p/mktorrent/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: mktorrent
+# Date created: 9 May 2010
+# Whom: Damian Gerow <dgerow@afflictions.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mktorrent
+PORTVERSION= 1.0
+CATEGORIES= net-p2p
+MASTER_SITES= SF
+
+MAINTAINER= dgerow@afflictions.org
+COMMENT= A command-line utility for creating BitTorrent metainfo files
+
+MAKEFILE= BSDmakefile
+MAKE_FLAGS= USE_LONG_OPTIONS=1
+
+PLIST_FILES= bin/mktorrent
+
+OPTIONS= THREADS "Enable support for pthreads" on \
+ OPENSSL "Use OpenSSL for hashing" on \
+ HASHCHECK "Verify file hashes" on
+
+.include <bsd.port.options.mk>
+
+.if !defined(WITHOUT_THREADS)
+MAKE_FLAGS+= USE_PTHREADS=1
+.endif
+
+.if !defined(WITHOUT_OPENSSL)
+MAKE_FLAGS+= USE_OPENSSL=1
+USE_OPENSSL= yes
+.endif
+
+.if defined(WITHOUT_HASHCHECK)
+MAKE_FLAGS+= NO_HASH_CHECK=1
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|g" ${WRKSRC}/BSDmakefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net-p2p/mktorrent/distinfo b/net-p2p/mktorrent/distinfo
new file mode 100644
index 000000000000..3817914a8b82
--- /dev/null
+++ b/net-p2p/mktorrent/distinfo
@@ -0,0 +1,3 @@
+MD5 (mktorrent-1.0.tar.gz) = 0da00209da96a0dc39efbb6eb5b4d8ff
+SHA256 (mktorrent-1.0.tar.gz) = 6f8e562af6366e0d9bde76e434f740b55722c6c3c555860dbe80083f9d1d119f
+SIZE (mktorrent-1.0.tar.gz) = 23089
diff --git a/net-p2p/mktorrent/pkg-descr b/net-p2p/mktorrent/pkg-descr
new file mode 100644
index 000000000000..2c2cdfa5227a
--- /dev/null
+++ b/net-p2p/mktorrent/pkg-descr
@@ -0,0 +1,5 @@
+mktorrent is a simple command-line utility to create BitTorrent
+metainfo files. It supports multiple trackers, private trackers,
+custom comments, and is multi-threaded to support multiple CPUs.
+
+WWW: http://mktorrent.sourceforge.net/