aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-12-12 07:47:44 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-12-12 07:47:44 +0000
commit54270f7f77f99f82832db92e555e3468ee943e49 (patch)
tree66ac2eebb151904702c06ba1a01d48ad1f0e60e4 /net-p2p
parent5685fe1b7a7616130e7bcb89ec2617dbd6290919 (diff)
downloadports-54270f7f77f99f82832db92e555e3468ee943e49.tar.gz
ports-54270f7f77f99f82832db92e555e3468ee943e49.zip
net-p2p/libtorrent-rasterbar: drop clang workaround (reverting r529947)
Old -CURRENT snapshots are not supported while Clang assertions are disabled on FreeBSD -RELEASEs and -STABLE branches. PR: 244830
Notes
Notes: svn path=/head/; revision=557802
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/libtorrent-rasterbar/Makefile17
1 files changed, 1 insertions, 16 deletions
diff --git a/net-p2p/libtorrent-rasterbar/Makefile b/net-p2p/libtorrent-rasterbar/Makefile
index 1d1443285d2f..20e81a22c37e 100644
--- a/net-p2p/libtorrent-rasterbar/Makefile
+++ b/net-p2p/libtorrent-rasterbar/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libboost_chrono.so:devel/boost-libs \
libboost_random.so:devel/boost-libs \
libboost_system.so:devel/boost-libs
-USES= cmake iconv:wchar_t libtool localbase:ldflags pathfix pkgconfig python:test shebangfix ssl
+USES= cmake compiler:c++11-lib iconv:wchar_t libtool localbase:ldflags pathfix pkgconfig python:test shebangfix ssl
SHEBANG_FILES= test/socks.py test/web_server.py
USE_LDCONFIG= yes
@@ -37,21 +37,6 @@ LOGGING_DESC= Enable logging to disk
EXAMPLES_CMAKE_BOOL= build_examples
LOGGING_CMAKE_BOOL= logging
-.include <bsd.port.options.mk>
-
-.if !${ARCH:Mpowerpc*} && ${OPSYS}_${OSREL:R} == FreeBSD_13 && ${OSVERSION} < 1300093
-# workaroud for the clang-10 compiler failure: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=244830
-# on powerpc, llvm 9 crashes with segfault, while 10 works https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=243958
-# on powerpc64 elfv1, clang doesn't work at all (no support for elfv1), on elfv2 clang from base works ok
-LLVM_VER= 90
-BUILD_DEPENDS+= clang${LLVM_VER}:devel/llvm${LLVM_VER}
-CPP= clang-cpp${LLVM_VER}
-CC= clang${LLVM_VER}
-CXX= clang++${LLVM_VER}
-.else
-USES+= compiler:c++11-lang
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|return "python3";|return "${PYTHON_CMD}";|' \
${WRKSRC}/test/setup_transfer.cpp