aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-05-16 16:09:15 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-05-16 16:09:15 +0000
commit5671b14afb3f8c18421ddd41f0f7a32817c44e3d (patch)
tree8fe5d5845648a4177013c69d8cad26b8d907eadd /net-p2p
parent46861b31d94656e17a5cfee0728aeec20edbf945 (diff)
downloadports-5671b14afb3f8c18421ddd41f0f7a32817c44e3d.tar.gz
ports-5671b14afb3f8c18421ddd41f0f7a32817c44e3d.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/eiskaltdcpp-lib/Makefile2
-rw-r--r--net-p2p/eiskaltdcpp-lib/files/patch-dcpp-Atomic.h25
-rw-r--r--net-p2p/libtorrent-rasterbar-14/Makefile2
-rw-r--r--net-p2p/libtorrent-rasterbar-14/files/patch-include-libtorrent-create_torrent.hpp11
-rw-r--r--net-p2p/libtorrent-rasterbar-14/files/patch-include-libtorrent-debug.hpp11
-rw-r--r--net-p2p/libtorrent-rasterbar-14/files/patch-src-create_torrent.cpp11
-rw-r--r--net-p2p/libtorrent-rasterbar-14/files/patch-src-file.cpp11
-rw-r--r--net-p2p/libtorrent-rasterbar-14/files/patch-src-file_storage.cpp14
-rw-r--r--net-p2p/libtorrent-rasterbar-14/files/patch-src-logger.cpp11
-rw-r--r--net-p2p/libtorrent-rasterbar-14/files/patch-src-storage.cpp90
-rw-r--r--net-p2p/libtorrent-rasterbar-14/files/patch-src-torrent_info.cpp11
11 files changed, 197 insertions, 2 deletions
diff --git a/net-p2p/eiskaltdcpp-lib/Makefile b/net-p2p/eiskaltdcpp-lib/Makefile
index c8ad8b8bef62..7f9d77a891ae 100644
--- a/net-p2p/eiskaltdcpp-lib/Makefile
+++ b/net-p2p/eiskaltdcpp-lib/Makefile
@@ -7,7 +7,7 @@
PORTNAME= eiskaltdcpp-lib
PORTVERSION= 2.2.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-p2p
MASTER_SITES= GOOGLE_CODE
DISTNAME= eiskaltdcpp-${DISTVERSION}
diff --git a/net-p2p/eiskaltdcpp-lib/files/patch-dcpp-Atomic.h b/net-p2p/eiskaltdcpp-lib/files/patch-dcpp-Atomic.h
new file mode 100644
index 000000000000..3d8eb02871a8
--- /dev/null
+++ b/net-p2p/eiskaltdcpp-lib/files/patch-dcpp-Atomic.h
@@ -0,0 +1,25 @@
+--- dcpp/Atomic.h.orig 2012-01-27 21:20:06.000000000 +0300
++++ dcpp/Atomic.h 2012-01-27 21:21:11.000000000 +0300
+@@ -57,18 +57,18 @@
+
+ // type cast
+ operator value_type() const {
+- return boost::interprocess::detail::atomic_read32(&m_value);
++ return boost::interprocess::ipcdetail::atomic_read32(&m_value);
+ }
+
+ // increment
+- void inc() { boost::interprocess::detail::atomic_inc32(&m_value); }
++ void inc() { boost::interprocess::ipcdetail::atomic_inc32(&m_value); }
+
+ // decrement
+- void dec() { boost::interprocess::detail::atomic_dec32(&m_value); }
++ void dec() { boost::interprocess::ipcdetail::atomic_dec32(&m_value); }
+
+ private:
+ mutable value_type m_value;
+- void assign(value_type val) { boost::interprocess::detail::atomic_write32(&m_value, val); }
++ void assign(value_type val) { boost::interprocess::ipcdetail::atomic_write32(&m_value, val); }
+ };
+
+ // int32_t
diff --git a/net-p2p/libtorrent-rasterbar-14/Makefile b/net-p2p/libtorrent-rasterbar-14/Makefile
index 7fb79a8aa9f0..82c527654d70 100644
--- a/net-p2p/libtorrent-rasterbar-14/Makefile
+++ b/net-p2p/libtorrent-rasterbar-14/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libtorrent-rasterbar
PORTVERSION= 0.14.12
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-p2p ipv6
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PROJECTHOST= libtorrent
diff --git a/net-p2p/libtorrent-rasterbar-14/files/patch-include-libtorrent-create_torrent.hpp b/net-p2p/libtorrent-rasterbar-14/files/patch-include-libtorrent-create_torrent.hpp
new file mode 100644
index 000000000000..1a5ede745a3f
--- /dev/null
+++ b/net-p2p/libtorrent-rasterbar-14/files/patch-include-libtorrent-create_torrent.hpp
@@ -0,0 +1,11 @@
+--- include/libtorrent/create_torrent.hpp.orig 2012-01-27 21:05:27.000000000 +0300
++++ include/libtorrent/create_torrent.hpp 2012-01-27 21:05:56.000000000 +0300
+@@ -152,7 +152,7 @@
+ #if BOOST_VERSION < 103600
+ std::string leaf = i->path().leaf();
+ #else
+- std::string leaf = i->path().filename();
++ std::string leaf = i->path().filename().string();
+ #endif
+ if (leaf == ".." || leaf == ".") continue;
+ add_files_impl(fs, p, l / leaf, pred);
diff --git a/net-p2p/libtorrent-rasterbar-14/files/patch-include-libtorrent-debug.hpp b/net-p2p/libtorrent-rasterbar-14/files/patch-include-libtorrent-debug.hpp
new file mode 100644
index 000000000000..112b73bb973e
--- /dev/null
+++ b/net-p2p/libtorrent-rasterbar-14/files/patch-include-libtorrent-debug.hpp
@@ -0,0 +1,11 @@
+--- include/libtorrent/debug.hpp.orig 2012-01-27 20:16:02.000000000 +0300
++++ include/libtorrent/debug.hpp 2012-01-27 20:16:23.000000000 +0300
+@@ -64,7 +64,7 @@
+ try
+ {
+ #endif
+- fs::path dir(fs::complete(logpath / ("libtorrent_logs" + boost::lexical_cast<std::string>(instance))));
++ fs::path dir(fs::absolute(logpath / ("libtorrent_logs" + boost::lexical_cast<std::string>(instance))));
+ if (!fs::exists(dir)) fs::create_directories(dir);
+ m_file.open((dir / filename).string().c_str(), std::ios_base::out | (append ? std::ios_base::app : std::ios_base::out));
+ *this << "\n\n\n*** starting log ***\n";
diff --git a/net-p2p/libtorrent-rasterbar-14/files/patch-src-create_torrent.cpp b/net-p2p/libtorrent-rasterbar-14/files/patch-src-create_torrent.cpp
new file mode 100644
index 000000000000..f3be87da0a67
--- /dev/null
+++ b/net-p2p/libtorrent-rasterbar-14/files/patch-src-create_torrent.cpp
@@ -0,0 +1,11 @@
+--- src/create_torrent.cpp.orig 2010-01-19 04:42:35.000000000 +0300
++++ src/create_torrent.cpp 2012-01-27 21:04:43.000000000 +0300
+@@ -217,7 +217,7 @@
+ for (fs::path::iterator j = boost::next(i->path.begin());
+ j != i->path.end(); ++j)
+ {
+- path_e.list().push_back(entry(*j));
++ path_e.list().push_back(entry((*j).string()));
+ }
+ }
+ }
diff --git a/net-p2p/libtorrent-rasterbar-14/files/patch-src-file.cpp b/net-p2p/libtorrent-rasterbar-14/files/patch-src-file.cpp
new file mode 100644
index 000000000000..8f739d6d5f7b
--- /dev/null
+++ b/net-p2p/libtorrent-rasterbar-14/files/patch-src-file.cpp
@@ -0,0 +1,11 @@
+--- src/file.cpp.orig 2012-01-27 20:46:48.000000000 +0300
++++ src/file.cpp 2012-01-27 20:47:10.000000000 +0300
+@@ -207,7 +207,7 @@
+ | S_IRGRP | S_IWGRP
+ | S_IROTH | S_IWOTH;
+
+- m_fd = ::open(path.external_file_string().c_str()
++ m_fd = ::open(path.native().c_str()
+ , map_open_mode(mode.m_mask), permissions);
+
+ if (m_fd == -1)
diff --git a/net-p2p/libtorrent-rasterbar-14/files/patch-src-file_storage.cpp b/net-p2p/libtorrent-rasterbar-14/files/patch-src-file_storage.cpp
new file mode 100644
index 000000000000..8005b61ef6c6
--- /dev/null
+++ b/net-p2p/libtorrent-rasterbar-14/files/patch-src-file_storage.cpp
@@ -0,0 +1,14 @@
+--- src/file_storage.cpp.orig 2012-01-27 20:52:46.000000000 +0300
++++ src/file_storage.cpp 2012-01-27 20:54:50.000000000 +0300
+@@ -147,9 +147,9 @@
+ else
+ {
+ if (m_files.empty())
+- m_name = *file.begin();
++ m_name = (*file.begin()).string();
+ }
+- TORRENT_ASSERT(m_name == *file.begin());
++ TORRENT_ASSERT(m_name == (*file.begin()).string());
+ file_entry e;
+ m_files.push_back(e);
+ m_files.back().size = size;
diff --git a/net-p2p/libtorrent-rasterbar-14/files/patch-src-logger.cpp b/net-p2p/libtorrent-rasterbar-14/files/patch-src-logger.cpp
new file mode 100644
index 000000000000..98b98117a919
--- /dev/null
+++ b/net-p2p/libtorrent-rasterbar-14/files/patch-src-logger.cpp
@@ -0,0 +1,11 @@
+--- src/logger.cpp.orig 2012-01-27 20:49:39.000000000 +0300
++++ src/logger.cpp 2012-01-27 20:49:56.000000000 +0300
+@@ -63,7 +63,7 @@
+ {
+ logger_peer_plugin(std::string const& filename)
+ {
+- fs::path dir(fs::complete("libtorrent_ext_logs"));
++ fs::path dir(fs::absolute("libtorrent_ext_logs"));
+ if (!fs::exists(dir)) fs::create_directories(dir);
+ m_file.open((dir / filename).string().c_str(), std::ios_base::out | std::ios_base::out);
+ m_file << "\n\n\n";
diff --git a/net-p2p/libtorrent-rasterbar-14/files/patch-src-storage.cpp b/net-p2p/libtorrent-rasterbar-14/files/patch-src-storage.cpp
new file mode 100644
index 000000000000..d018605a9f9f
--- /dev/null
+++ b/net-p2p/libtorrent-rasterbar-14/files/patch-src-storage.cpp
@@ -0,0 +1,90 @@
+--- src/storage.cpp.orig 2010-09-06 03:59:03.000000000 +0400
++++ src/storage.cpp 2012-01-27 20:39:22.000000000 +0300
+@@ -161,7 +161,7 @@
+ template <class Path>
+ void recursive_copy(Path const& old_path, Path const& new_path, error_code& ec)
+ {
+- using boost::filesystem::basic_directory_iterator;
++ using boost::filesystem::directory_iterator;
+ #ifndef BOOST_NO_EXCEPTIONS
+ try {
+ #endif
+@@ -169,7 +169,7 @@
+ if (is_directory(old_path))
+ {
+ create_directory(new_path);
+- for (basic_directory_iterator<Path> i(old_path), end; i != end; ++i)
++ for (directory_iterator i(old_path), end; i != end; ++i)
+ {
+ #if BOOST_VERSION < 103600
+ recursive_copy(i->path(), new_path / i->path().leaf(), ec);
+@@ -202,13 +202,13 @@
+ template <class Path>
+ void recursive_remove(Path const& old_path)
+ {
+- using boost::filesystem::basic_directory_iterator;
++ using boost::filesystem::directory_iterator;
+ #ifndef BOOST_NO_EXCEPTIONS
+ try {
+ #endif
+ if (is_directory(old_path))
+ {
+- for (basic_directory_iterator<Path> i(old_path), end; i != end; ++i)
++ for (directory_iterator i(old_path), end; i != end; ++i)
+ recursive_remove(i->path());
+ remove(old_path);
+ }
+@@ -301,7 +301,7 @@
+ || (!compact_mode && size < s->first))
+ {
+ if (error) *error = "filesize mismatch for file '"
+- + i->path.external_file_string()
++ + i->path.native()
+ + "', size: " + boost::lexical_cast<std::string>(size)
+ + ", expected to be " + boost::lexical_cast<std::string>(s->first)
+ + " bytes";
+@@ -314,7 +314,7 @@
+ (!compact_mode && (time > s->second + 5 * 60 || time < s->second - 1)))
+ {
+ if (error) *error = "timestamp mismatch for file '"
+- + i->path.external_file_string()
++ + i->path.native()
+ + "', modification date: " + boost::lexical_cast<std::string>(time)
+ + ", expected to have modification date "
+ + boost::lexical_cast<std::string>(s->second);
+@@ -334,7 +334,7 @@
+ if (mapped) m_mapped_files.reset(new file_storage(*mapped));
+
+ TORRENT_ASSERT(m_files.begin() != m_files.end());
+- m_save_path = fs::complete(path);
++ m_save_path = fs::absolute(path);
+ TORRENT_ASSERT(m_save_path.is_complete());
+ }
+
+@@ -781,7 +781,7 @@
+ {
+ if (i->size != fs->first)
+ {
+- error = "file size for '" + i->path.external_file_string()
++ error = "file size for '" + i->path.native()
+ + "' was expected to be "
+ + boost::lexical_cast<std::string>(i->size) + " bytes";
+ return false;
+@@ -828,7 +828,7 @@
+ for (file_storage::iterator i = f.begin()
+ , end(f.end()); i != end; ++i)
+ {
+- to_move.insert(to_move.begin(), *i->path.begin());
++ to_move.insert(to_move.begin(), (*i->path.begin()).string());
+ }
+
+ for (std::set<std::string>::const_iterator i = to_move.begin()
+@@ -1461,7 +1461,7 @@
+ {
+ if (m_storage->move_storage(save_path))
+ {
+- m_save_path = fs::complete(save_path);
++ m_save_path = fs::absolute(save_path);
+ return 0;
+ }
+ return -1;
diff --git a/net-p2p/libtorrent-rasterbar-14/files/patch-src-torrent_info.cpp b/net-p2p/libtorrent-rasterbar-14/files/patch-src-torrent_info.cpp
new file mode 100644
index 000000000000..82632ed24b04
--- /dev/null
+++ b/net-p2p/libtorrent-rasterbar-14/files/patch-src-torrent_info.cpp
@@ -0,0 +1,11 @@
+--- src/torrent_info.cpp.orig 2012-01-27 20:42:54.000000000 +0300
++++ src/torrent_info.cpp 2012-01-27 20:44:06.000000000 +0300
+@@ -199,7 +199,7 @@
+ fs::path new_path;
+ for (fs::path::const_iterator i = p.begin(); i != p.end(); ++i)
+ {
+- if (!valid_path_element(*i)) continue;
++ if (!valid_path_element((*i).string())) continue;
+ new_path /= *i;
+ }
+ TORRENT_ASSERT(!new_path.is_complete());