aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorRobert Noland <rnoland@FreeBSD.org>2009-12-01 21:05:21 +0000
committerRobert Noland <rnoland@FreeBSD.org>2009-12-01 21:05:21 +0000
commit57dd744e404d29cd6a5bc93cabb1be8dd12e78e3 (patch)
tree4b2ddae85d2e431d59fcaada523ea81ba4c5e41c /net-p2p
parent532b105cc83a8ffd5c2bdef62acf043a2c9b8188 (diff)
downloadports-57dd744e404d29cd6a5bc93cabb1be8dd12e78e3.tar.gz
ports-57dd744e404d29cd6a5bc93cabb1be8dd12e78e3.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/vuze/Makefile21
-rw-r--r--net-p2p/vuze/distinfo6
-rw-r--r--net-p2p/vuze/files/build.xml6
-rw-r--r--net-p2p/vuze/files/extra-patch-com__aelitis__azureus__core__networkmanager__impl__TransportHelperFilterStream.java11
-rw-r--r--net-p2p/vuze/files/extra-patch-com__aelitis__azureus__core__networkmanager__impl__TransportHelperFilterTransparent.java11
-rw-r--r--net-p2p/vuze/files/patch-org__gudy__azureus2__platform__PlatformManagerFactory.java8
-rw-r--r--net-p2p/vuze/files/patch-org__gudy__azureus2__platform__macosx__access__jnilib__OSXAccess.java20
-rw-r--r--net-p2p/vuze/files/patch-org__gudy__azureus2__platform__unix__ScriptBeforeStartup.java11
-rw-r--r--net-p2p/vuze/files/vuze.in29
-rw-r--r--net-p2p/vuze/pkg-message2
10 files changed, 39 insertions, 86 deletions
diff --git a/net-p2p/vuze/Makefile b/net-p2p/vuze/Makefile
index 913970560631..c78b4a6f400c 100644
--- a/net-p2p/vuze/Makefile
+++ b/net-p2p/vuze/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= vuze
-PORTVERSION= 4.2.0.2
-PORTREVISION= 1
+PORTVERSION= 4.3.0.4
CATEGORIES= net-p2p java
MASTER_SITES= SF/azureus/${PORTNAME}/${PORTNAME}-${PORTVERSION}
DISTNAME= Vuze_${PORTVERSION}_source
@@ -20,7 +19,7 @@ BUILD_DEPENDS= ${JAVALIBDIR}/log4j.jar:${PORTSDIR}/devel/log4j \
${JAVALIBDIR}/junit.jar:${PORTSDIR}/java/junit
USE_JAVA= yes
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
JAVA_OS= native
USE_ANT= yes
@@ -35,12 +34,13 @@ org/gudy/azureus2/ui/swt/views/table/impl/TableViewSWTImpl.java \
com/aelitis/azureus/core/networkmanager/impl/TransportHelperFilterStream.java \
com/aelitis/azureus/core/networkmanager/impl/TransportHelperFilterTransparent.java
+USE_GECKO= libxul
+
NO_WRKSUBDIR= yes
JARFILE= ${PORTNAME}.jar
-OPTIONS= SWTDEVEL "Use SWT Development port" on \
- EXTRAHACK "Apply extra performance hack" off
+OPTIONS= SWTDEVEL "Use SWT Development port" on
# build classpath from BUILD_DEPENDS
MAKE_ENV= LANG=C
@@ -54,7 +54,8 @@ PLIST_FILES= %%JAVAJARDIR%%/${JARFILE} \
SUB_FILES= ${PORTNAME}
SUB_LIST= LIBDIR="${LOCALBASE}/lib" JARFILE="${JARFILE}" \
- SWTJAR="${JAVALIBDIR}/${SWT}.jar" JAVA="${LOCALBASE}/bin/java"
+ SWTJAR="${JAVALIBDIR}/${SWT}.jar" JAVA="${LOCALBASE}/bin/java" \
+ GECKO="${GECKO}"
DESKTOP_ENTRIES= "Vuze" \
"A full feature BitTorrent client" \
@@ -77,14 +78,6 @@ BUILD_DEPENDS+= ${JAVALIBDIR}/swt.jar:${PORTSDIR}/x11-toolkits/swt
RUN_DEPENDS+= ${JAVALIBDIR}/swt.jar:${PORTSDIR}/x11-toolkits/swt
.endif
-# Ok, I'm not quite sure why this works, or if it is in any way a proper fix.
-# Use at your own risk, I've just had it around and decided to share.
-.if defined(WITH_EXTRAHACK)
-EXTRA_PATCHES+= \
- ${PATCHDIR}/extra-patch-com__aelitis__azureus__core__networkmanager__impl__TransportHelperFilterStream.java \
- ${PATCHDIR}/extra-patch-com__aelitis__azureus__core__networkmanager__impl__TransportHelperFilterTransparent.java
-.endif
-
CLASSPATH=.
.for jar in ${CLASSPATH_JARS}
CLASSPATH:=${CLASSPATH}:${jar}
diff --git a/net-p2p/vuze/distinfo b/net-p2p/vuze/distinfo
index 15f418391fed..4fbc4ae847fa 100644
--- a/net-p2p/vuze/distinfo
+++ b/net-p2p/vuze/distinfo
@@ -1,3 +1,3 @@
-MD5 (Vuze_4.2.0.2_source.zip) = 20c2d445d4aacfb6f9f04fee21c8e3c1
-SHA256 (Vuze_4.2.0.2_source.zip) = 2bf903ea6595631bc27a76fee6ac42ff25d6a6876782ee210fb1dcfaf360b8d3
-SIZE (Vuze_4.2.0.2_source.zip) = 8717028
+MD5 (Vuze_4.3.0.4_source.zip) = b5de3ffbcd16d1c69281de21c2550fc8
+SHA256 (Vuze_4.3.0.4_source.zip) = adc7662762b2b05ea09fa0ee455ec7d6101ac0f332851d763bf8b24af29f8b15
+SIZE (Vuze_4.3.0.4_source.zip) = 8828818
diff --git a/net-p2p/vuze/files/build.xml b/net-p2p/vuze/files/build.xml
index 40f8c19cfe10..0c784e0e4e2d 100644
--- a/net-p2p/vuze/files/build.xml
+++ b/net-p2p/vuze/files/build.xml
@@ -19,7 +19,8 @@
<target name="compile" depends="init" description="compile the source " >
<!-- Compile the java code from ${src} into ${build} -->
- <javac srcdir="." destdir="${build}" fork="yes" memoryMaximumSize="512m">
+ <javac srcdir="." destdir="${build}" fork="yes" source="1.5" target="1.5"
+ memoryMaximumSize="512m">
<include name="**/*.java"/>
<exclude name="**/Win32*.java"/>
<exclude name="**/swt/osx/**"/>
@@ -33,10 +34,11 @@
<mkdir dir="${dist}/lib"/>
<copy todir="${build}">
- <fileset dir="." includes="**/*.gif **/*.jpg, **/*.png **/*.properties" />
+ <fileset dir="." includes="**/*.gif **/*.jpg, **/*.png" />
<fileset dir="." includes="**/*.dat **/*.stf **/*.xsd" />
<fileset dir="." includes="**/*.css **/*.html **/*.js **/*.php **/*.tmpl **/*.txt" />
<fileset dir="." includes="**/*.ico **/*.wav" />
+ <fileset dir="." includes="**/*.properties" />
</copy>
<!-- Put everything in ${build} into the azureus.jar file -->
<jar jarfile="${dist}/lib/vuze.jar" basedir="${build}"/>
diff --git a/net-p2p/vuze/files/extra-patch-com__aelitis__azureus__core__networkmanager__impl__TransportHelperFilterStream.java b/net-p2p/vuze/files/extra-patch-com__aelitis__azureus__core__networkmanager__impl__TransportHelperFilterStream.java
deleted file mode 100644
index ec0bac48e011..000000000000
--- a/net-p2p/vuze/files/extra-patch-com__aelitis__azureus__core__networkmanager__impl__TransportHelperFilterStream.java
+++ /dev/null
@@ -1,11 +0,0 @@
---- com/aelitis/azureus/core/networkmanager/impl/TransportHelperFilterStream.java.orig 2007-03-01 23:39:40.000000000 -0500
-+++ com/aelitis/azureus/core/networkmanager/impl/TransportHelperFilterStream.java 2008-05-29 13:45:17.000000000 -0400
-@@ -57,7 +57,7 @@
- public boolean
- hasBufferedRead()
- {
-- return false;
-+ return true;
- }
-
- public TransportHelper
diff --git a/net-p2p/vuze/files/extra-patch-com__aelitis__azureus__core__networkmanager__impl__TransportHelperFilterTransparent.java b/net-p2p/vuze/files/extra-patch-com__aelitis__azureus__core__networkmanager__impl__TransportHelperFilterTransparent.java
deleted file mode 100644
index 46ca52490f9d..000000000000
--- a/net-p2p/vuze/files/extra-patch-com__aelitis__azureus__core__networkmanager__impl__TransportHelperFilterTransparent.java
+++ /dev/null
@@ -1,11 +0,0 @@
---- com/aelitis/azureus/core/networkmanager/impl/TransportHelperFilterTransparent.java.orig 2008-05-29 14:05:20.000000000 -0400
-+++ com/aelitis/azureus/core/networkmanager/impl/TransportHelperFilterTransparent.java 2008-05-29 14:08:25.000000000 -0400
-@@ -60,7 +60,7 @@
- public boolean
- hasBufferedRead()
- {
-- return( read_insert != null && read_insert.remaining() > 0 );
-+ return( true );
- }
-
- public long
diff --git a/net-p2p/vuze/files/patch-org__gudy__azureus2__platform__PlatformManagerFactory.java b/net-p2p/vuze/files/patch-org__gudy__azureus2__platform__PlatformManagerFactory.java
index d6373550ea6f..2b6713892d48 100644
--- a/net-p2p/vuze/files/patch-org__gudy__azureus2__platform__PlatformManagerFactory.java
+++ b/net-p2p/vuze/files/patch-org__gudy__azureus2__platform__PlatformManagerFactory.java
@@ -1,6 +1,6 @@
---- org/gudy/azureus2/platform/PlatformManagerFactory.java.orig 2008-10-22 19:53:40.000000000 -0400
-+++ org/gudy/azureus2/platform/PlatformManagerFactory.java 2008-10-22 19:53:58.000000000 -0400
-@@ -48,21 +48,17 @@
+--- org/gudy/azureus2/platform/PlatformManagerFactory.java.orig 2009-07-10 06:30:32.000000000 -0500
++++ org/gudy/azureus2/platform/PlatformManagerFactory.java 2009-07-10 06:36:34.000000000 -0500
+@@ -50,21 +50,17 @@
try{
if ( getPlatformType() == PlatformManager.PT_WINDOWS ){
@@ -14,7 +14,7 @@
}else if( getPlatformType() == PlatformManager.PT_UNIX ){
- platform_manager = org.gudy.azureus2.platform.unix.PlatformManagerImpl.getSingleton();
+ platform_manager = org.gudy.azureus2.platform.unix.PlatformManagerImpl.getSingleton();
}
- }catch( PlatformManagerException e ){
diff --git a/net-p2p/vuze/files/patch-org__gudy__azureus2__platform__macosx__access__jnilib__OSXAccess.java b/net-p2p/vuze/files/patch-org__gudy__azureus2__platform__macosx__access__jnilib__OSXAccess.java
deleted file mode 100644
index 580bb621d76c..000000000000
--- a/net-p2p/vuze/files/patch-org__gudy__azureus2__platform__macosx__access__jnilib__OSXAccess.java
+++ /dev/null
@@ -1,20 +0,0 @@
---- org/gudy/azureus2/platform/macosx/access/jnilib/OSXAccess.java.orig 2008-06-03 11:20:58.000000000 -0400
-+++ org/gudy/azureus2/platform/macosx/access/jnilib/OSXAccess.java 2008-06-03 11:23:02.000000000 -0400
-@@ -19,7 +19,7 @@
- */
- package org.gudy.azureus2.platform.macosx.access.jnilib;
-
--import org.eclipse.swt.internal.carbon.AEDesc;
-+// import org.eclipse.swt.internal.carbon.AEDesc;
-
- import org.gudy.azureus2.core3.util.*;
-
-@@ -42,7 +42,7 @@
- }
- }
-
-- public static final native int AEGetParamDesc(int theAppleEvent, int theAEKeyword, int desiredType, AEDesc result);
-+// public static final native int AEGetParamDesc(int theAppleEvent, int theAEKeyword, int desiredType, AEDesc result);
-
- public static final native String getVersion();
-
diff --git a/net-p2p/vuze/files/patch-org__gudy__azureus2__platform__unix__ScriptBeforeStartup.java b/net-p2p/vuze/files/patch-org__gudy__azureus2__platform__unix__ScriptBeforeStartup.java
index 0e7893f724d9..93902adf2237 100644
--- a/net-p2p/vuze/files/patch-org__gudy__azureus2__platform__unix__ScriptBeforeStartup.java
+++ b/net-p2p/vuze/files/patch-org__gudy__azureus2__platform__unix__ScriptBeforeStartup.java
@@ -1,6 +1,6 @@
---- org/gudy/azureus2/platform/unix/ScriptBeforeStartup.java.orig 2008-06-03 11:25:03.000000000 -0400
-+++ org/gudy/azureus2/platform/unix/ScriptBeforeStartup.java 2008-06-03 11:27:27.000000000 -0400
-@@ -139,6 +139,7 @@
+--- org/gudy/azureus2/platform/unix/ScriptBeforeStartup.java.orig 2009-09-20 15:37:15.000000000 -0500
++++ org/gudy/azureus2/platform/unix/ScriptBeforeStartup.java 2009-09-20 15:53:35.000000000 -0500
+@@ -141,10 +141,12 @@
return false;
}
});
@@ -8,3 +8,8 @@
possibleDirs.add(new File("/usr/local"));
possibleDirs.add(new File("/opt"));
+ final String[] possibleDirNames = {
++ "libxul",
+ "mozilla",
+ "firefox",
+ "seamonkey",
diff --git a/net-p2p/vuze/files/vuze.in b/net-p2p/vuze/files/vuze.in
index 160d5cf1b635..ea54f166463b 100644
--- a/net-p2p/vuze/files/vuze.in
+++ b/net-p2p/vuze/files/vuze.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD: /tmp/pcvs/ports/net-p2p/vuze/files/vuze.in,v 1.1 2008-12-22 18:27:01 rnoland Exp $
+# $FreeBSD: /tmp/pcvs/ports/net-p2p/vuze/files/vuze.in,v 1.2 2009-12-01 21:05:21 rnoland Exp $
# java
export JAVA_VERSION="%%JAVA_VERSION%%"
@@ -12,22 +12,17 @@ LIB_PATH=%%LIBDIR%%
CLASS_PATH=:%%JAVAJARDIR%%/%%JARFILE%%:${ECLIPSE_SWT_JAR}
-BROWSERS="firefox xulrunner seamonkey mozilla"
+#if [ ! "${MOZILLA_FIVE_HOME}" ]; then
+# if [ -d "%%LOCALBASE%%/lib/%%GECKO%%" ]; then
+# MOZILLA_FIVE_HOME="%%LOCALBASE%%/lib/%%GECKO%%"
+# fi
+#fi
-if [ ! "${MOZILLA_FIVE_HOME}" ]; then
- for browser in ${BROWSERS}; do
- if [ -d "%%LOCALBASE%%/lib/${browser}" ]; then
- MOZILLA_FIVE_HOME="%%LOCALBASE%%/lib/${browser}"
- break;
- fi
- done
-fi
-
-if [ "${MOZILLA_FIVE_HOME}" ];then
- LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:${MOZILLA_FIVE_HOME}"
- export MOZILLA_FIVE_HOME LD_LIBRARY_PATH
- echo "MOZILLA_FIVE_HOME=${MOZILLA_FIVE_HOME}"
-fi
+#if [ "${MOZILLA_FIVE_HOME}" ];then
+# LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:${MOZILLA_FIVE_HOME}"
+# export MOZILLA_FIVE_HOME LD_LIBRARY_PATH
+# echo "MOZILLA_FIVE_HOME=${MOZILLA_FIVE_HOME}"
+#fi
if [ "${DEBUG}" ]
then
@@ -39,4 +34,4 @@ then
echo "LIB_PATH = ${LIB_PATH}"
fi
-exec "%%JAVA%%" -cp "${CLASS_PATH}" "-Djava.library.path=${LIB_PATH}" "-Dos.name=linux" "-Dazureus.config.path=${HOME}/.Azureus" "-Duser.dir=${HOME}/.Azureus" org.gudy.azureus2.ui.swt.Main "${@}"
+exec "%%JAVA%%" -cp "${CLASS_PATH}" "-Djava.library.path=${LIB_PATH}" "-Dos.name=FreeBSD" "-Dazureus.config.path=${HOME}/.Azureus" "-Duser.dir=${HOME}/.Azureus" org.gudy.azureus2.ui.swt.Main "${@}"
diff --git a/net-p2p/vuze/pkg-message b/net-p2p/vuze/pkg-message
index 1842e9988326..7efbaa51bb37 100644
--- a/net-p2p/vuze/pkg-message
+++ b/net-p2p/vuze/pkg-message
@@ -8,7 +8,7 @@ latest version of all your installed
packages.
For instance, make sure the swt
-package is of version 3.4 or
+package is of version 3.5 or
later.
====================================