aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-02-28 20:13:57 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-02-28 20:13:57 +0000
commit61917e0e19ffde7918de62e4b70e5edaca7a754f (patch)
tree230c65f42cb09f50cfa01d458d2f6a658886bb7b /net-p2p
parent0db81eef0e88168fb4d403fba39c24414f0af442 (diff)
downloadports-61917e0e19ffde7918de62e4b70e5edaca7a754f.tar.gz
ports-61917e0e19ffde7918de62e4b70e5edaca7a754f.zip
net-p2p/py-libtorrent-rasterbar: Update 1.2.10 -> 2.0.2
Notes
Notes: svn path=/head/; revision=566804
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/py-libtorrent-rasterbar/Makefile26
-rw-r--r--net-p2p/py-libtorrent-rasterbar/distinfo8
-rw-r--r--net-p2p/py-libtorrent-rasterbar/files/b23
-rw-r--r--net-p2p/py-libtorrent-rasterbar/files/patch-ca9a7f3b89095949e30f533e53080293f33f2f6050
4 files changed, 74 insertions, 13 deletions
diff --git a/net-p2p/py-libtorrent-rasterbar/Makefile b/net-p2p/py-libtorrent-rasterbar/Makefile
index 06763136f5be..3dd328644109 100644
--- a/net-p2p/py-libtorrent-rasterbar/Makefile
+++ b/net-p2p/py-libtorrent-rasterbar/Makefile
@@ -2,34 +2,40 @@
# $FreeBSD$
PORTNAME= libtorrent-rasterbar
-DISTVERSIONPREFIX= libtorrent-
-DISTVERSION= 1.2.10
+DISTVERSION= 2.0.2
CATEGORIES= net-p2p python
+MASTER_SITES= https://github.com/arvidn/libtorrent/releases/download/v${DISTVERSION}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PATCH_SITES= https://github.com/arvidn/libtorrent/commit/
+PATCHFILES= 2e9a8423c8e2d3eba49165bacbae2878e25991cb.patch:-p3 # https://github.com/arvidn/libtorrent/pull/6016/commits
+
MAINTAINER= yuri@FreeBSD.org
COMMENT= Python bindings for libtorrent-rasterbar
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/../../COPYING
-LIB_DEPENDS= libtorrent-rasterbar.so:net-p2p/libtorrent-rasterbar \
- ${PY_BOOST}
+BUILD_DEPENDS= b2:devel/boost_build
+#LIB_DEPENDS= libtorrent-rasterbar.so:net-p2p/libtorrent-rasterbar \
+# ${PY_BOOST}
+LIB_DEPENDS= ${PY_BOOST} # Python binding rebuilds whole libtorrent: https://github.com/arvidn/libtorrent/issues/6017
-USES= compiler:c11 iconv localbase python:3.6+
-USE_GITHUB= yes
-GH_ACCOUNT= arvidn
-GH_PROJECT= libtorrent
+USES= compiler:c11 iconv localbase:ldflags python:3.6+
USE_PYTHON= distutils autoplist
+BINARY_ALIAS= b2=${FILESDIR}/b2
+
CFLAGS+= -DTORRENT_DISABLE_LOGGING # undefined symbol: https://github.com/arvidn/libtorrent/issues/3331
-LDFLAGS+= ${LOCALBASE}/lib/libboost_python${PYTHON_SUFFIX}.so ${LOCALBASE}/lib/libiconv.so # fails to link libs: https://github.com/arvidn/libtorrent/issues/3330
+CFLAGS+= -fPIC
+#LDFLAGS+= ${LOCALBASE}/lib/libboost_python${PYTHON_SUFFIX}.so ${LOCALBASE}/lib/libiconv.so # fails to link libs: https://github.com/arvidn/libtorrent/issues/3330
WRKSRC_SUBDIR= bindings/python
# ensure python paths are correctly identified
CONFIGURE_ENV= PYTHON_INCLUDEDIR="${PYTHON_INCLUDEDIR}" \
- PYTHON_VERSION="${PYTHON_VERSION}"
+ PYTHON_VERSION="${PYTHON_VERSION}" \
+ BOOST_ROOT=${LOCALBASE}
post-install:
@${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/libtorrent*.so
diff --git a/net-p2p/py-libtorrent-rasterbar/distinfo b/net-p2p/py-libtorrent-rasterbar/distinfo
index 146fcd43aa5b..ad7cd69af61a 100644
--- a/net-p2p/py-libtorrent-rasterbar/distinfo
+++ b/net-p2p/py-libtorrent-rasterbar/distinfo
@@ -1,3 +1,5 @@
-TIMESTAMP = 1599281590
-SHA256 (arvidn-libtorrent-libtorrent-1.2.10_GH0.tar.gz) = e0fedb583f1e7bdcc0eb80a9df064a1e6fb0b825d8423e64bdb0f7a35879a09e
-SIZE (arvidn-libtorrent-libtorrent-1.2.10_GH0.tar.gz) = 3586008
+TIMESTAMP = 1614539774
+SHA256 (libtorrent-rasterbar-2.0.2.tar.gz) = 3af22ea1b60e04a7cf357a3d770470ea5df15e968501782bd1414634a2b42cb7
+SIZE (libtorrent-rasterbar-2.0.2.tar.gz) = 4269533
+SHA256 (2e9a8423c8e2d3eba49165bacbae2878e25991cb.patch) = 189088dc121b6c62915b1edb76681298ccf34e0a4f628c4bee67a95b4ffceba9
+SIZE (2e9a8423c8e2d3eba49165bacbae2878e25991cb.patch) = 1422
diff --git a/net-p2p/py-libtorrent-rasterbar/files/b2 b/net-p2p/py-libtorrent-rasterbar/files/b2
new file mode 100644
index 000000000000..3381c22472b5
--- /dev/null
+++ b/net-p2p/py-libtorrent-rasterbar/files/b2
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+$PREFIX/bin/b2 toolset=clang "$@"
diff --git a/net-p2p/py-libtorrent-rasterbar/files/patch-ca9a7f3b89095949e30f533e53080293f33f2f60 b/net-p2p/py-libtorrent-rasterbar/files/patch-ca9a7f3b89095949e30f533e53080293f33f2f60
new file mode 100644
index 000000000000..8908de08462d
--- /dev/null
+++ b/net-p2p/py-libtorrent-rasterbar/files/patch-ca9a7f3b89095949e30f533e53080293f33f2f60
@@ -0,0 +1,50 @@
+- patch from the upstream to fix build
+
+From ca9a7f3b89095949e30f533e53080293f33f2f60 Mon Sep 17 00:00:00 2001
+From: arvidn <arvid@libtorrent.org>
+Date: Mon, 11 Jan 2021 21:14:29 +0100
+Subject: [PATCH] Fix cxxflags and linkflags injection via environment
+ variables
+
+---
+ ChangeLog | 2 ++
+ Jamfile | 5 ++---
+ 2 files changed, 4 insertions(+), 3 deletions(-)
+
+diff --git ../../ChangeLog ../..//ChangeLog
+index 01301258c8..aaefc2bc76 100644
+--- ../..//ChangeLog
++++ ../..//ChangeLog
+@@ -1,3 +1,5 @@
++ * Fix cxxflags and linkflags injection via environment variables
++
+ 1.2.12 released
+
+ * fix loading of DHT node ID from previous session on startup
+diff --git ../..//Jamfile ../../Jamfile
+index 21d1fc423e..44a1199484 100644
+--- ../../Jamfile
++++ ../../Jamfile
+@@ -745,8 +745,7 @@ local usage-requirements =
+ <toolset>msvc:<define>_SCL_SECURE_NO_DEPRECATE
+ <toolset>msvc:<define>_CRT_SECURE_NO_DEPRECATE
+
+- <cxxflags>$(CXXFLAGS)
+- <linkflags>$(LDFLAGS)
++ <cxxflags>"$(CXXFLAGS:J= )"
+ ;
+
+ project torrent ;
+@@ -770,11 +769,11 @@ lib torrent
+
+ <conditional>@building
+ <conditional>@warnings
+- <cxxflags>$(CXXFLAGS)
+
+ <tag>@tag
+
+ $(usage-requirements)
++ <linkflags>"$(LDFLAGS:J= )"
+
+ : # default build
+ <threading>multi