aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-06-05 06:05:16 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-06-05 06:05:16 +0000
commit789124acc9bf54f562c9559627e5b0c5f074e02b (patch)
tree271f7fca86f2121414acd770e11267a84c94b048 /net-p2p
parent8454971ccc1c45db9c3c8073774bb0ea8d4b677b (diff)
- Update to 0.12
PR: 112697 Submitted by: Johan Strom <johan@stromnet.se> (maintainer)
Notes
Notes: svn path=/head/; revision=192797
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/rblibtorrent/Makefile4
-rw-r--r--net-p2p/rblibtorrent/distinfo6
-rw-r--r--net-p2p/rblibtorrent/files/patch-include_libtorrent_asio_detail_socket_ops.hpp92
-rw-r--r--net-p2p/rblibtorrent/files/patch-socket_ops.hpp10
-rw-r--r--net-p2p/rblibtorrent/pkg-plist24
5 files changed, 34 insertions, 102 deletions
diff --git a/net-p2p/rblibtorrent/Makefile b/net-p2p/rblibtorrent/Makefile
index 0ce440130464..0fb2f75e86c6 100644
--- a/net-p2p/rblibtorrent/Makefile
+++ b/net-p2p/rblibtorrent/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libtorrent
-PORTVERSION= 0.11
-PORTREVISION= 1
+PORTVERSION= 0.12
CATEGORIES= net-p2p
MASTER_SITES= SF
PKGNAMEPREFIX= rb
@@ -19,6 +18,7 @@ LIB_DEPENDS= boost_date_time.3:${PORTSDIR}/devel/boost
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+USE_GCC= 3.4
CONFIGURE_ARGS= --disable-debug
CONFIGURE_ENV= CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
diff --git a/net-p2p/rblibtorrent/distinfo b/net-p2p/rblibtorrent/distinfo
index 74318f11702b..f12d4973f5b2 100644
--- a/net-p2p/rblibtorrent/distinfo
+++ b/net-p2p/rblibtorrent/distinfo
@@ -1,3 +1,3 @@
-MD5 (libtorrent-0.11.tar.gz) = 56e9071b95a6e3f9377121f2fead3499
-SHA256 (libtorrent-0.11.tar.gz) = f350e0af6b42c2cdb1f19008b00fe5f0b70236817f532a94bcb1e3ef6ebba0d7
-SIZE (libtorrent-0.11.tar.gz) = 1130537
+MD5 (libtorrent-0.12.tar.gz) = a09a37e6fc74d152821c00c3cb15d248
+SHA256 (libtorrent-0.12.tar.gz) = 0663f9adaa9d90334ebf78eb6f5b31074ff533d7bec5d3325ff98baad5b7df07
+SIZE (libtorrent-0.12.tar.gz) = 1176469
diff --git a/net-p2p/rblibtorrent/files/patch-include_libtorrent_asio_detail_socket_ops.hpp b/net-p2p/rblibtorrent/files/patch-include_libtorrent_asio_detail_socket_ops.hpp
deleted file mode 100644
index 0943e805c176..000000000000
--- a/net-p2p/rblibtorrent/files/patch-include_libtorrent_asio_detail_socket_ops.hpp
+++ /dev/null
@@ -1,92 +0,0 @@
---- include/libtorrent/asio/detail/socket_ops.hpp.original Tue Oct 24 00:50:21 2006
-+++ include/libtorrent/asio/detail/socket_ops.hpp Wed Nov 29 14:40:02 2006
-@@ -66,7 +66,7 @@
- socket_addr_len_type* addrlen)
- {
- set_error(0);
--#if defined(__MACH__) && defined(__APPLE__)
-+#if defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- socket_type new_s = error_wrapper(::accept(s, addr, addrlen));
- if (new_s == invalid_socket)
- return new_s;
-@@ -279,7 +279,7 @@
- #if defined(BOOST_WINDOWS) || defined(__CYGWIN__)
- return error_wrapper(::WSASocket(af, type, protocol, 0, 0,
- WSA_FLAG_OVERLAPPED));
--#elif defined(__MACH__) && defined(__APPLE__)
-+#elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- socket_type s = error_wrapper(::socket(af, type, protocol));
- if (s == invalid_socket)
- return s;
-@@ -561,7 +561,7 @@
- }
-
- #if defined(BOOST_WINDOWS) || defined(__CYGWIN__) \
-- || defined(__MACH__) && defined(__APPLE__)
-+ || defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
-
- // The following functions are only needed for emulation of getaddrinfo and
- // getnameinfo.
-@@ -604,7 +604,7 @@
- buffer, buflength, error));
- *error = translate_netdb_error(*error);
- return retval;
--#elif defined(__MACH__) && defined(__APPLE__)
-+#elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- (void)(buffer);
- (void)(buflength);
- hostent* retval = error_wrapper(::getipnodebyaddr(addr, length, af, error));
-@@ -652,7 +652,7 @@
- buflength, error));
- *error = translate_netdb_error(*error);
- return retval;
--#elif defined(__MACH__) && defined(__APPLE__)
-+#elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- (void)(buffer);
- (void)(buflength);
- hostent* retval = error_wrapper(::getipnodebyname(
-@@ -679,7 +679,7 @@
-
- inline void freehostent(hostent* h)
- {
--#if defined(__MACH__) && defined(__APPLE__)
-+#if defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- if (h)
- ::freehostent(h);
- #else
-@@ -1372,7 +1372,7 @@
- }
-
- #endif // defined(BOOST_WINDOWS) || defined(__CYGWIN__)
-- // || defined(__MACH__) && defined(__APPLE__)
-+ // || defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
-
- inline int translate_addrinfo_error(int error)
- {
-@@ -1425,7 +1425,7 @@
- int error = getaddrinfo_emulation(host, service, hints, result);
- return translate_addrinfo_error(error);
- # endif
--#elif defined(__MACH__) && defined(__APPLE__)
-+#elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- int error = getaddrinfo_emulation(host, service, hints, result);
- return translate_addrinfo_error(error);
- #else
-@@ -1453,7 +1453,7 @@
- }
- freeaddrinfo_emulation(ai);
- # endif
--#elif defined(__MACH__) && defined(__APPLE__)
-+#elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- freeaddrinfo_emulation(ai);
- #else
- ::freeaddrinfo(ai);
-@@ -1488,7 +1488,7 @@
- host, hostlen, serv, servlen, flags);
- return translate_addrinfo_error(error);
- # endif
--#elif defined(__MACH__) && defined(__APPLE__)
-+#elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
- using namespace std; // For memcpy.
- sockaddr_storage_type tmp_addr;
- memcpy(&tmp_addr, addr, addrlen);
diff --git a/net-p2p/rblibtorrent/files/patch-socket_ops.hpp b/net-p2p/rblibtorrent/files/patch-socket_ops.hpp
new file mode 100644
index 000000000000..65260b013846
--- /dev/null
+++ b/net-p2p/rblibtorrent/files/patch-socket_ops.hpp
@@ -0,0 +1,10 @@
+--- include/libtorrent/asio/detail/socket_ops.hpp Wed May 16 00:35:55 2007
++++ include/libtorrent/asio/detail/socket_ops.hpp.orig Wed May 16 00:35:45 2007
+66c66
+< #if defined(__MACH__) && defined(__APPLE__)
+---
+> #if defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
+298c298
+< #elif defined(__MACH__) && defined(__APPLE__)
+---
+> #elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
diff --git a/net-p2p/rblibtorrent/pkg-plist b/net-p2p/rblibtorrent/pkg-plist
index fca1337deebc..e73162821c28 100644
--- a/net-p2p/rblibtorrent/pkg-plist
+++ b/net-p2p/rblibtorrent/pkg-plist
@@ -5,7 +5,6 @@ include/libtorrent/asio.hpp
include/libtorrent/asio/basic_datagram_socket.hpp
include/libtorrent/asio/basic_deadline_timer.hpp
include/libtorrent/asio/basic_io_object.hpp
-include/libtorrent/asio/basic_resolver.hpp
include/libtorrent/asio/basic_socket.hpp
include/libtorrent/asio/basic_socket_acceptor.hpp
include/libtorrent/asio/basic_socket_iostream.hpp
@@ -40,6 +39,7 @@ include/libtorrent/asio/detail/hash_map.hpp
include/libtorrent/asio/detail/io_control.hpp
include/libtorrent/asio/detail/kqueue_reactor.hpp
include/libtorrent/asio/detail/kqueue_reactor_fwd.hpp
+include/libtorrent/asio/detail/local_free_on_block_exit.hpp
include/libtorrent/asio/detail/mutex.hpp
include/libtorrent/asio/detail/noncopyable.hpp
include/libtorrent/asio/detail/null_event.hpp
@@ -64,7 +64,10 @@ include/libtorrent/asio/detail/scoped_lock.hpp
include/libtorrent/asio/detail/select_interrupter.hpp
include/libtorrent/asio/detail/select_reactor.hpp
include/libtorrent/asio/detail/select_reactor_fwd.hpp
+include/libtorrent/asio/detail/service_base.hpp
+include/libtorrent/asio/detail/service_id.hpp
include/libtorrent/asio/detail/service_registry.hpp
+include/libtorrent/asio/detail/service_registry_fwd.hpp
include/libtorrent/asio/detail/signal_blocker.hpp
include/libtorrent/asio/detail/signal_init.hpp
include/libtorrent/asio/detail/socket_holder.hpp
@@ -76,6 +79,7 @@ include/libtorrent/asio/detail/strand_service.hpp
include/libtorrent/asio/detail/task_io_service.hpp
include/libtorrent/asio/detail/task_io_service_fwd.hpp
include/libtorrent/asio/detail/thread.hpp
+include/libtorrent/asio/detail/throw_error.hpp
include/libtorrent/asio/detail/timer_queue.hpp
include/libtorrent/asio/detail/timer_queue_base.hpp
include/libtorrent/asio/detail/tss_ptr.hpp
@@ -85,7 +89,6 @@ include/libtorrent/asio/detail/win_iocp_io_service.hpp
include/libtorrent/asio/detail/win_iocp_io_service_fwd.hpp
include/libtorrent/asio/detail/win_iocp_operation.hpp
include/libtorrent/asio/detail/win_iocp_socket_service.hpp
-include/libtorrent/asio/detail/win_local_free_on_block_exit.hpp
include/libtorrent/asio/detail/win_mutex.hpp
include/libtorrent/asio/detail/win_signal_blocker.hpp
include/libtorrent/asio/detail/win_thread.hpp
@@ -93,9 +96,10 @@ include/libtorrent/asio/detail/win_tss_ptr.hpp
include/libtorrent/asio/detail/winsock_init.hpp
include/libtorrent/asio/detail/wrapped_handler.hpp
include/libtorrent/asio/error.hpp
-include/libtorrent/asio/error_handler.hpp
+include/libtorrent/asio/error_code.hpp
include/libtorrent/asio/handler_alloc_hook.hpp
include/libtorrent/asio/handler_invoke_hook.hpp
+include/libtorrent/asio/impl/error_code.ipp
include/libtorrent/asio/impl/io_service.ipp
include/libtorrent/asio/impl/read.ipp
include/libtorrent/asio/impl/read_until.ipp
@@ -105,6 +109,7 @@ include/libtorrent/asio/ip/address.hpp
include/libtorrent/asio/ip/address_v4.hpp
include/libtorrent/asio/ip/address_v6.hpp
include/libtorrent/asio/ip/basic_endpoint.hpp
+include/libtorrent/asio/ip/basic_resolver.hpp
include/libtorrent/asio/ip/basic_resolver_entry.hpp
include/libtorrent/asio/ip/basic_resolver_iterator.hpp
include/libtorrent/asio/ip/basic_resolver_query.hpp
@@ -112,6 +117,7 @@ include/libtorrent/asio/ip/detail/socket_option.hpp
include/libtorrent/asio/ip/host_name.hpp
include/libtorrent/asio/ip/multicast.hpp
include/libtorrent/asio/ip/resolver_query_base.hpp
+include/libtorrent/asio/ip/resolver_service.hpp
include/libtorrent/asio/ip/tcp.hpp
include/libtorrent/asio/ip/udp.hpp
include/libtorrent/asio/is_read_buffered.hpp
@@ -119,7 +125,6 @@ include/libtorrent/asio/is_write_buffered.hpp
include/libtorrent/asio/placeholders.hpp
include/libtorrent/asio/read.hpp
include/libtorrent/asio/read_until.hpp
-include/libtorrent/asio/resolver_service.hpp
include/libtorrent/asio/socket_acceptor_service.hpp
include/libtorrent/asio/socket_base.hpp
include/libtorrent/asio/ssl.hpp
@@ -138,12 +143,13 @@ include/libtorrent/asio/ssl/stream_service.hpp
include/libtorrent/asio/strand.hpp
include/libtorrent/asio/stream_socket_service.hpp
include/libtorrent/asio/streambuf.hpp
-include/libtorrent/asio/system_exception.hpp
+include/libtorrent/asio/system_error.hpp
include/libtorrent/asio/thread.hpp
include/libtorrent/asio/time_traits.hpp
include/libtorrent/asio/write.hpp
include/libtorrent/aux_/allocate_resources_impl.hpp
include/libtorrent/aux_/session_impl.hpp
+include/libtorrent/bandwidth_manager.hpp
include/libtorrent/bencode.hpp
include/libtorrent/bt_peer_connection.hpp
include/libtorrent/buffer.hpp
@@ -151,7 +157,12 @@ include/libtorrent/config.hpp
include/libtorrent/debug.hpp
include/libtorrent/entry.hpp
include/libtorrent/escape_string.hpp
+include/libtorrent/extensions.hpp
+include/libtorrent/extensions/logger.hpp
+include/libtorrent/extensions/metadata_transfer.hpp
+include/libtorrent/extensions/ut_pex.hpp
include/libtorrent/file.hpp
+include/libtorrent/file_pool.hpp
include/libtorrent/fingerprint.hpp
include/libtorrent/hasher.hpp
include/libtorrent/http_tracker_connection.hpp
@@ -201,7 +212,10 @@ lib/libtorrent.la
lib/libtorrent.so
lib/libtorrent.so.1
libdata/pkgconfig/libtorrent.pc
+share/nls/POSIX
+share/nls/en_US.US-ASCII
@dirrm include/libtorrent/kademlia
+@dirrm include/libtorrent/extensions
@dirrm include/libtorrent/aux_
@dirrm include/libtorrent/asio/ssl/detail
@dirrm include/libtorrent/asio/ssl