aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2008-01-10 18:44:17 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2008-01-10 18:44:17 +0000
commit837b1fd5de08fa694d23581736e95a9863363b57 (patch)
tree4eb214ecbc678864f05b142d3d6e9b7033600a1c /net-p2p
parent8227d5062a896d5afc3c9ffbdf519c08fd399969 (diff)
downloadports-837b1fd5de08fa694d23581736e95a9863363b57.tar.gz
ports-837b1fd5de08fa694d23581736e95a9863363b57.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/deluge/Makefile11
-rw-r--r--net-p2p/deluge/files/patch-disable_browser17
-rw-r--r--net-p2p/deluge/files/patch-scripts_deluge15
-rw-r--r--net-p2p/deluge05/Makefile11
-rw-r--r--net-p2p/deluge05/files/patch-disable_browser17
-rw-r--r--net-p2p/deluge05/files/patch-scripts_deluge15
6 files changed, 36 insertions, 50 deletions
diff --git a/net-p2p/deluge/Makefile b/net-p2p/deluge/Makefile
index 20fee2773e99..fbd76805dd53 100644
--- a/net-p2p/deluge/Makefile
+++ b/net-p2p/deluge/Makefile
@@ -7,6 +7,7 @@
PORTNAME= deluge
PORTVERSION= 0.5.8
+PORTREVISION= 1
CATEGORIES= net-p2p python
MASTER_SITES= http://download.deluge-torrent.org/tarball/${PORTVERSION}/
@@ -32,14 +33,7 @@ MAKE_ENV= CC="${CC}" CXX="${CXX}"
DOCS= LICENSE README
-# Internal anonymizing browser needs gecko stuff in py-gnome-extras.
-.if !defined(WITHOUT_GECKO)
-RUN_DEPENDS+= ${pygnomeextras_DETECT}:${PORTSDIR}/x11-toolkits/py-gnome-extras
-USE_GECKO= firefox seamonkey xulrunner mozilla
-.endif
-
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
.if ${ARCH} == "sparc64" || ${ARCH} == "ia64"
CFLAGS+= -DAMD64
@@ -48,9 +42,6 @@ CFLAGS+= -DAMD64
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g ; \
s|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g' ${WRKSRC}/setup.py
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
- s|%%GECKO_LIB%%|${LOCALBASE}/lib/${GECKO}|g' \
- ${WRKSRC}/scripts/deluge
post-install:
@-update-desktop-database
diff --git a/net-p2p/deluge/files/patch-disable_browser b/net-p2p/deluge/files/patch-disable_browser
new file mode 100644
index 000000000000..763a932517dc
--- /dev/null
+++ b/net-p2p/deluge/files/patch-disable_browser
@@ -0,0 +1,17 @@
+--- src/interface.py.orig 2008-01-10 12:35:50.000000000 -0600
++++ src/interface.py 2008-01-10 12:36:09.000000000 -0600
+@@ -244,13 +244,7 @@
+ self.manager.pause_all()
+
+ def launch_browser_clicked(self, arg=None):
+- try:
+- import browser
+- browser.Browser()
+- except:
+- dialogs.show_popup_warning(self.window, _("Unable to state browser. \
+-Make sure you have python-gnome2-extras installed or try setting your LD_LIBRARY_PATH \
+-and MOZILLA_FIVE_HOME environment variables to /usr/lib/firefox"))
++ dialogs.show_popup_warning(self.window, _("This feature has been removed by the developers, so it does not work any longer. See http://forum.deluge-torrent.org/viewtopic.php?f=7&t=1069 for more info."))
+
+ def resume_all_clicked(self, arg=None):
+ self.manager.resume_all()
diff --git a/net-p2p/deluge/files/patch-scripts_deluge b/net-p2p/deluge/files/patch-scripts_deluge
deleted file mode 100644
index 6179f508f3e2..000000000000
--- a/net-p2p/deluge/files/patch-scripts_deluge
+++ /dev/null
@@ -1,15 +0,0 @@
---- scripts/deluge.orig 2007-12-29 23:24:53.000000000 -0600
-+++ scripts/deluge 2007-12-29 23:27:45.000000000 -0600
-@@ -62,6 +62,12 @@
- os.environ["LD_LIBRARY_PATH"] = "/usr/lib/firefox"
- os.system("/usr/bin/deluge %s &" % arguments)
- raise SystemExit
-+ if platform.system() == "FreeBSD":
-+ if os.environ.get("MOZILLA_FIVE_HOME") != "%%GECKO_LIB%%":
-+ os.environ["MOZILLA_FIVE_HOME"] = "%%GECKO_LIB%%"
-+ os.environ["LD_LIBRARY_PATH"] = "%%GECKO_LIB%%"
-+ os.system("%%PREFIX%%/bin/deluge %s &" % arguments)
-+ raise SystemExit
-
- parser = OptionParser(usage="%prog [options] [torrents to add]",
- version=deluge.common.PROGRAM_VERSION)
diff --git a/net-p2p/deluge05/Makefile b/net-p2p/deluge05/Makefile
index 20fee2773e99..fbd76805dd53 100644
--- a/net-p2p/deluge05/Makefile
+++ b/net-p2p/deluge05/Makefile
@@ -7,6 +7,7 @@
PORTNAME= deluge
PORTVERSION= 0.5.8
+PORTREVISION= 1
CATEGORIES= net-p2p python
MASTER_SITES= http://download.deluge-torrent.org/tarball/${PORTVERSION}/
@@ -32,14 +33,7 @@ MAKE_ENV= CC="${CC}" CXX="${CXX}"
DOCS= LICENSE README
-# Internal anonymizing browser needs gecko stuff in py-gnome-extras.
-.if !defined(WITHOUT_GECKO)
-RUN_DEPENDS+= ${pygnomeextras_DETECT}:${PORTSDIR}/x11-toolkits/py-gnome-extras
-USE_GECKO= firefox seamonkey xulrunner mozilla
-.endif
-
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
.if ${ARCH} == "sparc64" || ${ARCH} == "ia64"
CFLAGS+= -DAMD64
@@ -48,9 +42,6 @@ CFLAGS+= -DAMD64
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g ; \
s|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g' ${WRKSRC}/setup.py
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
- s|%%GECKO_LIB%%|${LOCALBASE}/lib/${GECKO}|g' \
- ${WRKSRC}/scripts/deluge
post-install:
@-update-desktop-database
diff --git a/net-p2p/deluge05/files/patch-disable_browser b/net-p2p/deluge05/files/patch-disable_browser
new file mode 100644
index 000000000000..763a932517dc
--- /dev/null
+++ b/net-p2p/deluge05/files/patch-disable_browser
@@ -0,0 +1,17 @@
+--- src/interface.py.orig 2008-01-10 12:35:50.000000000 -0600
++++ src/interface.py 2008-01-10 12:36:09.000000000 -0600
+@@ -244,13 +244,7 @@
+ self.manager.pause_all()
+
+ def launch_browser_clicked(self, arg=None):
+- try:
+- import browser
+- browser.Browser()
+- except:
+- dialogs.show_popup_warning(self.window, _("Unable to state browser. \
+-Make sure you have python-gnome2-extras installed or try setting your LD_LIBRARY_PATH \
+-and MOZILLA_FIVE_HOME environment variables to /usr/lib/firefox"))
++ dialogs.show_popup_warning(self.window, _("This feature has been removed by the developers, so it does not work any longer. See http://forum.deluge-torrent.org/viewtopic.php?f=7&t=1069 for more info."))
+
+ def resume_all_clicked(self, arg=None):
+ self.manager.resume_all()
diff --git a/net-p2p/deluge05/files/patch-scripts_deluge b/net-p2p/deluge05/files/patch-scripts_deluge
deleted file mode 100644
index 6179f508f3e2..000000000000
--- a/net-p2p/deluge05/files/patch-scripts_deluge
+++ /dev/null
@@ -1,15 +0,0 @@
---- scripts/deluge.orig 2007-12-29 23:24:53.000000000 -0600
-+++ scripts/deluge 2007-12-29 23:27:45.000000000 -0600
-@@ -62,6 +62,12 @@
- os.environ["LD_LIBRARY_PATH"] = "/usr/lib/firefox"
- os.system("/usr/bin/deluge %s &" % arguments)
- raise SystemExit
-+ if platform.system() == "FreeBSD":
-+ if os.environ.get("MOZILLA_FIVE_HOME") != "%%GECKO_LIB%%":
-+ os.environ["MOZILLA_FIVE_HOME"] = "%%GECKO_LIB%%"
-+ os.environ["LD_LIBRARY_PATH"] = "%%GECKO_LIB%%"
-+ os.system("%%PREFIX%%/bin/deluge %s &" % arguments)
-+ raise SystemExit
-
- parser = OptionParser(usage="%prog [options] [torrents to add]",
- version=deluge.common.PROGRAM_VERSION)