aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-02-24 18:46:37 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-02-24 18:46:37 +0000
commit91e4d5aaefce2d129288079f3cce5a706775c203 (patch)
tree30d7971e0cd2c019e557c977b353b213cd99db25 /net-p2p
parent23d3d04e5073fb3d2ca0a8f26dcb9c8d9220db3b (diff)
downloadports-91e4d5aaefce2d129288079f3cce5a706775c203.tar.gz
ports-91e4d5aaefce2d129288079f3cce5a706775c203.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/rtorrent-devel/Makefile26
-rw-r--r--net-p2p/rtorrent/Makefile28
2 files changed, 23 insertions, 31 deletions
diff --git a/net-p2p/rtorrent-devel/Makefile b/net-p2p/rtorrent-devel/Makefile
index fa9e27693b2e..a4b9744a38a8 100644
--- a/net-p2p/rtorrent-devel/Makefile
+++ b/net-p2p/rtorrent-devel/Makefile
@@ -12,7 +12,7 @@ COMMENT= BitTorrent Client written in C++ (development version)
BUILD_DEPENDS= libtorrent-devel=0.13.3_1:${PORTSDIR}/net-p2p/libtorrent-devel
RUN_DEPENDS= libtorrent-devel=0.13.3_1:${PORTSDIR}/net-p2p/libtorrent-devel
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
CONFLICTS= rtorrent-[0-9]*
@@ -26,25 +26,24 @@ SUB_FILES= pkg-message
PORTDOCS= README
OPTIONS_DEFINE= XMLRPC IPV6 DOCS
-OPTIONS_DEFAULT= XMLRPC IPV6
+OPTIONS_DEFAULT= XMLRPC
XMLRPC_DESC= Compile with xmlrpc-c support
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if ${ARCH} == "arm"
+.if ${ARCH} == arm
BROKEN= Does not configure on arm
.endif
# Workaround to build and segfault on > 10.x
-.if ${OPSYS} == "FreeBSD" && ${OSVERSION} >= 1000000
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
USE_GCC= yes
LDFLAGS+= -lc++
.endif
.if ${PORT_OPTIONS:MXMLRPC}
CONFIGURE_ARGS+= --with-xmlrpc-c
-LIB_DEPENDS+= xmlrpc:${PORTSDIR}/net/xmlrpc-c-devel
+LIB_DEPENDS+= libxmlrpc.so:${PORTSDIR}/net/xmlrpc-c-devel
.else
CONFIGURE_ARGS+= --with-xmlrpc-c=no
.endif
@@ -57,12 +56,9 @@ post-patch:
@${REINPLACE_CMD} -e 's|-O3|${CFLAGS}|' ${WRKSRC}/configure
post-install:
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/rtorrent.rc ${EXAMPLESDIR}/
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}/
-.endif
- @${CAT} ${PKGMESSAGE}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/rtorrent.rc ${STAGEDIR}${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-p2p/rtorrent/Makefile b/net-p2p/rtorrent/Makefile
index ad5794af04fa..75ea28d0f28f 100644
--- a/net-p2p/rtorrent/Makefile
+++ b/net-p2p/rtorrent/Makefile
@@ -11,7 +11,7 @@ COMMENT= BitTorrent Client written in C++
BUILD_DEPENDS= libtorrent=0.13.2_1:${PORTSDIR}/net-p2p/libtorrent
RUN_DEPENDS= libtorrent=0.13.2_1:${PORTSDIR}/net-p2p/libtorrent
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
CONFLICTS= rtorrent-devel-[0-9]*
@@ -25,25 +25,24 @@ SUB_FILES= pkg-message
PORTDOCS= README
OPTIONS_DEFINE= XMLRPC IPV6 DOCS
-OPTIONS_DEFAULT= XMLRPC IPV6
+OPTIONS_DEFAULT= XMLRPC
XMLRPC_DESC= Compile with xmlrpc-c support
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if ${ARCH} == "arm"
+.if ${ARCH} == arm
BROKEN= Does not configure on arm
.endif
# Workaround to build and segfault on > 10.x
-.if ${OPSYS} == "FreeBSD" && ${OSVERSION} >= 1000000
-USE_GCC= yes
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
+USE_GCC= yes
LDFLAGS+= -lc++
.endif
.if ${PORT_OPTIONS:MXMLRPC}
CONFIGURE_ARGS+= --with-xmlrpc-c
-LIB_DEPENDS+= xmlrpc.3:${PORTSDIR}/net/xmlrpc-c-devel
+LIB_DEPENDS+= libxmlrpc.so:${PORTSDIR}/net/xmlrpc-c-devel
.else
CONFIGURE_ARGS+= --with-xmlrpc-c=no
.endif
@@ -56,12 +55,9 @@ post-patch:
@${REINPLACE_CMD} -e 's|-O3|${CFLAGS}|' ${WRKSRC}/configure
post-install:
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/rtorrent.rc ${EXAMPLESDIR}/
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}/
-.endif
- @${CAT} ${PKGMESSAGE}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/rtorrent.rc ${STAGEDIR}${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>