aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2018-12-02 15:41:47 +0000
committerRene Ladan <rene@FreeBSD.org>2018-12-02 15:41:47 +0000
commit99d6d12a388dab91f415ddebd52c6a57e3a6347a (patch)
treedecf1f7754d8060ee740cd0c0edc9a51c04a0ec1 /net-p2p
parent577806de96b111cab272c48a686bcca681cc6d4d (diff)
downloadports-99d6d12a388dab91f415ddebd52c6a57e3a6347a.tar.gz
ports-99d6d12a388dab91f415ddebd52c6a57e3a6347a.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/amule-devel/Makefile5
-rw-r--r--net-p2p/amule/Makefile5
-rw-r--r--net-p2p/bitmessage/Makefile3
-rw-r--r--net-p2p/eiskaltdcpp-qt/Makefile3
-rw-r--r--net-p2p/torrent-file-editor/Makefile7
-rw-r--r--net-p2p/transmission-qt/Makefile7
-rw-r--r--net-p2p/valknut/Makefile3
-rw-r--r--net-p2p/zetacoin/Makefile7
8 files changed, 36 insertions, 4 deletions
diff --git a/net-p2p/amule-devel/Makefile b/net-p2p/amule-devel/Makefile
index ee1756b0fc22..fd8f042a9b37 100644
--- a/net-p2p/amule-devel/Makefile
+++ b/net-p2p/amule-devel/Makefile
@@ -111,6 +111,11 @@ XAS_USE= PERL5+=run
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MPLASMAMULE}
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE= 2018-12-31
+.endif
+
.if ${PORT_OPTIONS:MED2K}
CONFLICTS+= ed2k-hash*
.endif
diff --git a/net-p2p/amule/Makefile b/net-p2p/amule/Makefile
index cefc64507c05..0dcb9b874824 100644
--- a/net-p2p/amule/Makefile
+++ b/net-p2p/amule/Makefile
@@ -107,6 +107,11 @@ XAS_USE= PERL5+=run
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MPLASMA_MULE}
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE= 2018-12-31
+.endif
+
.if ${PORT_OPTIONS:MED2K}
CONFLICTS+= ed2k-hash*
.endif
diff --git a/net-p2p/bitmessage/Makefile b/net-p2p/bitmessage/Makefile
index 5c7f80483298..52f69aaf9283 100644
--- a/net-p2p/bitmessage/Makefile
+++ b/net-p2p/bitmessage/Makefile
@@ -12,6 +12,9 @@ COMMENT= Secure P2P communications client
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE= 2019-03-15
+
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}qt4-core>=${PYQT4_VERSION}:devel/py-qt4-core@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}qt4-network>=${PYQT4_VERSION}:net/py-qt4-network@${PY_FLAVOR} \
diff --git a/net-p2p/eiskaltdcpp-qt/Makefile b/net-p2p/eiskaltdcpp-qt/Makefile
index 5b394eda7908..42b5aebd90ef 100644
--- a/net-p2p/eiskaltdcpp-qt/Makefile
+++ b/net-p2p/eiskaltdcpp-qt/Makefile
@@ -11,6 +11,9 @@ COMMENT= EiskaltDC++ Direct Connect client Qt GUI
LICENSE= GPLv3
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE= 2019-03-15
+
RUN_DEPENDS= eiskaltdcpp-data>=0:net-p2p/eiskaltdcpp-data
LIB_DEPENDS= libeiskaltdcpp.so:net-p2p/eiskaltdcpp-lib
diff --git a/net-p2p/torrent-file-editor/Makefile b/net-p2p/torrent-file-editor/Makefile
index dcb4d251ee12..92f061ca4e48 100644
--- a/net-p2p/torrent-file-editor/Makefile
+++ b/net-p2p/torrent-file-editor/Makefile
@@ -33,4 +33,11 @@ QT5_USE_OFF= QT=${_QT4_DEPS:ts,}
QT5_LIB_DEPENDS_OFF= libqjson.so:devel/qjson@qt4
QT5_CMAKE_BOOL= QT5_BUILD
+.include <bsd.port.options.mk>
+
+.if ! ${PORT_OPTIONS:MQT5}
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE= 2019-03-15
+.endif
+
.include <bsd.port.mk>
diff --git a/net-p2p/transmission-qt/Makefile b/net-p2p/transmission-qt/Makefile
index 0ae57fb4c84e..a838ec75c9f3 100644
--- a/net-p2p/transmission-qt/Makefile
+++ b/net-p2p/transmission-qt/Makefile
@@ -1,17 +1,20 @@
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 2
PKGNAMESUFFIX= -${FLAVOR}
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-FLAVORS= qt4 qt5
+FLAVORS= qt5 qt4
FLAVOR?= ${FLAVORS:[1]}
qt4_CONFLICTS_INSTALL= transmission-qt5
qt5_CONFLICTS_INSTALL= transmission-qt4
+qt4_DEPRECATED= Qt4 has been EOL since december 2015
+qt4_EXPIRATION_DATE= 2019-03-15
+
.if ${FLAVOR} == qt4
USES= qt:4
NLS_USES= gettext-runtime:run qt:4
diff --git a/net-p2p/valknut/Makefile b/net-p2p/valknut/Makefile
index 639a1e357cf8..3dde82e3d3ef 100644
--- a/net-p2p/valknut/Makefile
+++ b/net-p2p/valknut/Makefile
@@ -12,6 +12,9 @@ COMMENT= Qt-based Direct Connect client
LICENSE= GPLv2
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE= 2019-03-15
+
LIB_DEPENDS= libdc.so:net-p2p/dclib \
libxml2.so:textproc/libxml2
diff --git a/net-p2p/zetacoin/Makefile b/net-p2p/zetacoin/Makefile
index 73de18547fad..0c5e1dde9b07 100644
--- a/net-p2p/zetacoin/Makefile
+++ b/net-p2p/zetacoin/Makefile
@@ -4,7 +4,7 @@
PORTNAME= zetacoin
PORTVERSION= 0.11.2.3
DISTVERSIONPREFIX= v
-PORTREVISION= 21
+PORTREVISION= 22
CATEGORIES= net-p2p finance
MAINTAINER= daniel@morante.net
@@ -30,7 +30,7 @@ WALLET_DESC= Build wallet or P2P server node only
QRCODES_DESC= Enable QR code display when building graphical interface
CLI_DESC= Build command line RPC client
-OPTIONS_DEFAULT= X11 WALLET QRCODES
+OPTIONS_DEFAULT= WALLET
OPTIONS_GROUP= X11
OPTIONS_GROUP_X11= QRCODES
@@ -89,6 +89,9 @@ SUB_LIST+= PORTNAME=${PORTNAME}
SUB_FILES= pkg-message
USERS= ${PORTNAME}
GROUPS= ${PORTNAME}
+.else
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE= 2019-03-15
.endif
.include <bsd.port.pre.mk>