aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2018-10-06 13:06:42 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2018-10-06 13:06:42 +0000
commit9dff3523203bdda7ae358dcff3eb5a5ef3e54d33 (patch)
tree0721b637b4bcfc0a8ff2a945bdcb7e68f8993680 /net-p2p
parent2e4b740f2cc9a250b2c6056d8706e15d3bfa9763 (diff)
downloadports-9dff3523203bdda7ae358dcff3eb5a5ef3e54d33.tar.gz
ports-9dff3523203bdda7ae358dcff3eb5a5ef3e54d33.zip
Fix every instance of RUN_DEPENDS:=${BUILD_DEPENDS} in p5 ports, except
for where it resulted in a change in output from build-depends-list or run-depends-list. Approved by: portmgr (adamw)
Notes
Notes: svn path=/head/; revision=481365
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/p5-Net-BitTorrent-File/Makefile4
-rw-r--r--net-p2p/p5-Net-DirectConnect/Makefile4
-rw-r--r--net-p2p/p5-WWW-BitTorrent/Makefile4
3 files changed, 6 insertions, 6 deletions
diff --git a/net-p2p/p5-Net-BitTorrent-File/Makefile b/net-p2p/p5-Net-BitTorrent-File/Makefile
index a1e46f3f93ef..1ffb93f177cc 100644
--- a/net-p2p/p5-Net-BitTorrent-File/Makefile
+++ b/net-p2p/p5-Net-BitTorrent-File/Makefile
@@ -15,9 +15,9 @@ COMMENT= Perl5 module for handles loading and saving of .torrent file
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-Convert-Bencode>=0:converters/p5-Convert-Bencode \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Convert-Bencode>=0:converters/p5-Convert-Bencode \
p5-Digest-SHA1>=0:security/p5-Digest-SHA1
-RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_ARCH= yes
USE_PERL5= configure
diff --git a/net-p2p/p5-Net-DirectConnect/Makefile b/net-p2p/p5-Net-DirectConnect/Makefile
index f5e09da53bbc..f9fe3f0abe9e 100644
--- a/net-p2p/p5-Net-DirectConnect/Makefile
+++ b/net-p2p/p5-Net-DirectConnect/Makefile
@@ -14,7 +14,8 @@ COMMENT= Perl Direct Connect lib and client
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-DBD-SQLite>=0:databases/p5-DBD-SQLite \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-DBD-SQLite>=0:databases/p5-DBD-SQLite \
p5-DBI>=0:databases/p5-DBI \
p5-IO-Socket-INET6>=0:net/p5-IO-Socket-INET6 \
p5-IO-Socket-SSL>=0:security/p5-IO-Socket-SSL \
@@ -23,7 +24,6 @@ BUILD_DEPENDS= p5-DBD-SQLite>=0:databases/p5-DBD-SQLite \
p5-lib-abs>=0:devel/p5-lib-abs \
p5-MIME-Base32>=0:converters/p5-MIME-Base32 \
p5-Sys-Sendfile-FreeBSD>=0:devel/p5-Sys-Sendfile-FreeBSD
-RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
diff --git a/net-p2p/p5-WWW-BitTorrent/Makefile b/net-p2p/p5-WWW-BitTorrent/Makefile
index 077e4253879e..cf5b29086fc5 100644
--- a/net-p2p/p5-WWW-BitTorrent/Makefile
+++ b/net-p2p/p5-WWW-BitTorrent/Makefile
@@ -11,8 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= snowfly@yuntech.edu.tw
COMMENT= Search and Download .torrent(s) files from BitTorrents boards
-BUILD_DEPENDS= p5-libwww>=0:www/p5-libwww
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-libwww>=0:www/p5-libwww
USES= perl5 shebangfix
SHEBANG_FILES= bittorrent.pl