aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-10-01 19:57:46 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-10-01 19:57:46 +0000
commitae7f26f1073d97439314cedfaa89107eb94786db (patch)
tree93c1a550edea769dc1279d204b5adce4e9b5fd8e /net-p2p
parentba38e1e8be2b8403dd01fdecb1b63049adad84e9 (diff)
downloadports-ae7f26f1073d97439314cedfaa89107eb94786db.tar.gz
ports-ae7f26f1073d97439314cedfaa89107eb94786db.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/libtorrent-rasterbar-14/Makefile9
-rw-r--r--net-p2p/libtorrent-rasterbar-14/distinfo6
-rw-r--r--net-p2p/libtorrent-rasterbar-14/files/patch-socket_ops.hpp21
-rw-r--r--net-p2p/libtorrent-rasterbar-14/files/patch-src__storage.cpp15
-rw-r--r--net-p2p/libtorrent-rasterbar-14/pkg-plist30
-rw-r--r--net-p2p/rblibtorrent-devel/Makefile9
-rw-r--r--net-p2p/rblibtorrent-devel/distinfo6
-rw-r--r--net-p2p/rblibtorrent-devel/files/patch-socket_ops.hpp21
-rw-r--r--net-p2p/rblibtorrent-devel/files/patch-src__storage.cpp15
-rw-r--r--net-p2p/rblibtorrent-devel/pkg-plist30
10 files changed, 124 insertions, 38 deletions
diff --git a/net-p2p/libtorrent-rasterbar-14/Makefile b/net-p2p/libtorrent-rasterbar-14/Makefile
index 06541c5aa0e4..815b4b861ab7 100644
--- a/net-p2p/libtorrent-rasterbar-14/Makefile
+++ b/net-p2p/libtorrent-rasterbar-14/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= libtorrent
-PORTVERSION= 0.12
-PORTREVISION= 1
+DISTVERSION= 0.13svn.r1615
CATEGORIES= net-p2p
-MASTER_SITES= SF
+MASTER_SITES= SF/qbittorrent
PKGNAMEPREFIX= rb
PKGNAMESUFFIX= -devel
@@ -28,4 +27,8 @@ CONFLICTS= libtorrent-[0-9]* \
libtorrent-devel-[0-9]* \
rblibtorrent-[0-9]*
+post-install:
+ @cd ${PREFIX}/lib && ${MV} libtorrent-0.13.so libtorrent.so.1 && \
+ ${LN} -sf libtorrent.so.1 libtorrent.so
+
.include <bsd.port.mk>
diff --git a/net-p2p/libtorrent-rasterbar-14/distinfo b/net-p2p/libtorrent-rasterbar-14/distinfo
index f12d4973f5b2..d6ed702b1b33 100644
--- a/net-p2p/libtorrent-rasterbar-14/distinfo
+++ b/net-p2p/libtorrent-rasterbar-14/distinfo
@@ -1,3 +1,3 @@
-MD5 (libtorrent-0.12.tar.gz) = a09a37e6fc74d152821c00c3cb15d248
-SHA256 (libtorrent-0.12.tar.gz) = 0663f9adaa9d90334ebf78eb6f5b31074ff533d7bec5d3325ff98baad5b7df07
-SIZE (libtorrent-0.12.tar.gz) = 1176469
+MD5 (libtorrent-0.13svn.r1615.tar.gz) = 7e006958274b6a9e9c7827543ca3248c
+SHA256 (libtorrent-0.13svn.r1615.tar.gz) = e0ebc667184e4db79d53d631ea239608c75ae55a8918de956c5db92bddab3ed3
+SIZE (libtorrent-0.13svn.r1615.tar.gz) = 1898209
diff --git a/net-p2p/libtorrent-rasterbar-14/files/patch-socket_ops.hpp b/net-p2p/libtorrent-rasterbar-14/files/patch-socket_ops.hpp
index 65260b013846..651e734b4067 100644
--- a/net-p2p/libtorrent-rasterbar-14/files/patch-socket_ops.hpp
+++ b/net-p2p/libtorrent-rasterbar-14/files/patch-socket_ops.hpp
@@ -1,10 +1,11 @@
---- include/libtorrent/asio/detail/socket_ops.hpp Wed May 16 00:35:55 2007
-+++ include/libtorrent/asio/detail/socket_ops.hpp.orig Wed May 16 00:35:45 2007
-66c66
-< #if defined(__MACH__) && defined(__APPLE__)
----
-> #if defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
-298c298
-< #elif defined(__MACH__) && defined(__APPLE__)
----
-> #elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
+--- include/libtorrent/asio/detail/socket_ops.hpp.orig Wed Aug 8 03:43:42 2007
++++ include/libtorrent/asio/detail/socket_ops.hpp Mon Sep 10 12:46:17 2007
+@@ -715,7 +715,7 @@
+ if (error)
+ ec = translate_netdb_error(error);
+ return retval;
+-#elif defined(__MACH__) && defined(__APPLE__)
++#elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
+ (void)(buffer);
+ (void)(buflength);
+ int error = 0;
diff --git a/net-p2p/libtorrent-rasterbar-14/files/patch-src__storage.cpp b/net-p2p/libtorrent-rasterbar-14/files/patch-src__storage.cpp
new file mode 100644
index 000000000000..ea0156332167
--- /dev/null
+++ b/net-p2p/libtorrent-rasterbar-14/files/patch-src__storage.cpp
@@ -0,0 +1,15 @@
+--- src/storage.cpp.orig Sat Aug 25 15:26:43 2007
++++ src/storage.cpp Mon Sep 10 12:51:23 2007
+@@ -75,9 +75,11 @@
+ #include <cstdio>
+ #endif
+
+-#if defined(__APPLE__)
++#if defined(__APPLE__) || defined(__FreeBSD__)
+ // for getattrlist()
++#ifdef __APPLE__
+ #include <sys/attr.h>
++#endif
+ #include <unistd.h>
+ // for statfs()
+ #include <sys/param.h>
diff --git a/net-p2p/libtorrent-rasterbar-14/pkg-plist b/net-p2p/libtorrent-rasterbar-14/pkg-plist
index b288f6ebee40..3897868e6ffe 100644
--- a/net-p2p/libtorrent-rasterbar-14/pkg-plist
+++ b/net-p2p/libtorrent-rasterbar-14/pkg-plist
@@ -1,6 +1,5 @@
include/libtorrent/alert.hpp
include/libtorrent/alert_types.hpp
-include/libtorrent/allocate_resources.hpp
include/libtorrent/asio.hpp
include/libtorrent/asio/basic_datagram_socket.hpp
include/libtorrent/asio/basic_deadline_timer.hpp
@@ -35,6 +34,7 @@ include/libtorrent/asio/detail/event.hpp
include/libtorrent/asio/detail/fd_set_adapter.hpp
include/libtorrent/asio/detail/handler_alloc_helpers.hpp
include/libtorrent/asio/detail/handler_invoke_helpers.hpp
+include/libtorrent/asio/detail/handler_queue.hpp
include/libtorrent/asio/detail/hash_map.hpp
include/libtorrent/asio/detail/io_control.hpp
include/libtorrent/asio/detail/kqueue_reactor.hpp
@@ -120,6 +120,8 @@ include/libtorrent/asio/ip/resolver_query_base.hpp
include/libtorrent/asio/ip/resolver_service.hpp
include/libtorrent/asio/ip/tcp.hpp
include/libtorrent/asio/ip/udp.hpp
+include/libtorrent/asio/ip/unicast.hpp
+include/libtorrent/asio/ip/v6_only.hpp
include/libtorrent/asio/is_read_buffered.hpp
include/libtorrent/asio/is_write_buffered.hpp
include/libtorrent/asio/placeholders.hpp
@@ -146,16 +148,22 @@ include/libtorrent/asio/streambuf.hpp
include/libtorrent/asio/system_error.hpp
include/libtorrent/asio/thread.hpp
include/libtorrent/asio/time_traits.hpp
+include/libtorrent/asio/version.hpp
include/libtorrent/asio/write.hpp
-include/libtorrent/aux_/allocate_resources_impl.hpp
+include/libtorrent/assert.hpp
include/libtorrent/aux_/session_impl.hpp
include/libtorrent/bandwidth_manager.hpp
include/libtorrent/bencode.hpp
+include/libtorrent/broadcast_socket.hpp
include/libtorrent/bt_peer_connection.hpp
include/libtorrent/buffer.hpp
+include/libtorrent/chained_buffer.hpp
include/libtorrent/config.hpp
+include/libtorrent/connection_queue.hpp
include/libtorrent/debug.hpp
+include/libtorrent/disk_io_thread.hpp
include/libtorrent/entry.hpp
+include/libtorrent/enum_net.hpp
include/libtorrent/escape_string.hpp
include/libtorrent/extensions.hpp
include/libtorrent/extensions/logger.hpp
@@ -165,8 +173,12 @@ include/libtorrent/file.hpp
include/libtorrent/file_pool.hpp
include/libtorrent/fingerprint.hpp
include/libtorrent/hasher.hpp
+include/libtorrent/http_connection.hpp
+include/libtorrent/http_stream.hpp
include/libtorrent/http_tracker_connection.hpp
include/libtorrent/identify_client.hpp
+include/libtorrent/instantiate_connection.hpp
+include/libtorrent/intrusive_ptr_base.hpp
include/libtorrent/invariant_check.hpp
include/libtorrent/io.hpp
include/libtorrent/ip_filter.hpp
@@ -174,14 +186,20 @@ include/libtorrent/kademlia/closest_nodes.hpp
include/libtorrent/kademlia/dht_tracker.hpp
include/libtorrent/kademlia/find_data.hpp
include/libtorrent/kademlia/logging.hpp
+include/libtorrent/kademlia/msg.hpp
include/libtorrent/kademlia/node.hpp
include/libtorrent/kademlia/node_entry.hpp
include/libtorrent/kademlia/node_id.hpp
+include/libtorrent/kademlia/observer.hpp
include/libtorrent/kademlia/packet_iterator.hpp
include/libtorrent/kademlia/refresh.hpp
include/libtorrent/kademlia/routing_table.hpp
include/libtorrent/kademlia/rpc_manager.hpp
include/libtorrent/kademlia/traversal_algorithm.hpp
+include/libtorrent/lsd.hpp
+include/libtorrent/natpmp.hpp
+include/libtorrent/pch.hpp
+include/libtorrent/pe_crypto.hpp
include/libtorrent/peer.hpp
include/libtorrent/peer_connection.hpp
include/libtorrent/peer_id.hpp
@@ -190,23 +208,29 @@ include/libtorrent/peer_request.hpp
include/libtorrent/piece_block_progress.hpp
include/libtorrent/piece_picker.hpp
include/libtorrent/policy.hpp
+include/libtorrent/proxy_base.hpp
include/libtorrent/random_sample.hpp
-include/libtorrent/resource_request.hpp
include/libtorrent/session.hpp
include/libtorrent/session_settings.hpp
include/libtorrent/session_status.hpp
include/libtorrent/size_type.hpp
include/libtorrent/socket.hpp
+include/libtorrent/socket_type.hpp
+include/libtorrent/socks4_stream.hpp
+include/libtorrent/socks5_stream.hpp
include/libtorrent/stat.hpp
include/libtorrent/storage.hpp
+include/libtorrent/time.hpp
include/libtorrent/torrent.hpp
include/libtorrent/torrent_handle.hpp
include/libtorrent/torrent_info.hpp
include/libtorrent/tracker_manager.hpp
include/libtorrent/udp_tracker_connection.hpp
include/libtorrent/utf8.hpp
+include/libtorrent/variant_stream.hpp
include/libtorrent/version.hpp
include/libtorrent/web_peer_connection.hpp
+include/libtorrent/xml_parse.hpp
lib/libtorrent.a
lib/libtorrent.la
lib/libtorrent.so
diff --git a/net-p2p/rblibtorrent-devel/Makefile b/net-p2p/rblibtorrent-devel/Makefile
index 06541c5aa0e4..815b4b861ab7 100644
--- a/net-p2p/rblibtorrent-devel/Makefile
+++ b/net-p2p/rblibtorrent-devel/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= libtorrent
-PORTVERSION= 0.12
-PORTREVISION= 1
+DISTVERSION= 0.13svn.r1615
CATEGORIES= net-p2p
-MASTER_SITES= SF
+MASTER_SITES= SF/qbittorrent
PKGNAMEPREFIX= rb
PKGNAMESUFFIX= -devel
@@ -28,4 +27,8 @@ CONFLICTS= libtorrent-[0-9]* \
libtorrent-devel-[0-9]* \
rblibtorrent-[0-9]*
+post-install:
+ @cd ${PREFIX}/lib && ${MV} libtorrent-0.13.so libtorrent.so.1 && \
+ ${LN} -sf libtorrent.so.1 libtorrent.so
+
.include <bsd.port.mk>
diff --git a/net-p2p/rblibtorrent-devel/distinfo b/net-p2p/rblibtorrent-devel/distinfo
index f12d4973f5b2..d6ed702b1b33 100644
--- a/net-p2p/rblibtorrent-devel/distinfo
+++ b/net-p2p/rblibtorrent-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (libtorrent-0.12.tar.gz) = a09a37e6fc74d152821c00c3cb15d248
-SHA256 (libtorrent-0.12.tar.gz) = 0663f9adaa9d90334ebf78eb6f5b31074ff533d7bec5d3325ff98baad5b7df07
-SIZE (libtorrent-0.12.tar.gz) = 1176469
+MD5 (libtorrent-0.13svn.r1615.tar.gz) = 7e006958274b6a9e9c7827543ca3248c
+SHA256 (libtorrent-0.13svn.r1615.tar.gz) = e0ebc667184e4db79d53d631ea239608c75ae55a8918de956c5db92bddab3ed3
+SIZE (libtorrent-0.13svn.r1615.tar.gz) = 1898209
diff --git a/net-p2p/rblibtorrent-devel/files/patch-socket_ops.hpp b/net-p2p/rblibtorrent-devel/files/patch-socket_ops.hpp
index 65260b013846..651e734b4067 100644
--- a/net-p2p/rblibtorrent-devel/files/patch-socket_ops.hpp
+++ b/net-p2p/rblibtorrent-devel/files/patch-socket_ops.hpp
@@ -1,10 +1,11 @@
---- include/libtorrent/asio/detail/socket_ops.hpp Wed May 16 00:35:55 2007
-+++ include/libtorrent/asio/detail/socket_ops.hpp.orig Wed May 16 00:35:45 2007
-66c66
-< #if defined(__MACH__) && defined(__APPLE__)
----
-> #if defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
-298c298
-< #elif defined(__MACH__) && defined(__APPLE__)
----
-> #elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
+--- include/libtorrent/asio/detail/socket_ops.hpp.orig Wed Aug 8 03:43:42 2007
++++ include/libtorrent/asio/detail/socket_ops.hpp Mon Sep 10 12:46:17 2007
+@@ -715,7 +715,7 @@
+ if (error)
+ ec = translate_netdb_error(error);
+ return retval;
+-#elif defined(__MACH__) && defined(__APPLE__)
++#elif defined(__MACH__) && defined(__APPLE__) || defined(__FreeBSD__)
+ (void)(buffer);
+ (void)(buflength);
+ int error = 0;
diff --git a/net-p2p/rblibtorrent-devel/files/patch-src__storage.cpp b/net-p2p/rblibtorrent-devel/files/patch-src__storage.cpp
new file mode 100644
index 000000000000..ea0156332167
--- /dev/null
+++ b/net-p2p/rblibtorrent-devel/files/patch-src__storage.cpp
@@ -0,0 +1,15 @@
+--- src/storage.cpp.orig Sat Aug 25 15:26:43 2007
++++ src/storage.cpp Mon Sep 10 12:51:23 2007
+@@ -75,9 +75,11 @@
+ #include <cstdio>
+ #endif
+
+-#if defined(__APPLE__)
++#if defined(__APPLE__) || defined(__FreeBSD__)
+ // for getattrlist()
++#ifdef __APPLE__
+ #include <sys/attr.h>
++#endif
+ #include <unistd.h>
+ // for statfs()
+ #include <sys/param.h>
diff --git a/net-p2p/rblibtorrent-devel/pkg-plist b/net-p2p/rblibtorrent-devel/pkg-plist
index b288f6ebee40..3897868e6ffe 100644
--- a/net-p2p/rblibtorrent-devel/pkg-plist
+++ b/net-p2p/rblibtorrent-devel/pkg-plist
@@ -1,6 +1,5 @@
include/libtorrent/alert.hpp
include/libtorrent/alert_types.hpp
-include/libtorrent/allocate_resources.hpp
include/libtorrent/asio.hpp
include/libtorrent/asio/basic_datagram_socket.hpp
include/libtorrent/asio/basic_deadline_timer.hpp
@@ -35,6 +34,7 @@ include/libtorrent/asio/detail/event.hpp
include/libtorrent/asio/detail/fd_set_adapter.hpp
include/libtorrent/asio/detail/handler_alloc_helpers.hpp
include/libtorrent/asio/detail/handler_invoke_helpers.hpp
+include/libtorrent/asio/detail/handler_queue.hpp
include/libtorrent/asio/detail/hash_map.hpp
include/libtorrent/asio/detail/io_control.hpp
include/libtorrent/asio/detail/kqueue_reactor.hpp
@@ -120,6 +120,8 @@ include/libtorrent/asio/ip/resolver_query_base.hpp
include/libtorrent/asio/ip/resolver_service.hpp
include/libtorrent/asio/ip/tcp.hpp
include/libtorrent/asio/ip/udp.hpp
+include/libtorrent/asio/ip/unicast.hpp
+include/libtorrent/asio/ip/v6_only.hpp
include/libtorrent/asio/is_read_buffered.hpp
include/libtorrent/asio/is_write_buffered.hpp
include/libtorrent/asio/placeholders.hpp
@@ -146,16 +148,22 @@ include/libtorrent/asio/streambuf.hpp
include/libtorrent/asio/system_error.hpp
include/libtorrent/asio/thread.hpp
include/libtorrent/asio/time_traits.hpp
+include/libtorrent/asio/version.hpp
include/libtorrent/asio/write.hpp
-include/libtorrent/aux_/allocate_resources_impl.hpp
+include/libtorrent/assert.hpp
include/libtorrent/aux_/session_impl.hpp
include/libtorrent/bandwidth_manager.hpp
include/libtorrent/bencode.hpp
+include/libtorrent/broadcast_socket.hpp
include/libtorrent/bt_peer_connection.hpp
include/libtorrent/buffer.hpp
+include/libtorrent/chained_buffer.hpp
include/libtorrent/config.hpp
+include/libtorrent/connection_queue.hpp
include/libtorrent/debug.hpp
+include/libtorrent/disk_io_thread.hpp
include/libtorrent/entry.hpp
+include/libtorrent/enum_net.hpp
include/libtorrent/escape_string.hpp
include/libtorrent/extensions.hpp
include/libtorrent/extensions/logger.hpp
@@ -165,8 +173,12 @@ include/libtorrent/file.hpp
include/libtorrent/file_pool.hpp
include/libtorrent/fingerprint.hpp
include/libtorrent/hasher.hpp
+include/libtorrent/http_connection.hpp
+include/libtorrent/http_stream.hpp
include/libtorrent/http_tracker_connection.hpp
include/libtorrent/identify_client.hpp
+include/libtorrent/instantiate_connection.hpp
+include/libtorrent/intrusive_ptr_base.hpp
include/libtorrent/invariant_check.hpp
include/libtorrent/io.hpp
include/libtorrent/ip_filter.hpp
@@ -174,14 +186,20 @@ include/libtorrent/kademlia/closest_nodes.hpp
include/libtorrent/kademlia/dht_tracker.hpp
include/libtorrent/kademlia/find_data.hpp
include/libtorrent/kademlia/logging.hpp
+include/libtorrent/kademlia/msg.hpp
include/libtorrent/kademlia/node.hpp
include/libtorrent/kademlia/node_entry.hpp
include/libtorrent/kademlia/node_id.hpp
+include/libtorrent/kademlia/observer.hpp
include/libtorrent/kademlia/packet_iterator.hpp
include/libtorrent/kademlia/refresh.hpp
include/libtorrent/kademlia/routing_table.hpp
include/libtorrent/kademlia/rpc_manager.hpp
include/libtorrent/kademlia/traversal_algorithm.hpp
+include/libtorrent/lsd.hpp
+include/libtorrent/natpmp.hpp
+include/libtorrent/pch.hpp
+include/libtorrent/pe_crypto.hpp
include/libtorrent/peer.hpp
include/libtorrent/peer_connection.hpp
include/libtorrent/peer_id.hpp
@@ -190,23 +208,29 @@ include/libtorrent/peer_request.hpp
include/libtorrent/piece_block_progress.hpp
include/libtorrent/piece_picker.hpp
include/libtorrent/policy.hpp
+include/libtorrent/proxy_base.hpp
include/libtorrent/random_sample.hpp
-include/libtorrent/resource_request.hpp
include/libtorrent/session.hpp
include/libtorrent/session_settings.hpp
include/libtorrent/session_status.hpp
include/libtorrent/size_type.hpp
include/libtorrent/socket.hpp
+include/libtorrent/socket_type.hpp
+include/libtorrent/socks4_stream.hpp
+include/libtorrent/socks5_stream.hpp
include/libtorrent/stat.hpp
include/libtorrent/storage.hpp
+include/libtorrent/time.hpp
include/libtorrent/torrent.hpp
include/libtorrent/torrent_handle.hpp
include/libtorrent/torrent_info.hpp
include/libtorrent/tracker_manager.hpp
include/libtorrent/udp_tracker_connection.hpp
include/libtorrent/utf8.hpp
+include/libtorrent/variant_stream.hpp
include/libtorrent/version.hpp
include/libtorrent/web_peer_connection.hpp
+include/libtorrent/xml_parse.hpp
lib/libtorrent.a
lib/libtorrent.la
lib/libtorrent.so