aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2020-11-16 08:25:30 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2020-11-16 08:25:30 +0000
commitc970e6bfbee58920f29464eecff2eb129e250ceb (patch)
tree1d43da7318e5371997713a2c3e34eb3410975fda /net-p2p
parent7b0ed90f43a0412e8c236996787ceff4b1717e30 (diff)
downloadports-c970e6bfbee58920f29464eecff2eb129e250ceb.tar.gz
ports-c970e6bfbee58920f29464eecff2eb129e250ceb.zip
net-p2p/deluge-cli: add upstream patch
Add patch for: https://dev.deluge-torrent.org/ticket/3337 It fixes list of listen hosts:ports parsing. Reported by: Daniel O'Connor <darius@dons.net.au> (by email)
Notes
Notes: svn path=/head/; revision=555454
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/deluge-cli/Makefile2
-rw-r--r--net-p2p/deluge-cli/files/patch-deluge_core_preferencesmanager.py13
2 files changed, 14 insertions, 1 deletions
diff --git a/net-p2p/deluge-cli/Makefile b/net-p2p/deluge-cli/Makefile
index e580f23bd900..a8a18e5fc4c2 100644
--- a/net-p2p/deluge-cli/Makefile
+++ b/net-p2p/deluge-cli/Makefile
@@ -2,7 +2,7 @@
PORTNAME= deluge
DISTVERSION= 2.0.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-p2p python
MASTER_SITES= CHEESESHOP
PKGNAMESUFFIX= -cli
diff --git a/net-p2p/deluge-cli/files/patch-deluge_core_preferencesmanager.py b/net-p2p/deluge-cli/files/patch-deluge_core_preferencesmanager.py
new file mode 100644
index 000000000000..e833dd0896e7
--- /dev/null
+++ b/net-p2p/deluge-cli/files/patch-deluge_core_preferencesmanager.py
@@ -0,0 +1,13 @@
+Fix for https://dev.deluge-torrent.org/ticket/3337
+
+--- deluge/core/preferencesmanager.py.orig 2020-11-16 07:47:52 UTC
++++ deluge/core/preferencesmanager.py
+@@ -231,7 +231,7 @@ class PreferencesManager(component.Component):
+ self.core.apply_session_settings(
+ {
+ 'listen_system_port_fallback': self.config['listen_use_sys_port'],
+- 'listen_interfaces': ''.join(interfaces),
++ 'listen_interfaces': ','.join(interfaces),
+ }
+ )
+