aboutsummaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-10-02 19:44:36 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-10-02 19:44:36 +0000
commitf9326a20d7e571e7e532bd7818f3298f1b152eab (patch)
treeb692bee7d1b6ef4cc85f9bb5b69d20b5cc737548 /net-p2p
parent2cef7ae1a2f94a7ac077b10bf1e46fc515550ccb (diff)
downloadports-f9326a20d7e571e7e532bd7818f3298f1b152eab.tar.gz
ports-f9326a20d7e571e7e532bd7818f3298f1b152eab.zip
Notes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/mldonkey/Makefile3
-rw-r--r--net-p2p/mldonkey/distinfo4
-rw-r--r--net-p2p/mldonkey/files/patch-Makefile37
-rw-r--r--net-p2p/mldonkey/files/patch-hashes153
4 files changed, 190 insertions, 7 deletions
diff --git a/net-p2p/mldonkey/Makefile b/net-p2p/mldonkey/Makefile
index abdb80851f71..d8c8d6c410b7 100644
--- a/net-p2p/mldonkey/Makefile
+++ b/net-p2p/mldonkey/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mldonkey
-PORTVERSION= 2.5.28.1
+PORTVERSION= 2.5.30.17
CATEGORIES+= net
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,6 +21,7 @@ CONFLICTS= mldonkey-devel-[0-9]*
USE_BZIP2= yes
WANT_AUTOCONF_VER= 259
USE_REINPLACE= yes
+USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-pthread --enable-ocamlver=3
USE_GMAKE= yes
diff --git a/net-p2p/mldonkey/distinfo b/net-p2p/mldonkey/distinfo
index 9318eb9e2f45..39752e077cb1 100644
--- a/net-p2p/mldonkey/distinfo
+++ b/net-p2p/mldonkey/distinfo
@@ -1,2 +1,2 @@
-MD5 (mldonkey-2.5.28.1.tar.bz2) = 4f24b2e1eeac4b54151ca2473ade45ec
-SIZE (mldonkey-2.5.28.1.tar.bz2) = 2791684
+MD5 (mldonkey-2.5.30.17.tar.bz2) = f8db2c502c7ed4f660af124a431af020
+SIZE (mldonkey-2.5.30.17.tar.bz2) = 2654409
diff --git a/net-p2p/mldonkey/files/patch-Makefile b/net-p2p/mldonkey/files/patch-Makefile
index bbd57ad8fff1..452e3963a19d 100644
--- a/net-p2p/mldonkey/files/patch-Makefile
+++ b/net-p2p/mldonkey/files/patch-Makefile
@@ -1,11 +1,40 @@
---- Makefile.orig Wed Sep 8 22:54:44 2004
-+++ Makefile Wed Sep 8 22:54:54 2004
-@@ -258,7 +258,7 @@
+--- config/Makefile.in.orig Tue Sep 6 21:51:36 2005
++++ config/Makefile.in Tue Sep 6 22:00:47 2005
+@@ -144,6 +144,11 @@
+ CDK_SRCS += $(CDK)/zlib.ml $(CDK)/zlibstubs.c
+ endif
+
++ifneq ("$(OPENSSLBASE)", "/usr")
++ LIBS_flags += -ccopt -I$(OPENSSLINC) -cclib -L$(OPENSSLLIB)
++endif
++LIBS_flags += -cclib -lcrypto
++
+ ifeq ("$(GD)", "yes")
+ LIBS_flags += -cclib -lgd -cclib -lfreetype -cclib -lm
+ LIBS_flags += -ccopt -W -ccopt -Wall -ccopt -Wno-unused
+@@ -219,8 +224,7 @@
+ $(LIB)/misc.ml $(LIB)/unix32.ml $(LIB)/md4.ml \
+ $(LIB)/avifile.ml $(LIB)/http_lexer.mll $(LIB)/url.ml \
+ $(LIB)/date.ml $(LIB)/fst_hash.c \
+- $(LIB)/md4_comp.c $(LIB)/md4_c.c \
+- $(LIB)/gettext.ml4 $(LIB)/md5_c.c $(LIB)/$(SHA1_VERSION)_c.c \
++ $(LIB)/md4_c.c $(LIB)/gettext.ml4 \
+ $(LIB)/tiger.c \
+ $(LIB)/stubs_c.c $(LIB)/queues.ml \
+ $(LIB)/charsetstubs.c $(LIB)/charset.ml
+@@ -291,7 +295,7 @@
all: Makefile config/Makefile.config $(TARGET_TYPE)
config/configure: config/configure.in
- cd config; autoconf
+ cd config; %%AUTOCONF%%
- ifeq ("$(MYCONFIG_ARGS_DEFINED)" , "yes")
+ ifeq ("$(CONFIGURE_RUN)" , "yes")
+
+@@ -2059,5 +2063,4 @@
+ src/utils/lib/sha1new_c.o: src/utils/lib/sha1new_c.h \
+ src/utils/lib/sha1_c.h src/utils/lib/os_stubs.h
+-src/daemon/common/commonHasher_c.o: src/utils/lib/sha1_c.h
+-src/utils/lib/stubs_c.o: src/utils/lib/sha1_c.h
++src/daemon/common/commonHasher_c.o:
diff --git a/net-p2p/mldonkey/files/patch-hashes b/net-p2p/mldonkey/files/patch-hashes
new file mode 100644
index 000000000000..1d042f022330
--- /dev/null
+++ b/net-p2p/mldonkey/files/patch-hashes
@@ -0,0 +1,153 @@
+--- src/utils/lib/stubs_c.c.orig Tue Sep 6 22:03:39 2005
++++ src/utils/lib/stubs_c.c Tue Sep 6 22:11:04 2005
+@@ -515,11 +515,11 @@
+ nread = os_read (fd, hash_buffer, max_nread); \
+ \
+ if(nread < 0) { \
+- unix_error(errno, "md4_safe_fd: Read", Nothing); \
++ unix_error(errno, "HASH_NAME##un_safe_fd: Read", Nothing); \
+ } \
+ \
+ if(nread == 0){ \
+- HASH_FINISH (&context, digest); \
++ HASH_FINISH (digest, &context); \
+ \
+ return Val_unit; \
+ } \
+@@ -527,7 +527,7 @@
+ HASH_APPEND (&context, hash_buffer, nread); \
+ len -= nread; \
+ } \
+- HASH_FINISH (&context, digest); \
++ HASH_FINISH (digest, &context); \
+ \
+ return Val_unit; \
+ } \
+@@ -541,7 +541,7 @@
+ \
+ HASH_INIT (&context); \
+ HASH_APPEND (&context, string, len); \
+- HASH_FINISH (&context, digest); \
++ HASH_FINISH (digest, &context); \
+ \
+ return Val_unit; \
+ } \
+@@ -561,7 +561,7 @@
+ HASH_INIT (&context); \
+ while ((len = fread (hash_buffer, 1, HASH_BUFFER_LEN, file)) >0) \
+ HASH_APPEND (&context, hash_buffer, len); \
+- HASH_FINISH (&context, digest); \
++ HASH_FINISH (digest, &context); \
+ \
+ fclose (file); \
+ } \
+@@ -569,13 +569,13 @@
+ } \
+
+
+-#include "md4.h"
+-#include "md5.h"
+-#include "sha1_c.h"
++#include <openssl/md4.h>
++#include <openssl/md5.h>
++#include <openssl/sha.h>
+
+-ML_HASH(sha1,SHA1_CTX,sha1_begin,sha1_hash, sha1_end)
+-ML_HASH(md5,md5_state_t,md5_init,md5_append,md5_finish)
+-ML_HASH(md4,MD4_CTX,MD4Init,MD4Update,md4_finish)
++ML_HASH(sha1,SHA_CTX,SHA1_Init,SHA1_Update, SHA1_Final)
++ML_HASH(md5, MD5_CTX, MD5_Init, MD5_Update, MD5_Final)
++ML_HASH(md4, MD4_CTX, MD4_Init, MD4_Update, MD4_Final)
+
+ /*******************************************************************
+
+--- src/daemon/common/commonHasher_c.c.orig Tue Sep 6 22:14:27 2005
++++ src/daemon/common/commonHasher_c.c Tue Sep 6 22:19:35 2005
+@@ -37,9 +37,9 @@
+ #define JOB_HANDLER 5
+ #define JOB_ERROR 6
+
+-#include "../../utils/lib/md4.h"
+-#include "../../utils/lib/md5.h"
+-#include "../../utils/lib/sha1_c.h"
++#include <openssl/md4.h>
++#include <openssl/md5.h>
++#include <openssl/sha.h>
+ #include "../../utils/lib/tiger.h"
+
+
+@@ -68,7 +68,7 @@
+ unix_error(errno, "HASH_NAME##unsafe64_fd_direct: Read", Nothing); \
+ } \
+ if(nread == 0){ \
+- HASH_FINISH (&context, digest); \
++ HASH_FINISH (digest, &context); \
+ \
+ return; \
+ } \
+@@ -76,12 +76,12 @@
+ HASH_APPEND (&context, local_hash_buffer, nread); \
+ len -= nread; \
+ } \
+- HASH_FINISH (&context, digest); \
++ HASH_FINISH (digest, &context); \
+ }
+
+-COMPLETE_HASH(sha1,SHA1_CTX,sha1_begin,sha1_hash, sha1_end)
+-COMPLETE_HASH(md5,md5_state_t,md5_init,md5_append,md5_finish)
+-COMPLETE_HASH(md4,MD4_CTX,MD4Init,MD4Update,md4_finish)
++COMPLETE_HASH(sha1,SHA_CTX,SHA1_Init,SHA1_Update, SHA1_Final)
++COMPLETE_HASH(md5, MD5_CTX, MD5_Init, MD5_Update, MD5_Final)
++COMPLETE_HASH(md4, MD4_CTX, MD4_Init, MD4_Update, MD4_Final)
+
+ static void tiger_tree_fd(OS_FD fd, long len, off_t pos,
+ int block_size, char *digest)
+@@ -160,7 +160,7 @@
+ \
+ if(nread == 0){ \
+ unsigned char *digest = String_val(Field(job_v, JOB_RESULT)); \
+- HASH_FINISH (&context, digest); \
++ HASH_FINISH (digest, &context); \
+ job_finished = 1; \
+ timer = 10; \
+ return Val_true; \
+@@ -173,7 +173,7 @@
+ \
+ if(job_len <= 0){ \
+ unsigned char *digest = String_val(Field(job_v, JOB_RESULT)); \
+- HASH_FINISH (&context, digest); \
++ HASH_FINISH (digest, &context); \
+ job_finished = 1; \
+ timer = 10; \
+ return Val_true; \
+--- src/networks/fasttrack/fst_crypt.c.orig Tue Sep 6 22:23:50 2005
++++ src/networks/fasttrack/fst_crypt.c Tue Sep 6 22:26:34 2005
+@@ -15,7 +15,7 @@
+ * General Public License for more details.
+ */
+
+-#include "../../utils/lib/md5.h"
++#include <openssl/md5.h>
+ #include "fst_crypt.h"
+
+ /*****************************************************************************/
+@@ -106,14 +106,14 @@
+
+ if (enc_type & 0x08)
+ {
+- MD5Context ctx;
+- unsigned char md5[MD5_HASH_LEN];
++ MD5_CTX ctx;
++ unsigned char md5[MD5_DIGEST_LENGTH];
+
+ FST_HEAVY_DBG ("init_cipher: enc_type & 0x08");
+
+- MD5Init (&ctx);
+- MD5Update (&ctx, cipher->pad, sizeof(cipher->pad));
+- MD5Final (md5, &ctx);
++ MD5_Init (&ctx);
++ MD5_Update (&ctx, cipher->pad, sizeof(cipher->pad));
++ MD5_Final (md5, &ctx);
+
+ /* correct md5 byte order on big-endian since it's converted to (unsigned int*) below */
+ reverse_bytes ( (unsigned int*)&md5, 4);