aboutsummaryrefslogtreecommitdiff
path: root/net/3proxy
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2017-10-22 19:36:03 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2017-10-22 19:36:03 +0000
commit35eff3e9e89d642bc74eb4e101fa4e32fafe8b69 (patch)
tree789fa387b71257ecd60fe92d4232a5ab613e6c0d /net/3proxy
parent96f40de2b6d899d8dd621caa4a67a6371d786ce4 (diff)
downloadports-35eff3e9e89d642bc74eb4e101fa4e32fafe8b69.tar.gz
ports-35eff3e9e89d642bc74eb4e101fa4e32fafe8b69.zip
* Updated to 0.8.11
* Fixed patches to satisfy portlint - Fixed: deadlock on insufficient resources - Fixed: race condition in ssl_plugin - Fixed: minor memory leak on configuration reload - Fixed: recursion detection was not working - Fixed: %n for IPv6 in logging terminates log record - Fixed: reverse PTR validation (required for dnsauth) - Fixed: error on external 0.0.0.0 for NOIPV6 (light version) - Better support for IPv6 in ftppr PR: 223148 Submitted by: t^@gmail.com (maintainer)
Notes
Notes: svn path=/head/; revision=452682
Diffstat (limited to 'net/3proxy')
-rw-r--r--net/3proxy/Makefile2
-rw-r--r--net/3proxy/distinfo4
-rw-r--r--net/3proxy/files/patch-Makefile.unix8
-rw-r--r--net/3proxy/files/patch-cfg_3proxy.cfg.sample (renamed from net/3proxy/files/patch-cfg-3proxy.cfg.sample)6
4 files changed, 10 insertions, 10 deletions
diff --git a/net/3proxy/Makefile b/net/3proxy/Makefile
index 9775cc603a48..15494ebe06ff 100644
--- a/net/3proxy/Makefile
+++ b/net/3proxy/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= 3proxy
-PORTVERSION= 0.8.10
+PORTVERSION= 0.8.11
CATEGORIES= net
MAINTAINER= timp87@gmail.com
diff --git a/net/3proxy/distinfo b/net/3proxy/distinfo
index 342402c530ed..7a42ad6feaed 100644
--- a/net/3proxy/distinfo
+++ b/net/3proxy/distinfo
@@ -1,3 +1,3 @@
TIMESTAMP = 1498592146
-SHA256 (z3APA3A-3proxy-0.8.10_GH0.tar.gz) = 31af5c37bc37c90626ff689e0dcd412bbce19cdd124e3d3a09421898b4f760c2
-SIZE (z3APA3A-3proxy-0.8.10_GH0.tar.gz) = 497026
+SHA256 (z3APA3A-3proxy-0.8.11_GH0.tar.gz) = fc4295e1a462baa61977fcc21747db7861c4e3d0dcca86cbaa3e06017e5c66c9
+SIZE (z3APA3A-3proxy-0.8.11_GH0.tar.gz) = 497117
diff --git a/net/3proxy/files/patch-Makefile.unix b/net/3proxy/files/patch-Makefile.unix
index 70ac30f002a3..52b7d64f792d 100644
--- a/net/3proxy/files/patch-Makefile.unix
+++ b/net/3proxy/files/patch-Makefile.unix
@@ -1,4 +1,4 @@
---- Makefile.unix.orig 2016-01-19 22:20:05 UTC
+--- Makefile.unix.orig 2017-10-19 14:54:31 UTC
+++ Makefile.unix
@@ -8,18 +8,18 @@
# library support. Add -DSAFESQL for poorely written ODBC library / drivers.
@@ -9,7 +9,7 @@
# you may need -L/usr/pkg/lib for older NetBSD versions
-CFLAGS = -g -O2 -c -pthread -D_THREAD_SAFE -D_REENTRANT -DNOODBC -DWITH_STD_MALLOC -DFD_SETSIZE=4096 -DWITH_POLL
-+CFLAGS = -c %%CFLAGS%% -DNOODBC -DWITH_STD_MALLOC -DFD_SETSIZE=4096 -DWITH_POLL
++CFLAGS = -c -O2 -pipe -fstack-protector -fno-strict-aliasing -DNOODBC -DWITH_STD_MALLOC -DFD_SETSIZE=4096 -DWITH_POLL
COUT = -o
-LN = gcc
-LDFLAGS = -O2 -pthread
@@ -22,5 +22,5 @@
-DLSUFFICS = .ld.so
+DLSUFFICS = .so
LIBS =
- LNOUT = -o
- EXESUFFICS =
+ LIBSPREFIX = -l
+ LIBSSUFFIX =
diff --git a/net/3proxy/files/patch-cfg-3proxy.cfg.sample b/net/3proxy/files/patch-cfg_3proxy.cfg.sample
index 8c14dfba3308..9496239afbe5 100644
--- a/net/3proxy/files/patch-cfg-3proxy.cfg.sample
+++ b/net/3proxy/files/patch-cfg_3proxy.cfg.sample
@@ -1,4 +1,4 @@
---- cfg/3proxy.cfg.sample.orig 2016-01-19 22:20:05 UTC
+--- cfg/3proxy.cfg.sample.orig 2017-10-20 15:02:38 UTC
+++ cfg/3proxy.cfg.sample
@@ -30,15 +30,15 @@ users 3APA3A:CL:3apa3a "test:CR:$1$qwer$
# this example shows you how to include passwd file. For included files
@@ -13,9 +13,9 @@
+#service
# service is required under NT if you want 3proxy to start as service
--#log /usr/local/etc/3proxy/logs/3proxy.log D
+-#log /var/log/3proxy/log D
-log c:\3proxy\logs\3proxy.log D
-+log /var/log/3proxy.log D
++log /var/log/3proxy/log D
+#log c:\3proxy\logs\3proxy.log D
# log allows to specify log file location and rotation, D means logfile
# is created daily