aboutsummaryrefslogtreecommitdiff
path: root/net/3proxy
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2004-02-20 16:45:18 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2004-02-20 16:45:18 +0000
commit68fa1a9eb9fdf44868e8b8c7085b0dcfabb44c07 (patch)
treee3779ae38a2a8eab8ede558a48f97d09db67f5c5 /net/3proxy
parente3acbf6ffba44f923e0abada1a498f3eca7ad1f8 (diff)
downloadports-68fa1a9eb9fdf44868e8b8c7085b0dcfabb44c07.tar.gz
ports-68fa1a9eb9fdf44868e8b8c7085b0dcfabb44c07.zip
Update to latest stable release 0.4.3b.
Make some improvments, SIZEfy. Approved by: maintainer (connect to relay.nnn.tstu.ru[62.76.180.20]: Operation timed out)
Notes
Notes: svn path=/head/; revision=101521
Diffstat (limited to 'net/3proxy')
-rw-r--r--net/3proxy/Makefile19
-rw-r--r--net/3proxy/distinfo3
-rw-r--r--net/3proxy/files/patch-aa15
-rw-r--r--net/3proxy/files/patch-ab18
4 files changed, 26 insertions, 29 deletions
diff --git a/net/3proxy/Makefile b/net/3proxy/Makefile
index 2ee37856092d..da41b428fc0d 100644
--- a/net/3proxy/Makefile
+++ b/net/3proxy/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= 3proxy
-PORTVERSION= 0.4.1b
+PORTVERSION= 0.4.3b
CATEGORIES= net
MASTER_SITES= http://www.security.nnov.ru/soft/3proxy/${PORTVERSION}/
DISTNAME= ${PORTNAME}
@@ -16,13 +16,14 @@ MAINTAINER= tim@relay.nnn.tstu.ru
COMMENT= Proxy servers set (support HTTP(S), FTP, SOCKS, POP3, TCP & UDP)
NO_WRKSUBDIR= yes
-MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" \
- PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
-
-pre-build:
- if [ ! -f ${WRKSRC}/Makefile ]; then \
- ${CP} ${WRKSRC}/Makefile.unix ${WRKSRC}/Makefile; \
- fi
+USE_REINPLACE= yes
+MAKEFILE= Makefile.unix
+MAKE_ENV= CC="${CC}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}" \
+ PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
+post-patch:
+ ${REINPLACE_CMD} -e "s|%%CFLAGS%%|${CFLAGS}|" \
+ ${WRKDIR}/Makefile.unix
do-install:
.for i in 3proxy dighosts mycrypt pop3p proxy socks tcppm udppm
@@ -37,7 +38,7 @@ post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
.for i in License Readme Release.notes
- ${INSTALL_MAN} ${WRKSRC}/${i} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
.endif
diff --git a/net/3proxy/distinfo b/net/3proxy/distinfo
index 2168a2f036ac..51b8e7c00881 100644
--- a/net/3proxy/distinfo
+++ b/net/3proxy/distinfo
@@ -1 +1,2 @@
-MD5 (3proxy.tgz) = 61c0b9d6fc80c55cb2b2eca8d4b2056c
+MD5 (3proxy.tgz) = 5588c1883eedd0d81254719baa53cdac
+SIZE (3proxy.tgz) = 54301
diff --git a/net/3proxy/files/patch-aa b/net/3proxy/files/patch-aa
index b7a4dfef7362..421875ef6b3e 100644
--- a/net/3proxy/files/patch-aa
+++ b/net/3proxy/files/patch-aa
@@ -1,17 +1,18 @@
---- Makefile.unix.orig Mon Jul 28 13:06:40 2003
-+++ Makefile.unix Mon Jul 28 13:24:40 2003
+--- Makefile.unix.orig Thu Oct 16 17:12:38 2003
++++ Makefile.unix Fri Feb 13 18:16:29 2004
@@ -3,11 +3,11 @@
# 3 proxy Makefile for GCC/Unix/Linux/Cygwin
#
-CC = gcc
--CFLAGS = -Wall -O2 -s -c -pthread -DNOODBC
+-CFLAGS = -Wall -O2 -c -pthread -DNOODBC
+CC ?= gcc
-+CFLAGS += -Wall -O2 -s -c ${PTHREAD_CFLAGS} -DNOODBC
++CFLAGS = -Wall -c -DNOODBC %%CFLAGS%% ${PTHREAD_CFLAGS}
COUT = -o
- LN = gcc
--LDFLAGS = -Wall -O2 -s -pthread
-+LDFLAGS += -Wall -O2 -s ${PTHREAD_LIBS}
+-LN = gcc
+-LDFLAGS = -Wall -O2 -pthread
++LN ?= ${CC}
++LDFLAGS = -Wall ${PTHREAD_LIBS}
LIBS =
LNOUT = -o
EXESUFFICS =
diff --git a/net/3proxy/files/patch-ab b/net/3proxy/files/patch-ab
index 918af3171a7c..ce31aa87fcf1 100644
--- a/net/3proxy/files/patch-ab
+++ b/net/3proxy/files/patch-ab
@@ -1,12 +1,15 @@
---- 3proxy.cfg.sample.orig Wed Oct 8 19:35:48 2003
-+++ 3proxy.cfg.sample Wed Oct 8 20:56:52 2003
-@@ -332,12 +332,12 @@
+--- 3proxy.cfg.sample.orig Fri Feb 13 18:09:36 2004
++++ 3proxy.cfg.sample Fri Feb 13 18:11:20 2004
+@@ -341,14 +341,14 @@
# this example shows you how to include passwd file. For included files
# <CR> and <LF> are treated as field separators.
-service
+#service
# service is required under NT if you want 3proxy to start as service
+-#daemon
++daemon
+ # now we will not depend on any console (daemonize).
#log /usr/local/etc/3proxy/logs/3proxy.log D
@@ -15,12 +18,3 @@
# log allows to specify log file location and rotation, D means logfile
# is created daily
-@@ -455,7 +455,7 @@
- #setuid 65535
- # now we needn't any root rights. We can chroot and setgid/setuid.
-
--#daemon
-+daemon
- # now we will not depend on any console (daemonize).
-
-