aboutsummaryrefslogtreecommitdiff
path: root/net/3proxy
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-05-28 18:05:37 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-05-28 18:05:37 +0000
commit81b80bccd4b35c9ae8ef3152976c8ab7de2f7034 (patch)
treea2aa50a9f20db9bde4a9ad53c4ee4b07a84ddbb0 /net/3proxy
parent620e49deffeb724bc16af27be41414c956e921e5 (diff)
downloadports-81b80bccd4b35c9ae8ef3152976c8ab7de2f7034.tar.gz
ports-81b80bccd4b35c9ae8ef3152976c8ab7de2f7034.zip
net/3proxy: 0.6.1 -> 0.7.1.2
The CONFLICT with libproxy was resolved by removing the conflicting files. 0.7.1.2 - Increased limits for header / request size in HTTP proxy - Increased system failures handling on insufficient resources 0.7.1.1 - Warnings added for most common misconfigurations - ftppr NLSD command supported - Ignore NTLM handshake if NTLM is not enabled - memcpy replaced with memmove for overlapped region - better EINTR handling on *nix - FTP proxy debugging output removed, binding for data connection corrected - memory leak fixed in ldapauth plugin PR: 188374 Submitted by: igorz@yandex.ru, timp87@gmail.com
Notes
Notes: svn path=/head/; revision=387751
Diffstat (limited to 'net/3proxy')
-rw-r--r--net/3proxy/Makefile15
-rw-r--r--net/3proxy/distinfo4
-rw-r--r--net/3proxy/files/patch-man95
-rw-r--r--net/3proxy/pkg-descr6
-rw-r--r--net/3proxy/pkg-plist15
5 files changed, 105 insertions, 30 deletions
diff --git a/net/3proxy/Makefile b/net/3proxy/Makefile
index f5359a653d2f..2476da09bde3 100644
--- a/net/3proxy/Makefile
+++ b/net/3proxy/Makefile
@@ -2,11 +2,9 @@
# $FreeBSD$
PORTNAME= 3proxy
-PORTVERSION= 0.6.1
-PORTREVISION= 1
+PORTVERSION= 0.7.1.2
CATEGORIES= net
-MASTER_SITES= http://3proxy.ru/${PORTVERSION}/ \
- http://security.nnov.ru/soft/3proxy/${PORTVERSION}/
+MASTER_SITES= http://github.com/z3APA3A/3proxy/archive/v${PORTVERSION}.tar.gz?dummy=/
MAINTAINER= ports@FreeBSD.org
COMMENT= Proxy servers set (support HTTP(S), FTP, SOCKS, POP3, TCP & UDP)
@@ -14,27 +12,24 @@ COMMENT= Proxy servers set (support HTTP(S), FTP, SOCKS, POP3, TCP & UDP)
LICENSE= APACHE20 BSD2CLAUSE GPLv2 GPLv3 LGPL21 LGPL3
LICENSE_COMB= dual
-CONFLICTS_INSTALL= libproxy-[0-9]*
-
OPTIONS_DEFINE= DOCS
MAKEFILE= Makefile.unix
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
USE_RC_SUBR= 3proxy
-USES= tar:tgz
-PORTDOCS= Readme
+PORTDOCS= README
post-patch:
@${REINPLACE_CMD} -e 's|%%CFLAGS%%|${CFLAGS}|' ${WRKSRC}/${MAKEFILE}
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/lib/${PORTNAME}/ ${STAGEDIR}${DOCSDIR}/
- cd ${WRKSRC}/src/ && ${INSTALL_PROGRAM} 3proxy countersutil dighosts ftppr icqpr msnpr mycrypt pop3p proxy smtpp socks tcppm udppm ${STAGEDIR}${PREFIX}/bin/
+ cd ${WRKSRC}/src/ && ${INSTALL_PROGRAM} 3proxy countersutil dighosts mycrypt ${STAGEDIR}${PREFIX}/bin/
cd ${WRKSRC}/cfg/ && ${INSTALL_DATA} 3proxy.cfg.sample ${STAGEDIR}${PREFIX}/etc/
cd ${WRKSRC}/src/ && ${INSTALL_LIB} PCREPlugin.so StringsPlugin.so TrafficPlugin.so ${STAGEDIR}${PREFIX}/lib/${PORTNAME}/
cd ${WRKSRC}/man/ && ${INSTALL_MAN} 3proxy.cfg.3 ${STAGEDIR}${PREFIX}/man/man3/
- cd ${WRKSRC}/man/ && ${INSTALL_MAN} 3proxy.8 ftppr.8 pop3p.8 proxy.8 socks.8 tcppm.8 udppm.8 ${STAGEDIR}${PREFIX}/man/man8/
+ cd ${WRKSRC}/man/ && ${INSTALL_MAN} 3proxy.8 ${STAGEDIR}${PREFIX}/man/man8/
cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
.include <bsd.port.mk>
diff --git a/net/3proxy/distinfo b/net/3proxy/distinfo
index 472ff1f5e94b..7bd58a6ac7b2 100644
--- a/net/3proxy/distinfo
+++ b/net/3proxy/distinfo
@@ -1,2 +1,2 @@
-SHA256 (3proxy-0.6.1.tgz) = 10f8804258791e80353a334dc9b80473a02c6dda939de76451e655f643aadd7f
-SIZE (3proxy-0.6.1.tgz) = 480160
+SHA256 (3proxy-0.7.1.2.tar.gz) = 85c5cadad1878855c382622787f787d5c2c30bdea0a240f7d35cfd8abe30b746
+SIZE (3proxy-0.7.1.2.tar.gz) = 468593
diff --git a/net/3proxy/files/patch-man b/net/3proxy/files/patch-man
new file mode 100644
index 000000000000..24eb1b28707e
--- /dev/null
+++ b/net/3proxy/files/patch-man
@@ -0,0 +1,95 @@
+diff -urN man/3proxy.8 man-bin/3proxy.8
+--- man/3proxy.8 2015-02-17 16:09:13.000000000 +0300
++++ man-bin/3proxy.8 2015-05-28 11:58:00.543952000 +0300
+@@ -25,18 +25,7 @@
+ It can establish multiple
+ gateways with HTTP and HTTPS proxy with FTP over HTTP support, SOCKS v4,
+ v4.5 and v5, POP3 proxy, UDP and TCP portmappers. Each gateway is started
+-from configuration file like independant service
+-.BR proxy (8)
+-.BR socks (8)
+-.BR pop3p (8)
+-.BR tcppm (8)
+-.BR udppm (8)
+-.BR ftppr (8)
+-.BR dnspr
+-but
+-.BR 3proxy
+-is not a kind of wrapper or superserver for this daemons. It just has same
+-code compiled in, but provides much more functionality. SOCKSv5
++from configuration file like independant service. SOCKSv5
+ implementatation allows to use 3proxy with any UDP or TCP based client
+ applications designed without
+ proxy support (with
+@@ -84,7 +73,7 @@
+ configuration from stdin. It makes it possible to use 3proxy.cfg file as
+ executable script just by setting +x mode and adding
+ .br
+-#!/usr/local/3proxy/3proxy
++#!/usr/local/bin/3proxy
+ .br
+ as a first line in 3proxy.cfg
+ .TP
+@@ -133,14 +122,14 @@
+ wget to automate this task.
+ .SH FILES
+ .TP
+-.I "/usr/local/3proxy/3proxy.cfg (3proxy.cfg)"
++.I "/usr/local/etc/3proxy.cfg (3proxy.cfg)"
+ .BR 3proxy
+ configuration file
+ .SH BUGS
+ Report all bugs to
+-.BR 3proxy@security.nnov.ru
++.BR 3proxy@3proxy.ru
+ .SH SEE ALSO
+-3proxy.cfg(3), proxy(8), ftppr(8), socks(8), pop3p(8), tcppm(8), udppm(8),
++3proxy.cfg(3),
+ kill(1), syslogd(8),
+ .br
+ http://3proxy.ru/
+@@ -148,6 +137,6 @@
+ 3APA3A is pronounced as \`\`zaraza\'\'.
+ .SH AUTHORS
+ 3proxy is designed by 3APA3A
+-.RI ( 3APA3A@security.nnov.ru ),
++.RI ( 3APA3A@3proxy.ru ),
+ Vladimir Dubrovin
+-.RI ( vlad@sandy.ru )
++.RI ( vlad@securityvulns.ru )
+diff -urN man/3proxy.cfg.3 man-bin/3proxy.cfg.3
+--- man/3proxy.cfg.3 2015-02-17 16:09:13.000000000 +0300
++++ man-bin/3proxy.cfg.3 2015-05-28 11:55:28.565596000 +0300
+@@ -113,15 +113,6 @@
+ .B -a1
+ (for proxy) - anonymous proxy (random client information reported)
+ .br
+- Also, all options mentioned for
+-.BR proxy (8)
+-.BR socks (8)
+-.BR pop3p (8)
+-.BR tcppm (8)
+-.BR udppm (8)
+-.BR ftppr (8)
+- are also supported.
+-.br
+ Portmapping services listen at SRCPORT and connect to DSTADDR:DSTPORT
+ HTTP and SOCKS proxies are standard.
+ .br
+@@ -884,13 +875,13 @@
+
+
+ .SH SEE ALSO
+-3proxy(8), proxy(8), ftppr(8), socks(8), pop3p(8), tcppm(8), udppm(8), syslogd(8),
++3proxy(8), syslogd(8),
+ .br
+ http://3proxy.ru/
+ .SH TRIVIA
+ 3APA3A is pronounced as \`\`zaraza\'\'.
+ .SH AUTHORS
+ 3proxy is designed by 3APA3A
+-.RI ( 3APA3A@security.nnov.ru ),
++.RI ( 3APA3A@3proxy.ru ),
+ Vladimir Dubrovin
+-.RI ( vlad@sandy.ru )
++.RI ( vlad@securityvulns.ru )
diff --git a/net/3proxy/pkg-descr b/net/3proxy/pkg-descr
index 21e2fae347c6..40d40a0c4703 100644
--- a/net/3proxy/pkg-descr
+++ b/net/3proxy/pkg-descr
@@ -12,9 +12,9 @@ included in archive and supports installation as NT/2K/XP service.
Currently 3proxy is tested to work under Windows 98/NT/2000/2003/XP,
FreeBSD/i386, Linux/i386, Linux/Alpha. See Release Notes and Changes for
features list.
-3proxy is FreeWare. It can be used under terms of GNU/GPL or under it own
+3proxy is FreeWare. It can be used under terms of GNU/GPL or under its own
license (please read License Agreement).
-For licensing or commercial support please e-mail to 3proxy@security.nnov.ru
+For licensing or commercial support please e-mail to 3proxy@3proxy.ru
-WWW: http://www.security.nnov.ru/soft/3proxy/
+WWW: http://3proxy.ru/
diff --git a/net/3proxy/pkg-plist b/net/3proxy/pkg-plist
index 6ac79adba293..574930eaf6b2 100644
--- a/net/3proxy/pkg-plist
+++ b/net/3proxy/pkg-plist
@@ -1,25 +1,10 @@
bin/3proxy
bin/countersutil
bin/dighosts
-bin/ftppr
-bin/icqpr
-bin/msnpr
bin/mycrypt
-bin/pop3p
-bin/proxy
-bin/smtpp
-bin/socks
-bin/tcppm
-bin/udppm
@sample etc/3proxy.cfg.sample
lib/3proxy/PCREPlugin.so
lib/3proxy/StringsPlugin.so
lib/3proxy/TrafficPlugin.so
man/man3/3proxy.cfg.3.gz
man/man8/3proxy.8.gz
-man/man8/ftppr.8.gz
-man/man8/pop3p.8.gz
-man/man8/proxy.8.gz
-man/man8/socks.8.gz
-man/man8/tcppm.8.gz
-man/man8/udppm.8.gz