aboutsummaryrefslogtreecommitdiff
path: root/net/3proxy
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-01-20 19:56:45 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-01-20 19:56:45 +0000
commitfb9388489f0647176366e67aad6e14dfdc6c41ba (patch)
tree54df73f209b38c6074ba1b88faaf980d41090633 /net/3proxy
parent7048ac05e856be12aa82c4e4f3acfe8717a782df (diff)
downloadports-fb9388489f0647176366e67aad6e14dfdc6c41ba.tar.gz
ports-fb9388489f0647176366e67aad6e14dfdc6c41ba.zip
net/3proxy: 0.7.1.3 -> 0.8.0
- introduces IPv6 support - connect back - DNS proxy via TCP with parent proxy support - non-blocking name resolution via default system methods on *nix - reduced memory usage - multiple race conditions fixes. It's recommended to move to 0.8.0 if you use 3proxy under high load. PR: 206423 Submitted by: timp87@gmail.com (maintainer)
Notes
Notes: svn path=/head/; revision=406802
Diffstat (limited to 'net/3proxy')
-rw-r--r--net/3proxy/Makefile4
-rw-r--r--net/3proxy/distinfo4
-rw-r--r--net/3proxy/files/patch-Makefile.unix12
-rw-r--r--net/3proxy/files/patch-cfg-3proxy.cfg.sample2
-rw-r--r--net/3proxy/files/patch-man131
-rw-r--r--net/3proxy/pkg-plist2
6 files changed, 42 insertions, 113 deletions
diff --git a/net/3proxy/Makefile b/net/3proxy/Makefile
index 108412080017..cf87a3c5bbde 100644
--- a/net/3proxy/Makefile
+++ b/net/3proxy/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= 3proxy
-PORTVERSION= 0.7.1.3
+PORTVERSION= 0.8.0
DISTVERSIONPREFIX= ${PORTNAME}-
CATEGORIES= net
@@ -31,7 +31,7 @@ post-build:
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/lib/${PORTNAME}/ ${STAGEDIR}${DOCSDIR}/
- cd ${WRKSRC}/src/ && ${INSTALL_PROGRAM} 3proxy countersutil dighosts ftppr icqpr msnpr mycrypt pop3p httppr smtpp socks tcppm udppm ${STAGEDIR}${PREFIX}/bin/
+ cd ${WRKSRC}/src/ && ${INSTALL_PROGRAM} 3proxy dighosts ftppr icqpr mycrypt pop3p httppr smtpp socks tcppm udppm ${STAGEDIR}${PREFIX}/bin/
cd ${WRKSRC}/cfg/ && ${INSTALL_DATA} 3proxy.cfg.sample ${STAGEDIR}${PREFIX}/etc/
cd ${WRKSRC}/src/ && ${INSTALL_LIB} PCREPlugin.so StringsPlugin.so TrafficPlugin.so ${STAGEDIR}${PREFIX}/lib/${PORTNAME}/
cd ${WRKSRC}/man/ && ${INSTALL_MAN} 3proxy.cfg.3 ${STAGEDIR}${PREFIX}/man/man3/
diff --git a/net/3proxy/distinfo b/net/3proxy/distinfo
index 809e89728e79..4560f28883cd 100644
--- a/net/3proxy/distinfo
+++ b/net/3proxy/distinfo
@@ -1,2 +1,2 @@
-SHA256 (z3APA3A-3proxy-3proxy-0.7.1.3_GH0.tar.gz) = 4d1f3cf539c8a32f5845b54e8a3fdbabef6fe8a6bbb06dfc80f7361804f6cb60
-SIZE (z3APA3A-3proxy-3proxy-0.7.1.3_GH0.tar.gz) = 468638
+SHA256 (z3APA3A-3proxy-3proxy-0.8.0_GH0.tar.gz) = 16a8dabe117142e5707367885d40ec3fe6edcf608e3602bee594158182aae522
+SIZE (z3APA3A-3proxy-3proxy-0.8.0_GH0.tar.gz) = 483764
diff --git a/net/3proxy/files/patch-Makefile.unix b/net/3proxy/files/patch-Makefile.unix
index c433140d1eaa..70ac30f002a3 100644
--- a/net/3proxy/files/patch-Makefile.unix
+++ b/net/3proxy/files/patch-Makefile.unix
@@ -1,6 +1,6 @@
---- Makefile.unix.orig 2015-02-17 13:09:13 UTC
+--- Makefile.unix.orig 2016-01-19 22:20:05 UTC
+++ Makefile.unix
-@@ -9,18 +9,18 @@
+@@ -8,18 +8,18 @@
# library support. Add -DSAFESQL for poorely written ODBC library / drivers.
BUILDDIR =
@@ -8,13 +8,13 @@
+CC ?= gcc
# you may need -L/usr/pkg/lib for older NetBSD versions
--CFLAGS = -Wall -g -O2 -c -pthread -D_THREAD_SAFE -D_REENTRANT -DNOODBC -DWITH_STD_MALLOC -DFD_SETSIZE=4096 -DWITH_POLL
-+CFLAGS = -Wall -c %%CFLAGS%% -DNOODBC -DWITH_STD_MALLOC -DFD_SETSIZE=4096 -DWITH_POLL
+-CFLAGS = -g -O2 -c -pthread -D_THREAD_SAFE -D_REENTRANT -DNOODBC -DWITH_STD_MALLOC -DFD_SETSIZE=4096 -DWITH_POLL
++CFLAGS = -c %%CFLAGS%% -DNOODBC -DWITH_STD_MALLOC -DFD_SETSIZE=4096 -DWITH_POLL
COUT = -o
-LN = gcc
--LDFLAGS = -Wall -O2 -pthread
+-LDFLAGS = -O2 -pthread
+LN ?= ${CC}
-+LDFLAGS = -Wall -lpthread
++LDFLAGS = -pthread
# -lpthreads may be reuqired on some platforms instead of -pthreads
# -ldl or -lld may be required for some platforms
DCFLAGS = -fpic
diff --git a/net/3proxy/files/patch-cfg-3proxy.cfg.sample b/net/3proxy/files/patch-cfg-3proxy.cfg.sample
index 3b3f793e6dcb..8c14dfba3308 100644
--- a/net/3proxy/files/patch-cfg-3proxy.cfg.sample
+++ b/net/3proxy/files/patch-cfg-3proxy.cfg.sample
@@ -1,4 +1,4 @@
---- cfg/3proxy.cfg.sample.orig 2015-02-17 13:09:13 UTC
+--- cfg/3proxy.cfg.sample.orig 2016-01-19 22:20:05 UTC
+++ cfg/3proxy.cfg.sample
@@ -30,15 +30,15 @@ users 3APA3A:CL:3apa3a "test:CR:$1$qwer$
# this example shows you how to include passwd file. For included files
diff --git a/net/3proxy/files/patch-man b/net/3proxy/files/patch-man
index b1385adc84eb..638fe3f6fa58 100644
--- a/net/3proxy/files/patch-man
+++ b/net/3proxy/files/patch-man
@@ -1,4 +1,4 @@
---- man/3proxy.8.orig 2015-02-17 13:09:13 UTC
+--- man/3proxy.8.orig 2016-01-19 22:20:05 UTC
+++ man/3proxy.8
@@ -26,7 +26,7 @@ It can establish multiple
gateways with HTTP and HTTPS proxy with FTP over HTTP support, SOCKS v4,
@@ -28,27 +28,17 @@
configuration file
.SH BUGS
Report all bugs to
--.BR 3proxy@security.nnov.ru
-+.BR 3proxy@3proxy.ru
+ .BR 3proxy@3proxy.ru
.SH SEE ALSO
-3proxy.cfg(3), proxy(8), ftppr(8), socks(8), pop3p(8), tcppm(8), udppm(8),
+3proxy.cfg(3), httppr(8), ftppr(8), socks(8), pop3p(8), tcppm(8), udppm(8),
kill(1), syslogd(8),
.br
http://3proxy.ru/
-@@ -148,6 +148,6 @@ http://3proxy.ru/
- 3APA3A is pronounced as \`\`zaraza\'\'.
- .SH AUTHORS
- 3proxy is designed by 3APA3A
--.RI ( 3APA3A@security.nnov.ru ),
-+.RI ( 3APA3A@3proxy.ru ),
- Vladimir Dubrovin
--.RI ( vlad@sandy.ru )
-+.RI ( vlad@securityvulns.ru )
---- man/3proxy.cfg.3.orig 2015-02-17 13:09:13 UTC
+--- man/3proxy.cfg.3.orig 2016-01-19 22:20:05 UTC
+++ man/3proxy.cfg.3
-@@ -114,7 +114,7 @@ view without ability to reset).
- (for proxy) - anonymous proxy (random client information reported)
+@@ -153,7 +153,7 @@ listen on given local HOST:port for inco
+ connect to given remote HOST:port instead of listening local connection on -p or default port. Can be used with another 3proxy service running -R option for connect back functionality. Most commonly used with proxy or socks. HOST can be given as IP or hostname, useful in case of dynamic DNS.
.br
Also, all options mentioned for
-.BR proxy (8)
@@ -56,78 +46,52 @@
.BR socks (8)
.BR pop3p (8)
.BR tcppm (8)
-@@ -884,13 +884,13 @@ corruption and/or Content-Length chaging
-
-
+@@ -927,7 +927,7 @@ corruption and/or Content-Length chaging
+ Report all bugs to
+ .BR 3proxy@3proxy.ru
.SH SEE ALSO
-3proxy(8), proxy(8), ftppr(8), socks(8), pop3p(8), tcppm(8), udppm(8), syslogd(8),
+3proxy(8), httppr(8), ftppr(8), socks(8), pop3p(8), tcppm(8), udppm(8), syslogd(8),
.br
http://3proxy.ru/
.SH TRIVIA
- 3APA3A is pronounced as \`\`zaraza\'\'.
- .SH AUTHORS
- 3proxy is designed by 3APA3A
--.RI ( 3APA3A@security.nnov.ru ),
-+.RI ( 3APA3A@3proxy.ru ),
- Vladimir Dubrovin
--.RI ( vlad@sandy.ru )
-+.RI ( vlad@securityvulns.ru )
---- man/ftppr.8.orig 2015-02-17 13:09:13 UTC
+--- man/ftppr.8.orig 2016-01-19 22:20:05 UTC
+++ man/ftppr.8
-@@ -75,11 +75,11 @@ Only cleartext authentication is current
+@@ -75,7 +75,7 @@ Only cleartext authentication is current
Report all bugs to
- .BR 3proxy@security.nnov.ru
+ .BR 3proxy@3proxy.ru
.SH SEE ALSO
-3proxy(8), proxy(8), pop3p(8), socks(8), tcppm(8), udppm(8), syslogd(8),
+3proxy(8), httppr(8), pop3p(8), socks(8), tcppm(8), udppm(8), syslogd(8),
.br
http://3proxy.ru/
.SH AUTHORS
- 3proxy is designed by 3APA3A
--.RI ( 3APA3A@security.nnov.ru ),
-+.RI ( 3APA3A@3proxy.ru ),
- Vladimir Dubrovin
--.RI ( vlad@sandy.ru )
-+.RI ( vlad@securityvulns.ru )
---- man/icqpr.8.orig 2015-02-17 13:09:13 UTC
+--- man/icqpr.8.orig 2016-01-19 22:20:05 UTC
+++ man/icqpr.8
-@@ -68,11 +68,11 @@ as a destination in client application.
+@@ -68,7 +68,7 @@ as a destination in client application.
Report all bugs to
- .BR 3proxy@security.nnov.ru
+ .BR 3proxy@3proxy.ru
.SH SEE ALSO
-3proxy(8), proxy(8), ftppr(8), socks(8), pop3p(8), udppm(8), syslogd(8),
+3proxy(8), httppr(8), ftppr(8), socks(8), pop3p(8), udppm(8), syslogd(8),
.br
http://3proxy.ru/
.SH AUTHORS
- 3proxy is designed by 3APA3A
--.RI ( 3APA3A@security.nnov.ru ),
-+.RI ( 3APA3A@3proxy.ru ),
- Vladimir Dubrovin
--.RI ( vlad@sandy.ru )
-+.RI ( vlad@securityvulns.ru )
---- man/pop3p.8.orig 2015-02-17 13:09:13 UTC
+--- man/pop3p.8.orig 2016-01-19 22:20:05 UTC
+++ man/pop3p.8
-@@ -71,11 +71,11 @@ we know which server to connect.
+@@ -71,7 +71,7 @@ we know which server to connect.
Report all bugs to
- .BR 3proxy@security.nnov.ru
+ .BR 3proxy@3proxy.ru
.SH SEE ALSO
-3proxy(8), ftppr(8), proxy(8), socks(8), tcppm(8), udppm(8), syslogd(8),
+3proxy(8), ftppr(8), httppr(8), socks(8), tcppm(8), udppm(8), syslogd(8),
.br
http://3proxy.ru/
.SH AUTHORS
- 3proxy is designed by 3APA3A
--.RI ( 3APA3A@security.nnov.ru ),
-+.RI ( 3APA3A@3proxy.ru ),
- Vladimir Dubrovin
--.RI ( vlad@sandy.ru )
-+.RI ( vlad@securityvulns.ru )
---- man/proxy.8.orig 2015-02-17 13:09:13 UTC
+--- man/proxy.8.orig 2016-01-19 22:20:05 UTC
+++ man/proxy.8
@@ -1,15 +1,15 @@
--.TH proxy "8" "July 2009" "3proxy 0.7" "Universal proxy server"
+-.TH proxy "8" "January 2016" "3proxy 0.8" "Universal proxy server"
+.TH httppr "8" "July 2009" "3proxy 0.7" "Universal proxy server"
.SH NAME
-.B proxy
@@ -146,80 +110,47 @@
is HTTP gateway service with HTTPS and FTP over HTTPS support.
.SH OPTIONS
.TP
-@@ -71,6 +71,6 @@ Report all bugs to
- http://3proxy.ru/
- .SH AUTHORS
- 3proxy is designed by 3APA3A
--.RI ( 3APA3A@security.nnov.ru ),
-+.RI ( 3APA3A@3proxy.ru ),
- Vladimir Dubrovin
--.RI ( vlad@sandy.ru )
-+.RI ( vlad@securityvulns.ru )
---- man/smtpp.8.orig 2015-02-17 13:09:13 UTC
+--- man/smtpp.8.orig 2016-01-19 22:20:05 UTC
+++ man/smtpp.8
-@@ -72,11 +72,11 @@ we know which server to connect.
+@@ -72,7 +72,7 @@ we know which server to connect.
Report all bugs to
- .BR 3proxy@security.nnov.ru
+ .BR 3proxy@3proxy.ru
.SH SEE ALSO
-3proxy(8), ftppr(8), proxy(8), socks(8), tcppm(8), udppm(8), syslogd(8),
+3proxy(8), ftppr(8), httppr(8), socks(8), tcppm(8), udppm(8), syslogd(8),
.br
http://3proxy.ru/
.SH AUTHORS
- 3proxy is designed by 3APA3A
--.RI ( 3APA3A@security.nnov.ru ),
-+.RI ( 3APA3A@3proxy.ru ),
- Vladimir Dubrovin
--.RI ( vlad@sandy.ru )
-+.RI ( vlad@securityvulns.ru )
---- man/socks.8.orig 2015-02-17 13:09:13 UTC
+--- man/socks.8.orig 2016-01-19 22:20:05 UTC
+++ man/socks.8
-@@ -67,11 +67,11 @@ instead.
+@@ -67,7 +67,7 @@ instead.
Report all bugs to
- .BR 3proxy@security.nnov.ru
+ .BR 3proxy@3proxy.ru
.SH SEE ALSO
-3proxy(8), proxy(8), ftppr(8), pop3p(8), tcppm(8), udppm(8), syslogd(8),
+3proxy(8), httppr(8), ftppr(8), pop3p(8), tcppm(8), udppm(8), syslogd(8),
.br
http://3proxy.ru/
.SH AUTHORS
- 3proxy is designed by 3APA3A
--.RI ( 3APA3A@security.nnov.ru ),
-+.RI ( 3APA3A@3proxy.ru ),
- Vladimir Dubrovin
--.RI ( vlad@sandy.ru )
-+.RI ( vlad@securityvulns.ru )
---- man/tcppm.8.orig 2015-02-17 13:09:13 UTC
+--- man/tcppm.8.orig 2016-01-19 22:20:05 UTC
+++ man/tcppm.8
-@@ -61,11 +61,11 @@ as a destination in client application.
+@@ -61,7 +61,7 @@ as a destination in client application.
Report all bugs to
- .BR 3proxy@security.nnov.ru
+ .BR 3proxy@3proxy.ru
.SH SEE ALSO
-3proxy(8), proxy(8), ftppr(8), socks(8), pop3p(8), udppm(8), syslogd(8),
+3proxy(8), httppr(8), ftppr(8), socks(8), pop3p(8), udppm(8), syslogd(8),
.br
http://3proxy.ru/
.SH AUTHORS
- 3proxy is designed by 3APA3A
--.RI ( 3APA3A@security.nnov.ru ),
-+.RI ( 3APA3A@3proxy.ru ),
- Vladimir Dubrovin
--.RI ( vlad@sandy.ru )
-+.RI ( vlad@securityvulns.ru )
---- man/udppm.8.orig 2015-02-17 13:09:13 UTC
+--- man/udppm.8.orig 2016-01-19 22:20:05 UTC
+++ man/udppm.8
-@@ -67,11 +67,11 @@ as a destination in client application.
+@@ -67,7 +67,7 @@ as a destination in client application.
Report all bugs to
- .BR 3proxy@security.nnov.ru
+ .BR 3proxy@3proxy.ru
.SH SEE ALSO
-3proxy(8), proxy(8), ftppr(8), socks(8), pop3p(8), udppm(8), syslogd(8),
+3proxy(8), httppr(8), ftppr(8), socks(8), pop3p(8), udppm(8), syslogd(8),
.br
http://3proxy.ru/
.SH AUTHORS
- 3proxy is designed by 3APA3A
--.RI ( 3APA3A@security.nnov.ru ),
-+.RI ( 3APA3A@3proxy.ru ),
- Vladimir Dubrovin
--.RI ( vlad@sandy.ru )
-+.RI ( vlad@securityvulns.ru )
diff --git a/net/3proxy/pkg-plist b/net/3proxy/pkg-plist
index 85bd72bc46bb..253f4fab5b47 100644
--- a/net/3proxy/pkg-plist
+++ b/net/3proxy/pkg-plist
@@ -1,9 +1,7 @@
bin/3proxy
-bin/countersutil
bin/dighosts
bin/ftppr
bin/icqpr
-bin/msnpr
bin/mycrypt
bin/pop3p
bin/httppr