aboutsummaryrefslogtreecommitdiff
path: root/net/Sockets
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2008-11-30 04:38:17 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2008-11-30 04:38:17 +0000
commit2141c40294c61c9f1630e71051b45c59125aa725 (patch)
treee1b28f532d36b6bb664666cac774610d65bd0e9d /net/Sockets
parent232159b31e84125a17b3947c9eae994723d6337c (diff)
downloadports-2141c40294c61c9f1630e71051b45c59125aa725.tar.gz
ports-2141c40294c61c9f1630e71051b45c59125aa725.zip
Notes
Diffstat (limited to 'net/Sockets')
-rw-r--r--net/Sockets/Makefile2
-rw-r--r--net/Sockets/files/extra-patch-SocketHandler.h10
2 files changed, 11 insertions, 1 deletions
diff --git a/net/Sockets/Makefile b/net/Sockets/Makefile
index f4728f9dc778..c161eb433aab 100644
--- a/net/Sockets/Makefile
+++ b/net/Sockets/Makefile
@@ -36,7 +36,7 @@ post-patch:
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-SocketHandler.h
.endif
.include <bsd.port.post.mk>
diff --git a/net/Sockets/files/extra-patch-SocketHandler.h b/net/Sockets/files/extra-patch-SocketHandler.h
new file mode 100644
index 000000000000..5fe04cf4ecd6
--- /dev/null
+++ b/net/Sockets/files/extra-patch-SocketHandler.h
@@ -0,0 +1,10 @@
+--- SocketHandler.h.orig 2008-11-30 02:32:59.000000000 -0200
++++ SocketHandler.h 2008-11-30 02:33:51.000000000 -0200
+@@ -36,6 +36,7 @@
+
+ class SocketHandler
+ {
++protected:
+ /** Map type for holding file descriptors/socket object pointers. */
+ typedef std::map<SOCKET,Socket *> socket_m;
+