aboutsummaryrefslogtreecommitdiff
path: root/net/afpfs-ng
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-09-12 01:39:02 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-09-12 01:39:02 +0000
commit0ff4c5a891bc62abff55d6eda9ba83e3203166c5 (patch)
tree6411c3f9fb041f2e65e9b5bca2f5eca502348991 /net/afpfs-ng
parent0575d0405165e33c0b469e080d3445bd6322fdec (diff)
downloadports-0ff4c5a891bc62abff55d6eda9ba83e3203166c5.tar.gz
ports-0ff4c5a891bc62abff55d6eda9ba83e3203166c5.zip
- Fix package list when FUSE option is selected
- Allow to build with any compiler and remove USE_GCC - Remove LICENSE_FILE (just a standard GPL boilerplate) - Employ OPTIONS helpers and modern LIB_DEPENDS syntax - Drop apparently left-over post-patch target that does nothing now - Improve on the COMMENT line, some other cleaning while here
Notes
Notes: svn path=/head/; revision=327028
Diffstat (limited to 'net/afpfs-ng')
-rw-r--r--net/afpfs-ng/Makefile45
-rw-r--r--net/afpfs-ng/files/patch-lib__loop.c10
2 files changed, 25 insertions, 30 deletions
diff --git a/net/afpfs-ng/Makefile b/net/afpfs-ng/Makefile
index 8ca43bb7f4d1..46ffc84e8ef9 100644
--- a/net/afpfs-ng/Makefile
+++ b/net/afpfs-ng/Makefile
@@ -8,16 +8,12 @@ CATEGORIES= net
MASTER_SITES= SF
MAINTAINER= manuel.creach@icloud.com
-COMMENT= The afpfs-ng is an Apple Filing Protocol client library
+COMMENT= Apple Filing Protocol client library
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
-OPTIONS_DEFINE= FUSE GCRYPT
-
-USE_BZIP2= yes
-USE_GCC= any
USES= iconv gmake
+USE_BZIP2= yes
USE_AUTOTOOLS= aclocal autoheader automake autoconf libtoolize
ACLOCAL_ARGS= -I.
AUTOMAKE_ARGS= --add-missing
@@ -26,34 +22,25 @@ USE_LDCONFIG= yes
CFLAGS+= -D_FILE_OFFSET_BITS=64 -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.options.mk>
-
-CONFIGURE_ARGS+=--prefix="${PREFIX}"
-
MAN1= afpcmd.1 afpgetstatus.1
-.if ${PORT_OPTIONS:MFUSE}
-LIB_DEPENDS+= fuse:${PORTSDIR}/sysutils/fusefs-libs
-CONFIGURE_ARGS+=--enable-fuse
-.else
-CONFIGURE_ARGS+=--disable-fuse
-.endif
+OPTIONS_DEFINE= FUSE GCRYPT
-.if ${PORT_OPTIONS:MGCRYPT}
-LIB_DEPENDS+= gcrypt:${PORTSDIR}/security/libgcrypt
-CONFIGURE_ARGS+=--enable-gcrypt
-.else
-CONFIGURE_ARGS+=--disable-gcrypt
-.endif
+FUSE_LIB_DEPENDS= libfuse.so:${PORTSDIR}/sysutils/fusefs-libs
+FUSE_CONFIGURE_ENABLE= fuse
-.include <bsd.port.pre.mk>
+GCRYPT_LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt
+GCRYPT_CONFIGURE_ENABLE=gcrypt
-post-patch: .SILENT
- ${REINPLACE_CMD} 's|$$(libdir)/\(pkgconfig\)|$$(prefix)/libdata/\1|' \
- ${WRKSRC}/Makefile.am
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MFUSE}
+MAN1+= afp_client.1 afpfsd.1 mount_afp.1
+PLIST_FILES+= bin/afp_client bin/afpfs bin/afpfsd bin/mount_afp
+.endif
-post-configure: .SILENT
- ${REINPLACE_CMD} 's|LIBS = |LIBS = ${ICONV_LIB} |' \
+post-configure:
+ @${REINPLACE_CMD} 's|LIBS = |LIBS = ${ICONV_LIB} |' \
${WRKSRC}/cmdline/Makefile
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/afpfs-ng/files/patch-lib__loop.c b/net/afpfs-ng/files/patch-lib__loop.c
index 330f40c45b9d..04a84fe45324 100644
--- a/net/afpfs-ng/files/patch-lib__loop.c
+++ b/net/afpfs-ng/files/patch-lib__loop.c
@@ -21,4 +21,12 @@
static int loop_started=0;
static pthread_cond_t loop_started_condition;
-diff -Naur afpfs-ng-0.8.1.orig/lib/lowlevel.c afpfs-ng-0.8.1/lib/lowlevel.c
+@@ -87,7 +87,7 @@ void signal_main_thread(void)
+ static int ending=0;
+ void * just_end_it_now(void * ignore)
+ {
+- if (ending) return;
++ if (ending) return NULL;
+ ending=1;
+ if (libafpclient->forced_ending_hook)
+ libafpclient->forced_ending_hook();