aboutsummaryrefslogtreecommitdiff
path: root/net/aoe
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-09-20 12:54:54 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2013-09-20 12:54:54 +0000
commitc93dfc2e9f8b7b990c22c6baa6cdab361cd12e16 (patch)
treee61ab76efa292f985d8e20e449572329fa964c1c /net/aoe
parentb10d5a64b7ea8bb32e9735304272e7344926e3b2 (diff)
downloadports-c93dfc2e9f8b7b990c22c6baa6cdab361cd12e16.tar.gz
ports-c93dfc2e9f8b7b990c22c6baa6cdab361cd12e16.zip
SSP support has been added to ports with WITH_SSP for i386 and amd64
on FreeBSD 10, and amd64 on earlier versions. SSP_UNSAFE is added to disable in a port if it fails to build, but this should only be used in rare circumstances such as kernel modules. Otherwise, the port may just be failing due to lack of respecting LDFLAGS. On FreeBSD 10, this uses an ldscript in /usr/lib/libc.so to pull in libssp_nonshared.a to address issues linking on i386 [1]. On earlier FreeBSD versions the WITH_SSP knob will add -lssp_nonshared to LDFLAGS on i386. This is not needed on amd64. However, several hundred ports do not currently respect LDFLAGS, so this support is disabled currently as it causes build failures if a dependency is looking for the stack_chk symbols. Many thanks to jlh@ for this as he had many years of patience in getting all of the necessary pieces [1][2] in. [1] http://svnweb.freebsd.org/base/head/lib/libc/libc.ldscript?revision=251668&view=markup PR: ports/138228 [2] Submitted by: jlh (bsd.ssp.mk based on) Reviewed by: bapt With hat: portmgr exp-runs done: 37 over a month on 91i386,91amd64,10i386,10amd64
Notes
Notes: svn path=/head/; revision=327697
Diffstat (limited to 'net/aoe')
-rw-r--r--net/aoe/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/net/aoe/Makefile b/net/aoe/Makefile
index 29da5efad00b..b180917fda60 100644
--- a/net/aoe/Makefile
+++ b/net/aoe/Makefile
@@ -1,13 +1,9 @@
-# Ports collection makefile for: aoe (ATA Over Ethernet) driver
-# Date created: 22 May 2006
-# Whom: Stacey D. Son <sds@son.org>
-#
+# Created by: Stacey D. Son <sds@son.org>
# $FreeBSD$
-#
PORTNAME= aoe
PORTVERSION= 1.2.0
-CATEGORIES= net
+CATEGORIES= net kld
MASTER_SITES= http://www.son.org/download/
DISTNAME= ${PORTNAME}-freebsd-${PORTVERSION}
@@ -15,6 +11,7 @@ MAINTAINER= fjoe@FreeBSD.org
COMMENT= FreeBSD driver for ATA over Ethernet (AoE)
NO_PACKAGE= Should be in sync with the kernel to work correctly
+SSP_UNSAFE= kernel module does not support ssp
WRKSRC= ${WRKDIR}/dev/aoe
MAN4= aoe.4