aboutsummaryrefslogtreecommitdiff
path: root/net/arping
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2005-07-20 23:37:32 +0000
committerKris Kennaway <kris@FreeBSD.org>2005-07-20 23:37:32 +0000
commit437971c851484e26aa8bf8bc6d7115cef8b44f80 (patch)
tree8ada1f538315c4ed4967045781e27f56b6e14e56 /net/arping
parente00237763403cebd0ff6a8308e1ac6691e2528a0 (diff)
downloadports-437971c851484e26aa8bf8bc6d7115cef8b44f80.tar.gz
ports-437971c851484e26aa8bf8bc6d7115cef8b44f80.zip
BROKEN on 6.0: Does not compile
Notes
Notes: svn path=/head/; revision=139746
Diffstat (limited to 'net/arping')
-rw-r--r--net/arping/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/net/arping/Makefile b/net/arping/Makefile
index cf16ab061495..62bdd622a065 100644
--- a/net/arping/Makefile
+++ b/net/arping/Makefile
@@ -20,6 +20,12 @@ LDFLAGS+= -lpcap
MAN8= arping.8
PLIST_FILES= sbin/arping
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 600031
+BROKEN= "Does not compile on FreeBSD >= 6.0"
+.endif
+
do-build:
cd ${WRKSRC} && \
${CC} ${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib \
@@ -33,4 +39,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/arping ${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/arping.8 ${PREFIX}/man/man8
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>