aboutsummaryrefslogtreecommitdiff
path: root/net/arping
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-12-15 02:43:14 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-12-15 02:43:14 +0000
commitb09780bd2e10a1bece098aa746daaac0174f829f (patch)
tree63b8ee8fd65b9628c5427c7cda72e2c812bd5735 /net/arping
parent587c3942a60e6d12f191034613089702e8377843 (diff)
downloadports-b09780bd2e10a1bece098aa746daaac0174f829f.tar.gz
ports-b09780bd2e10a1bece098aa746daaac0174f829f.zip
- if net/libpcap from ports is install, net/arping bombs b/c of errors in pcap.h
fix this. Versions of this patch are committed upstream. - Bump PORTREVISION PR: ports/151263 Submitted by: Lucius Windschuh <lwindschuh@gmail.com> Approved by: maintainer timeout (gavin ; 67 days)
Notes
Notes: svn path=/head/; revision=266317
Diffstat (limited to 'net/arping')
-rw-r--r--net/arping/Makefile1
-rw-r--r--net/arping/files/patch-src__arping.c22
2 files changed, 23 insertions, 0 deletions
diff --git a/net/arping/Makefile b/net/arping/Makefile
index 5691a8eadf0a..a59180eb230f 100644
--- a/net/arping/Makefile
+++ b/net/arping/Makefile
@@ -7,6 +7,7 @@
PORTNAME= arping
PORTVERSION= 2.09
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.habets.pp.se/synscan/files/
diff --git a/net/arping/files/patch-src__arping.c b/net/arping/files/patch-src__arping.c
new file mode 100644
index 000000000000..6abada91f23d
--- /dev/null
+++ b/net/arping/files/patch-src__arping.c
@@ -0,0 +1,22 @@
+--- ./src/arping.c.orig 2010-12-15 02:40:26.572881702 +0000
++++ ./src/arping.c 2010-12-15 02:41:01.891883112 +0000
+@@ -75,15 +75,15 @@
+ #include <libnet.h>
+ #endif
+
++#if HAVE_NET_BPF_H
++#include <net/bpf.h>
++#endif
++
+ #if HAVE_WIN32_LIBNET_H
+ #include <win32/libnet.h>
+ #endif
+ #include <pcap.h>
+
+-#if HAVE_NET_BPF_H
+-#include <net/bpf.h>
+-#endif
+-
+ #ifndef ETH_ALEN
+ #define ETH_ALEN 6
+ #endif