aboutsummaryrefslogtreecommitdiff
path: root/net/arping
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
commiteb81a88093e7d71530eebb2957f8ba4317b26ee6 (patch)
tree9290c97700f22b8ed6b87a10fda7d195dac09f04 /net/arping
parente6b247dce1d9f6355a583ef6269fdbba110eaea8 (diff)
downloadports-eb81a88093e7d71530eebb2957f8ba4317b26ee6.tar.gz
ports-eb81a88093e7d71530eebb2957f8ba4317b26ee6.zip
- Patch net/libnet* to versioned libraries and header files, so they can
coexist PR: ports/103861 Submitted by: alepulver Tested by: pointyhat With hat: portmgr
Notes
Notes: svn path=/head/; revision=183770
Diffstat (limited to 'net/arping')
-rw-r--r--net/arping/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/net/arping/Makefile b/net/arping/Makefile
index 64c9f73f54cd..6d252be275c8 100644
--- a/net/arping/Makefile
+++ b/net/arping/Makefile
@@ -7,27 +7,30 @@
PORTNAME= arping
PORTVERSION= 2.05
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.habets.pp.se/pub/synscan/
MAINTAINER= gavin.atkinson@ury.york.ac.uk
COMMENT= ARP level "ping" utility
-BUILD_DEPENDS= libnet*<=1.1.0,1:${PORTSDIR}/net/libnet10
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
LDFLAGS+= -lpcap
MAN8= arping.8
PLIST_FILES= sbin/arping
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
+
do-build:
cd ${WRKSRC} && \
${CC} ${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib \
- -DUSE_NETIF=1 -DFREEBSD=1 -c `libnet-config --defines` \
- `libnet-config --cflags` ${PORTNAME}.c && \
+ -DUSE_NETIF=1 -DFREEBSD=1 -c `${LIBNET_CONFIG} --defines` \
+ `${LIBNET_CONFIG} --cflags` ${PORTNAME}.c && \
${CC} ${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib \
-DUSE_NETIF=1 -DFREEBSD=1 -o ${PORTNAME} ${PORTNAME}.o \
- `libnet-config --libs` ${LDFLAGS}
+ `${LIBNET_CONFIG} --libs` ${LDFLAGS}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/arping ${PREFIX}/sbin