aboutsummaryrefslogtreecommitdiff
path: root/net/asio
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-01-31 04:43:28 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-01-31 04:43:28 +0000
commit9b80051284979dee204df3e9a6f46e11a93440b5 (patch)
tree08502b01b13d8b347b98a8fa7443ae570f799629 /net/asio
parentac2ed40088ac8cc548b77b15e4e8b8fcdc75541b (diff)
downloadports-9b80051284979dee204df3e9a6f46e11a93440b5.tar.gz
ports-9b80051284979dee204df3e9a6f46e11a93440b5.zip
net/asio: Added NO_ARCH=yes; Removed USES=gmake; Regenerated patches; Sorted the USES section
PR: 224578 Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D13805
Notes
Notes: svn path=/head/; revision=460459
Diffstat (limited to 'net/asio')
-rw-r--r--net/asio/Makefile3
-rw-r--r--net/asio/files/patch-configure8
-rw-r--r--net/asio/files/patch-include_asio_ssl_impl_context.ipp7
3 files changed, 10 insertions, 8 deletions
diff --git a/net/asio/Makefile b/net/asio/Makefile
index 8c48480822f8..1574cf6888c7 100644
--- a/net/asio/Makefile
+++ b/net/asio/Makefile
@@ -15,9 +15,10 @@ LICENSE_FILE= ${WRKSRC}/LICENSE_1_0.txt
RUN_DEPENDS= ${LOCALBASE}/include/boost/chrono/system_clocks.hpp:devel/boost-libs
+USES= tar:bz2
GNU_CONFIGURE= yes
-USES= gmake tar:bz2
NO_BUILD= yes
+NO_ARCH= yes
INSTALL_TARGET= install-data
.include <bsd.port.mk>
diff --git a/net/asio/files/patch-configure b/net/asio/files/patch-configure
index a5e1adc7369a..50ec7c63f18d 100644
--- a/net/asio/files/patch-configure
+++ b/net/asio/files/patch-configure
@@ -1,9 +1,11 @@
Since we aren't compiling anything for the port, don't look for boost:
---- configure 2014-10-01 20:10:53.000000000 -0400
-+++ configure 2014-11-30 12:32:04.000000000 -0500
-@@ -5026,5 +5026,4 @@
+--- configure.orig 2015-03-23 20:37:48 UTC
++++ configure
+@@ -5025,7 +5025,6 @@ else
+
echo "Can't find boost headers. Please check the location of the boost"
echo "distribution and rerun configure using the --with-boost=DIR option."
- exit 1
fi
+
diff --git a/net/asio/files/patch-include_asio_ssl_impl_context.ipp b/net/asio/files/patch-include_asio_ssl_impl_context.ipp
index 20832a35c47a..ce03ebedb355 100644
--- a/net/asio/files/patch-include_asio_ssl_impl_context.ipp
+++ b/net/asio/files/patch-include_asio_ssl_impl_context.ipp
@@ -1,21 +1,20 @@
--- include/asio/ssl/impl/context.ipp.orig 2015-03-23 20:28:30 UTC
+++ include/asio/ssl/impl/context.ipp
-@@ -88,7 +88,15 @@ context::context(context::method m)
+@@ -88,6 +88,14 @@ context::context(context::method m)
handle_ = ::SSL_CTX_new(::SSLv2_server_method());
break;
#endif // defined(OPENSSL_NO_SSL2)
+#if defined(OPENSSL_NO_SSL3)
- case context::sslv3:
++ case context::sslv3:
+ case context::sslv3_client:
+ case context::sslv3_server:
+ asio::detail::throw_error(
+ asio::error::invalid_argument, "context");
+ break;
+#else // defined(OPENSSL_NO_SSL3)
-+ case context::sslv3:
+ case context::sslv3:
handle_ = ::SSL_CTX_new(::SSLv3_method());
break;
- case context::sslv3_client:
@@ -97,6 +105,7 @@ context::context(context::method m)
case context::sslv3_server:
handle_ = ::SSL_CTX_new(::SSLv3_server_method());