aboutsummaryrefslogtreecommitdiff
path: root/net/aslookup
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-11-10 01:09:21 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-11-10 01:09:21 +0000
commitf64d11f210e661f337e28315a272506857e8a7b9 (patch)
tree76f4b9af7deaf17a98b269a6fd8d08ea96a1e3db /net/aslookup
parentad09954ad70f3eef7333fed1c4099b17c405f6f8 (diff)
downloadports-f64d11f210e661f337e28315a272506857e8a7b9.tar.gz
ports-f64d11f210e661f337e28315a272506857e8a7b9.zip
Spelling corrections to program
Bump PORTREVISION Add SHA256 Use DOCSDIR macro Respect CFLAGS and CC PR: 88614 Submitted by: Ted Mittelstaedt <tedm@toybox.placo.com> Approved by: maintainer
Notes
Notes: svn path=/head/; revision=147770
Diffstat (limited to 'net/aslookup')
-rw-r--r--net/aslookup/Makefile9
-rw-r--r--net/aslookup/distinfo1
-rw-r--r--net/aslookup/files/patch-Makefile30
-rw-r--r--net/aslookup/files/patch-aslookup.c56
-rw-r--r--net/aslookup/pkg-plist6
5 files changed, 79 insertions, 23 deletions
diff --git a/net/aslookup/Makefile b/net/aslookup/Makefile
index 8dcb4ee8dcd2..14a38c08ff25 100644
--- a/net/aslookup/Makefile
+++ b/net/aslookup/Makefile
@@ -7,13 +7,20 @@
PORTNAME= aslookup
PORTVERSION= 0.12
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.bugest.net/software/aslookup/
-DISTNAME= aslookup-alpha${PORTVERSION}
+DISTNAME= ${PORTNAME}-alpha${PORTVERSION}
MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= Tool that searches the sequence of AS numbers
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -E -e "s|CFLAGS.*=|CFLAGS +=|" \
+ -e "s|CC.*=|CC ?=|" ${WRKSRC}/Makefile
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/aslookup ${PREFIX}/bin
.if !defined(NOPORTDOCS)
diff --git a/net/aslookup/distinfo b/net/aslookup/distinfo
index 49ef242cccca..878621d4ef81 100644
--- a/net/aslookup/distinfo
+++ b/net/aslookup/distinfo
@@ -1,2 +1,3 @@
MD5 (aslookup-alpha0.12.tar.gz) = 0e52b29f5841094a53e0cc6e50ffe098
+SHA256 (aslookup-alpha0.12.tar.gz) = b5bbbf48dad6f2133078b060dae59afc12ee82ff326088458c5953f2a476c3d6
SIZE (aslookup-alpha0.12.tar.gz) = 12979
diff --git a/net/aslookup/files/patch-Makefile b/net/aslookup/files/patch-Makefile
index ead86a4d30fd..26a1caf5365a 100644
--- a/net/aslookup/files/patch-Makefile
+++ b/net/aslookup/files/patch-Makefile
@@ -1,19 +1,11 @@
-*** Makefile.orig Wed May 29 23:12:11 2002
---- Makefile Wed May 29 23:12:38 2002
-***************
-*** 34,40 ****
- # CFLAGS = -DJPIXDB -DJPNICDB -DAPNICDB
- # CFLAGS = -DRALOCAL -DJPNICDB -DAPNICDB
- # CFLAGS = -DJPNICDB -DAPNICDB -DLOG -DSOLARIS
-! CFLAGS = -DARINDB -DJPNICDB -DAPNICDB -DLOG -DDEBUG
- INCDIR = -I./
-
- # This line is for solaris.
---- 34,40 ----
- # CFLAGS = -DJPIXDB -DJPNICDB -DAPNICDB
- # CFLAGS = -DRALOCAL -DJPNICDB -DAPNICDB
- # CFLAGS = -DJPNICDB -DAPNICDB -DLOG -DSOLARIS
-! CFLAGS = -DARINDB -DJPNICDB -DAPNICDB
- INCDIR = -I./
-
- # This line is for solaris.
+--- ./Makefile.orig Wed Apr 5 05:36:20 2000
++++ ./Makefile Wed Nov 9 22:52:32 2005
+@@ -34,7 +34,7 @@
+ # CFLAGS = -DJPIXDB -DJPNICDB -DAPNICDB
+ # CFLAGS = -DRALOCAL -DJPNICDB -DAPNICDB
+ # CFLAGS = -DJPNICDB -DAPNICDB -DLOG -DSOLARIS
+-CFLAGS = -DARINDB -DJPNICDB -DAPNICDB -DLOG -DDEBUG
++CFLAGS = -DARINDB -DJPNICDB -DAPNICDB
+ INCDIR = -I./
+
+ # This line is for solaris.
diff --git a/net/aslookup/files/patch-aslookup.c b/net/aslookup/files/patch-aslookup.c
new file mode 100644
index 000000000000..b594d27a4ec8
--- /dev/null
+++ b/net/aslookup/files/patch-aslookup.c
@@ -0,0 +1,56 @@
+--- ./aslookup.c.orig Wed Apr 5 05:35:56 2000
++++ ./aslookup.c Wed Nov 9 22:53:13 2005
+@@ -249,7 +249,7 @@
+ break;
+ case 'C':
+ #ifdef DEBUG
+- printf("Compleate\n");
++ printf("Complete\n");
+ #endif
+ stop = 1;
+ break;
+@@ -936,7 +936,7 @@
+
+ if (strncmp(&line[3], " ", 7) == 0) {
+ #ifdef DEBUG
+- printf("Old Data Concatinate\n");
++ printf("Old Data Concatenate\n");
+ #endif
+ bzero(buf,40);
+ strncpy(buf, pathcache.data, 3);
+@@ -952,7 +952,7 @@
+ printf("%s:\n",pathcache.data);
+ searchas(pathcache.pathstr);
+ } else {
+- printf("%s: Dplicated AS Path\n",pathcache.data);
++ printf("%s: Duplicated AS Path\n",pathcache.data);
+ }
+ }
+ freecache();
+@@ -987,7 +987,7 @@
+
+ if (strncmp(&line[3], " ", 7) == 0) {
+ #ifdef DEBUG
+- printf("Old Data Concatinate: %s\n",olddata);
++ printf("Old Data Concatenate: %s\n",olddata);
+ #endif
+ if (strlen(olddata) > 0) {
+ bzero(buf,40);
+@@ -1007,7 +1007,7 @@
+ printf("%s:\n",pathcache.data);
+ searchas(pathcache.pathstr);
+ } else {
+- printf("%s: Dplicated AS Path\n",pathcache.data);
++ printf("%s: Duplicated AS Path\n",pathcache.data);
+ }
+ }
+ fclose(fp);
+@@ -1034,7 +1034,7 @@
+ if (a == 0) {
+ hp = gethostbyname(hn);
+ if (hp == NULL) {
+- printf("Could not resolv : %s\n",hn);
++ printf("Could not resolve : %s\n",hn);
+ return(1);
+ }
+ bzero(&sin, sizeof(struct sockaddr_in));
diff --git a/net/aslookup/pkg-plist b/net/aslookup/pkg-plist
index a66e438a0240..ba3a57e1884e 100644
--- a/net/aslookup/pkg-plist
+++ b/net/aslookup/pkg-plist
@@ -1,4 +1,4 @@
bin/aslookup
-%%PORTDOCS%%share/doc/aslookup/readme-eng.txt
-%%PORTDOCS%%share/doc/aslookup/readme-jp.txt
-%%PORTDOCS%%@dirrm share/doc/aslookup
+%%PORTDOCS%%%%DOCSDIR%%/readme-eng.txt
+%%PORTDOCS%%%%DOCSDIR%%/readme-jp.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%