aboutsummaryrefslogtreecommitdiff
path: root/net/avahi-app
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-07-14 21:17:21 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-07-14 21:17:21 +0000
commitbfa3958c83312f4c1cd3aa72db2f2d932648ba99 (patch)
tree045532534e1db412f1f596cdc2d983f42e70441a /net/avahi-app
parent9b087dd60f7fe2952b34f2fe25ae98ff2e6d54b9 (diff)
downloadports-bfa3958c83312f4c1cd3aa72db2f2d932648ba99.tar.gz
ports-bfa3958c83312f4c1cd3aa72db2f2d932648ba99.zip
Notes
Diffstat (limited to 'net/avahi-app')
-rw-r--r--net/avahi-app/Makefile60
-rw-r--r--net/avahi-app/distinfo4
-rw-r--r--net/avahi-app/files/patch-avahi-daemon_Makefile.in16
-rw-r--r--net/avahi-app/files/patch-avahi-utils_Makefile.in14
-rw-r--r--net/avahi-app/files/patch-check_nss.c15
5 files changed, 45 insertions, 64 deletions
diff --git a/net/avahi-app/Makefile b/net/avahi-app/Makefile
index 6388ea8012f6..1dafbf2b4eeb 100644
--- a/net/avahi-app/Makefile
+++ b/net/avahi-app/Makefile
@@ -1,14 +1,10 @@
-# New ports collection makefile for: avahi
-# Date created: 18 November 2005
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/net/avahi-app/Makefile,v 1.17 2011/03/13 17:23:19 kwm Exp $
-#
+# $MCom: ports/net/avahi-app/Makefile,v 1.25 2012/09/01 23:02:11 mezz Exp $
PORTNAME= avahi
-PORTVERSION= 0.6.29
-PORTREVISION?= 3
+PORTVERSION= 0.6.31
+PORTREVISION?= 0
CATEGORIES?= net dns
MASTER_SITES= http://www.avahi.org/download/
PKGNAMESUFFIX?= -app
@@ -16,36 +12,36 @@ PKGNAMESUFFIX?= -app
MAINTAINER?= gnome@FreeBSD.org
COMMENT?= Service discovery on a local network
+AVAHI_SLAVE?= no
+
+.if ${AVAHI_SLAVE} != header
BUILD_DEPENDS?= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
-LIB_DEPENDS?= expat.6:${PORTSDIR}/textproc/expat2 \
+LIB_DEPENDS?= expat:${PORTSDIR}/textproc/expat2 \
daemon.0:${PORTSDIR}/devel/libdaemon \
- dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- gdbm.4:${PORTSDIR}/databases/gdbm
+ dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
+ gdbm:${PORTSDIR}/databases/gdbm
RUN_DEPENDS?= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
USERS?= ${PORTNAME}
GROUPS?= ${USERS}
-USE_GNOME?= gnomehack ltverhack glib20 intltool
-USES= gettext
+USE_GNOME= ltverhack glib20 intltool
+USES= gettext gmake pathfix
USE_GNOME_SUBR= yes
-USE_GMAKE= yes
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
-AVAHI_SLAVE?= no
CONFIGURE_ARGS?=--with-distro=freebsd \
--with-dbus-system-socket=unix:path=/var/run/dbus/system_bus_socket \
--disable-monodoc \
--disable-doxygen-doc \
--disable-doxygen-dot \
+ --disable-qt3 \
--localstatedir=/var \
--enable-compat-howl
-CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- PTHREAD_LIBS="${PTHREAD_LIBS}"
CPPFLAGS+= -I${LOCALBASE}/include -DHAVE_KQUEUE
LDFLAGS+= -L${LOCALBASE}/lib
-.if ${AVAHI_SLAVE}=="no"
+.if ${AVAHI_SLAVE} == no
CONFLICTS= howl-[0-9]*
MAN1= avahi-browse.1 avahi-publish.1 avahi-resolve.1 avahi-set-host-name.1
@@ -62,47 +58,44 @@ DAEMON_CONFIG_FILES= hosts avahi-daemon.conf
.endif
USE_RC_SUBR=yes
+.endif # !avahi-header
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if ${AVAHI_SLAVE}=="autoipd"
+.if ${AVAHI_SLAVE} != header
+.if ${AVAHI_SLAVE} == autoipd
CONFIGURE_ARGS+=--enable-autoipd
.else
CONFIGURE_ARGS+=--disable-autoipd
.endif
-.if ${AVAHI_SLAVE}=="gtk"
+.if ${AVAHI_SLAVE} == gtk
CONFIGURE_ARGS+=--enable-gtk
.else
CONFIGURE_ARGS+=--disable-gtk
.endif
-.if ${AVAHI_SLAVE}=="gtk3"
+.if ${AVAHI_SLAVE} == gtk3
CONFIGURE_ARGS+=--enable-gtk3
.else
CONFIGURE_ARGS+=--disable-gtk3
.endif
-.if ${AVAHI_SLAVE}=="libdns"
+.if ${AVAHI_SLAVE} == libdns
CONFIGURE_ARGS+=--enable-compat-libdns_sd
.else
CONFIGURE_ARGS+=--disable-compat-libdns_sd
.endif
-.if ${AVAHI_SLAVE}=="python"
+.if ${AVAHI_SLAVE} == python
CONFIGURE_ARGS+=--enable-python
.else
CONFIGURE_ARGS+=--disable-python
.endif
-.if ${AVAHI_SLAVE}=="qt3"
-CONFIGURE_ARGS+=--enable-qt3
-.else
-CONFIGURE_ARGS+=--disable-qt3
-.endif
-.if ${AVAHI_SLAVE}=="qt4"
+.if ${AVAHI_SLAVE} == qt4
CONFIGURE_ARGS+=--enable-qt4 \
--disable-expat \
--disable-gdbm
.else
CONFIGURE_ARGS+=--disable-qt4
.endif
-.if ${AVAHI_SLAVE}=="sharp"
+.if ${AVAHI_SLAVE} == sharp
CONFIGURE_ARGS+=--enable-mono
.else
CONFIGURE_ARGS+=--disable-mono
@@ -132,6 +125,8 @@ avahi-post-patch:
${WRKSRC}/avahi-daemon/dbus-protocol.c
@${REINPLACE_CMD} -e 's|^_||g' \
${WRKSRC}/avahi-ui/*.desktop.in.in
+ @${REINPLACE_CMD} -e 's|am: install-avahiincludeHEADERS|am:|g' \
+ ${WRKSRC}/avahi-ui/Makefile.in
post-build: avahi-post-build
@@ -173,5 +168,6 @@ avahi-post-install:
${INSTALL_DATA} ${FILESDIR}/org.freedesktop.Avahi.service \
${LOCALBASE}/share/dbus-1/system-services
.endif
+.endif # avahi-header
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/avahi-app/distinfo b/net/avahi-app/distinfo
index e0264b34bb6a..c476c7bd638f 100644
--- a/net/avahi-app/distinfo
+++ b/net/avahi-app/distinfo
@@ -1,2 +1,2 @@
-SHA256 (avahi-0.6.29.tar.gz) = 4eb1a6bdc93f1b245fc1b26ff6a79f5f958c1135c04bff60d36d374d98cc14d8
-SIZE (avahi-0.6.29.tar.gz) = 1244081
+SHA256 (avahi-0.6.31.tar.gz) = 8372719b24e2dd75de6f59bb1315e600db4fd092805bd1201ed0cb651a2dab48
+SIZE (avahi-0.6.31.tar.gz) = 1268686
diff --git a/net/avahi-app/files/patch-avahi-daemon_Makefile.in b/net/avahi-app/files/patch-avahi-daemon_Makefile.in
index 7f36a6f25df9..5f08d07c1387 100644
--- a/net/avahi-app/files/patch-avahi-daemon_Makefile.in
+++ b/net/avahi-app/files/patch-avahi-daemon_Makefile.in
@@ -1,5 +1,5 @@
---- avahi-daemon/Makefile.in.orig 2013-01-01 13:29:10.000000000 -0600
-+++ avahi-daemon/Makefile.in 2013-01-01 13:31:10.000000000 -0600
+--- avahi-daemon/Makefile.in.orig 2013-01-01 13:45:35.000000000 -0600
++++ avahi-daemon/Makefile.in 2013-01-01 13:47:30.000000000 -0600
@@ -69,7 +69,7 @@
@ENABLE_CHROOT_TRUE@@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@ caps.c caps.h
@@ -9,18 +9,18 @@
@HAVE_DBUS_TRUE@@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@am__append_5 = \
@HAVE_DBUS_TRUE@@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@ dbus-protocol.c dbus-protocol.h \
@HAVE_DBUS_TRUE@@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@ dbus-util.c dbus-util.h \
-@@ -682,7 +682,7 @@
+@@ -688,7 +688,7 @@
rm -f $$list
- avahi-daemon$(EXEEXT): $(avahi_daemon_OBJECTS) $(avahi_daemon_DEPENDENCIES)
+ avahi-daemon$(EXEEXT): $(avahi_daemon_OBJECTS) $(avahi_daemon_DEPENDENCIES) $(EXTRA_avahi_daemon_DEPENDENCIES)
@rm -f avahi-daemon$(EXEEXT)
- $(AM_V_CCLD)$(avahi_daemon_LINK) $(avahi_daemon_OBJECTS) $(avahi_daemon_LDADD) $(LIBS)
+ $(AM_V_CCLD)$(avahi_daemon_LINK) $(avahi_daemon_OBJECTS) $(avahi_daemon_LDADD) $(LIBS) $(INTLLIBS)
- ini-file-parser-test$(EXEEXT): $(ini_file_parser_test_OBJECTS) $(ini_file_parser_test_DEPENDENCIES)
+ ini-file-parser-test$(EXEEXT): $(ini_file_parser_test_OBJECTS) $(ini_file_parser_test_DEPENDENCIES) $(EXTRA_ini_file_parser_test_DEPENDENCIES)
@rm -f ini-file-parser-test$(EXEEXT)
$(AM_V_CCLD)$(ini_file_parser_test_LINK) $(ini_file_parser_test_OBJECTS) $(ini_file_parser_test_LDADD) $(LIBS)
-@@ -1283,17 +1283,17 @@
- echo " ( cd '$(DESTDIR)$(servicedir)' && rm -f" $$files ")"; \
- cd "$(DESTDIR)$(servicedir)" && rm -f $$files
+@@ -1222,17 +1222,17 @@
+ files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
+ dir='$(DESTDIR)$(servicedir)'; $(am__uninstall_files_from_dir)
install-pkgsysconfDATA: $(pkgsysconf_DATA)
- @$(NORMAL_INSTALL)
- test -z "$(pkgsysconfdir)" || $(MKDIR_P) "$(DESTDIR)$(pkgsysconfdir)"
diff --git a/net/avahi-app/files/patch-avahi-utils_Makefile.in b/net/avahi-app/files/patch-avahi-utils_Makefile.in
index 90bc06015bf6..49b05ea3cf29 100644
--- a/net/avahi-app/files/patch-avahi-utils_Makefile.in
+++ b/net/avahi-app/files/patch-avahi-utils_Makefile.in
@@ -1,20 +1,20 @@
---- avahi-utils/Makefile.in.orig 2010-07-24 19:59:10.000000000 -0400
-+++ avahi-utils/Makefile.in 2010-07-24 20:00:07.000000000 -0400
-@@ -513,16 +513,16 @@ clean-binPROGRAMS:
+--- avahi-utils/Makefile.in.orig 2012-07-09 20:07:19.000000000 +0200
++++ avahi-utils/Makefile.in 2012-07-09 20:10:46.000000000 +0200
+@@ -518,16 +518,16 @@
rm -f $$list
- avahi-browse$(EXEEXT): $(avahi_browse_OBJECTS) $(avahi_browse_DEPENDENCIES)
+ avahi-browse$(EXEEXT): $(avahi_browse_OBJECTS) $(avahi_browse_DEPENDENCIES) $(EXTRA_avahi_browse_DEPENDENCIES)
@rm -f avahi-browse$(EXEEXT)
- $(AM_V_CCLD)$(avahi_browse_LINK) $(avahi_browse_OBJECTS) $(avahi_browse_LDADD) $(LIBS)
+ $(AM_V_CCLD)$(avahi_browse_LINK) $(avahi_browse_OBJECTS) $(avahi_browse_LDADD) $(LIBS) $(INTLLIBS)
- avahi-publish$(EXEEXT): $(avahi_publish_OBJECTS) $(avahi_publish_DEPENDENCIES)
+ avahi-publish$(EXEEXT): $(avahi_publish_OBJECTS) $(avahi_publish_DEPENDENCIES) $(EXTRA_avahi_publish_DEPENDENCIES)
@rm -f avahi-publish$(EXEEXT)
- $(AM_V_CCLD)$(avahi_publish_LINK) $(avahi_publish_OBJECTS) $(avahi_publish_LDADD) $(LIBS)
+ $(AM_V_CCLD)$(avahi_publish_LINK) $(avahi_publish_OBJECTS) $(avahi_publish_LDADD) $(LIBS) $(INTLLIBS)
- avahi-resolve$(EXEEXT): $(avahi_resolve_OBJECTS) $(avahi_resolve_DEPENDENCIES)
+ avahi-resolve$(EXEEXT): $(avahi_resolve_OBJECTS) $(avahi_resolve_DEPENDENCIES) $(EXTRA_avahi_resolve_DEPENDENCIES)
@rm -f avahi-resolve$(EXEEXT)
- $(AM_V_CCLD)$(avahi_resolve_LINK) $(avahi_resolve_OBJECTS) $(avahi_resolve_LDADD) $(LIBS)
+ $(AM_V_CCLD)$(avahi_resolve_LINK) $(avahi_resolve_OBJECTS) $(avahi_resolve_LDADD) $(LIBS) $(INTLLIBS)
- avahi-set-host-name$(EXEEXT): $(avahi_set_host_name_OBJECTS) $(avahi_set_host_name_DEPENDENCIES)
+ avahi-set-host-name$(EXEEXT): $(avahi_set_host_name_OBJECTS) $(avahi_set_host_name_DEPENDENCIES) $(EXTRA_avahi_set_host_name_DEPENDENCIES)
@rm -f avahi-set-host-name$(EXEEXT)
- $(AM_V_CCLD)$(avahi_set_host_name_LINK) $(avahi_set_host_name_OBJECTS) $(avahi_set_host_name_LDADD) $(LIBS)
+ $(AM_V_CCLD)$(avahi_set_host_name_LINK) $(avahi_set_host_name_OBJECTS) $(avahi_set_host_name_LDADD) $(LIBS) $(INTLLIBS)
diff --git a/net/avahi-app/files/patch-check_nss.c b/net/avahi-app/files/patch-check_nss.c
deleted file mode 100644
index 3f1360d83dbc..000000000000
--- a/net/avahi-app/files/patch-check_nss.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- avahi-client/check-nss.c.orig 2010-06-29 12:30:33.000000000 +0900
-+++ avahi-client/check-nss.c 2012-03-13 14:32:57.000000000 +0900
-@@ -33,9 +33,9 @@
-
- #ifdef HAVE_DLOPEN
- static const char * const libs[] = {
-- "libnss_mdns.so.2",
-- "libnss_mdns4.so.2",
-- "libnss_mdns6.so.2",
-+ "nss_mdns.so",
-+ "nss_mdns4.so",
-+ "nss_mdns6.so",
- NULL };
-
- const char * const *l;